Chapter 1: Introduction
An Introduction to Aura
Aura is a powerful painting, animation and video
layering system that supports most major still image
and animation file formats, including NewTek’s D1
RTV and FLYER CLIP, as well as QuickTime®, AVI,
Photoshop®, BMP, GIF, JPEG, PNG, TIFF, and many
more. Aura includes an arsenal of industry standard
video and image processing tools, natural media
brushes, and fully animated/video brush operations—
you can literally paint with and onto video! Aura
enhances any non-linear editing system, paint system, character generation program, or even 3D animation application.

With Aura’s system of unlimited layering and support for multiple projects, you can easily position
keys, 3D animations, video elements, painted layers
and effects. Aura can manage layer transparency at a
pixel level! Aura can be used as a powerful compositing tool and the time-line-based layers feature is perfect for rotoscoping.
When playing back animations/video, you have
absolute control over playback rates. Keyframe tools
can position and rotate any element in 3D space.
Time stretching interpolation options make elements
fit into defined time slots.

Animators will love the light table (onion skin) feature that allows you to see action in preceding and
subsequent frames. The light table makes Aura ideal
as a pencil test system for traditional animators. Aura
even supports Wacom-compatible pressure sensitive
drawing tablets.
Web graphic artists have waited for a tool like Aura
to come along. With Aura’s animation abilities, you
can create stunning animated graphics and save
them directly as Web standard animated GIFs.
Aura’s plug-in architecture enables users to add
new filters and features as external modules. You can
even apply the effects of most filters over time, with
different settings at different frames! Aura is also
compatible with many Adobe® Photoshop® plug-in
filters.
Aura features George, a rich macro programming
language that can automate many tasks normally
handled through the interface.
Aura provides direct access to TWAIN® devices
such as scanners.
Aura is multi-threaded and automatically senses
multiple processors in a system. Many operations,
particularly filters, will function much faster in a multiprocessor system.
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TYPOGRAPHIC CONVENTIONS
The folllowing conventions are used throughout
this manual.

Directory Structure
Except for a few system files, all of the software is
installed in a subdirectory called AURA found inside
your main VT[3] folder. Unless otherwise specified,
subdirectories referred to in this manual are found in
the main AURA folder. (For example, if the discussion
refers to the Images folder, the actual path might be
C:\VT[3]\AURA\IMAGES.)

Typefaces
ALL CAPS

Bold

Computer keys, directories, device
names (e.g., Enter, C:\Aura,
Control+P, etc.).
Names of menus, commands,
requesters, fields, buttons, etc., are
set in bold type.

Keystroke Combinations
Key1 + Key2

Simultaneous keystrokes. Hold the
first key and press the second key.

Mouse Operations
LMB
RMB
Selecting

Left mouse button
Right mouse button
To single-click an item with the LMB
to activate or select the item.
Deselecting
To single-click an item with the LMB
to deactivate or deselect the item.
Activate to select an option by click
ing on its toggle button.
Deactivate
To deselect an option by clicking on
its toggle button.
Clicking
To place your mouse pointer over an
item and then press a mouse button.
Clicking usually refers to the LMB.
Right-click
To click an item using your RMB.
Double-clicking To rapidly click an item twice.
Dragging
To select an item with your mouse
pointer and continue holding the
mouse button down as you move
your mouse. Dragging usually refers
to the LMB.
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ATTENTI-CON
WARNING The warning symbol highlights a
discussion that warns the user about something. Pay special attention to text marked
with this symbol.
NOTE The note symbol highlights a discussion that is particularly noteworthy.
HINT The tip symbol highlights time-saving
tips and suggestions.

SOME GENERAL CONCEPTS
The reference manual offers a detailed description
of the various icons, tools, menus and functions available in Aura. It is designed to provide quick access to
the information you need.

Mouse and Graphic Tablet
You perform all drawing operations with the mouse
or a digitizing tablet stylus. These two tools complement each other. You should typically use the mouse
to draw rectangles or straight lines. However, for
sketching, the digitizing tablet offers incomparable
flexibility. Furthermore, the mouse is like an On/Off
switch: either you draw something or you don’t. The
tablet is sensitive to the pressure exerted on the stylus, allowing you to control the amount of digital ink
applied to your work of art.
NOTE The term mouse in the text can apply
to either the mouse or digitizing tablet stylus if
in use.
NOTE If you are using a Wacom Intuos
tablet, its Tools ID feature allows Aura to
remember the drawing tool and mode last
used for each pen.

Left and Right Buttons
The left mouse button is equivalent to the stylus
tip, while the right mouse button is equivalent to the
stylus tip with its button pressed. If the stylus you use
has no button, you can press the SHIFT key instead.
This method also works for a stylus that has a button.
Often when you right-click a tool or icon, Aura
shows its available options, so you should try rightclicking your tools to find shortcuts.

Brushes
You create images in Aura using brushes and
drawing functions (freehand lines, straight lines, circles, etc.). Aura offers two basic types of brushes:
built-in brushes and custom brushes. Custom brushes are basically images you can draw with; these can
be as simple as a small oval or they can be large fullcolor images, including video and animations.

(e.g., the filled and non-filled drawing functions). In
such cases, click on the icon once to access the first
function and again to access the next function. The
icon changes after each click
Some functions have a settings panel that you
access by clicking the icon with the right mouse button.

Pop-up Menus
You can identify pop-up menus by a button that
contains a small arrow pointing downwards.

A and B Colors
Two colors are always displayed on the color
selector button on the Main panel. The center color is
the A Color and the surrounding color is the B Color.
The A Color is your main drawing color. The B Color
is used only when a particular function requires a
second color.

Sometimes, you see just a button with an arrow;
when you click on this type of button, Aura displays a
list of options. Drag the mouse pointer to highlight the
desired option and then release the mouse button.
The chosen menu item usually appears on the button. To avoid selecting an item, move the mouse
pointer off the menu before releasing the mouse button.

A and B Colors Picker
HINT Use the Color: Invert A/B command,
mapped to the n key, to swap the two colors.
See the Working With Colors chapter for information on selecting colors.

Selecting Functions
When you click an icon, generally you select that
function; however, somicons have multiple functions

Example of Pop up menu

FreehandLine

FreehandLine Filled
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Text and Numeric Input Fields

Sliders

You enter text or a value in the text and numeric
input fields. Click in a field to modify its contents. A
cursor appears and then you can type the new contents using the standard edit functions for your computer.

You can use Sliders to pan an area, scroll through
a list and set values. Sliders can be oriented vertically
or horizontally. The position of the slider indicates
which section of a list/area is visible or the set value.
Clicking on either side of the slider with your LMB
moves it by some increment. Using your RMB makes
the slider jump to your mouse pointer position. Some
sliders also have two arrow buttons that allow you to
move in small increments in the arrow’s direction.

All input fields offer a pop-up menu, which is available when you click the RMB over the field. The available commands are Undo (CTRL+Z), Cut (CTRL+X),
Copy (CTRL+C), Paste (CTRL+V), and Delete.
(These operations work on the entire field.) You
can also press SHIFT+DEL to delete everything in
front of the cursor or SHIFT+BACKSPACE to delete
everything behind the cursor.

Right click the input field for pop up menu

Mini-slider Buttons
Numeric fields feature a mini-slider button to the
right of the field. Dragging your mouse to the right
increases the value, while dragging to the left reduces
it. Releasing the mouse button accepts the new
value. The mini-slider button beside the Angle field
displays a compass to help you visualize the result of
a numeric selection.

Examples of sliders

Progress gauges
Many Aura operations display a progress gauge so
that you can monitor the status of the function. When
a progress gauge is displayed, you can abort the current operation by clicking the Stop button on the
gauge or pressing the ESC key.

Example of progress gauge
Above: mini-slider buttons. Below: Angle
compass.
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NOTE If you abort an operation, everything
done prior to the interruption will remain.
However, in some cases, you can then use
Undo to reverse this partial result.

STARTING AURA
Aura VT is launched from the main VT[3]® menu.
You may alternatively run Aura from the Windows
Start menu, for use without the VT[3]. Unless you
have previously saved a different startup configuration, Aura launches in D1 NTSC video mode, ready
for use with your VT[3].

Default Configurations
The Configuration defines the current work environment, including the position of panels, tool settings, Project resolution and Frame Rate, etc. When
you quit Aura, you are offered the option to save the
current configuration. If you do so, the configuration
used at the next start-up will conform to the new
saved settings.

Configuring Project Properties
You can set various basic parameters (Width,
Height, etc.) for new projects or modify them for
open ones. To save these settings as the start-up
default settings, select Save this configuration when
you Exit Aura. When opening new projects or modifying open ones, you can quickly choose settings for
common resolutions ranging from VGA to film from
the pop-up menu. You can also enter a name for
your project in the input field to the right of the popup menu. This name will be the default filename when
you save the project. If you load a saved project,
Aura applies the settings from that project automatically.
NOTE VT[3] users should normally use the
D1 setting for their appropriate video standard (i.e., NTSC or PAL).
The Width and Height values set the resolution of
the project in pixels.

Project Frame Rate

NOTE AuraVT always opens using the last
saved configuration. To access a different preset configuration, you must either open a new
project using File > New Project, or use
Project > Modify Project to adjust the settings of
the current project.

The Frame Rate setting determines how many
frames per second your project should playback, if it
is a sequence. Use the pop-up menu to the right of
the input field to select from commonly used settings,
or enter a value directly into the field

The pop-up menu in the sections mentioned
above contains a list of pre-defined user configurations. If you use Aura frequently, or different users
have different preferences, you may want to set up
various configurations. You might create a configuration for drawing and another for touching up photos.

Changing Project Properties

NOTE The manual assumes you are using the
default settings.
NOTE Creating a new user configuration in
Aura VT requires you to modify a text file
found in the AURA\DATAS folder. The file
PAGESIZE.CONF defines the preset configurations available for ready use in the New and Modify
Project menu panels. It would be prudent to back up
the original file under another name before modifying
it. Be sure to save the modified file as a plain ASCII
text file.

You can alter these settings after your project is
open by choosing Project > Modify Project. If you
activate the Lock Aspect option, changes to either
the Width or Height fields will force a change of the
complementary resolution setting, maintaining a constant width to height ratio. You can also rotate your
project. In the Angle field, you set the rotation in
degrees. The new page size indicates the new project size after rotation.
NOTE The result of clicking the Keep and
Stretch buttons vary depending on the project parameter being modified.
NOTE If you need to stretch the resolution,
but keep a frame-rate change (or vice versa),
you must make each change separately via
the Modify Project panel.
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Resolution Changes
When modifying the project resolution, click on the
Keep Project button if you wish to retain the contents of the current project without stretching to fit
the resized page. In this case, Aura will crop the project images at the bottom and right margins when the
new project size is smaller than the existing project.
Aura leaves an empty area at the bottom and right if
the new size is larger.
Clicking the Stretch Project button instead scales
the contents of the current project to fit the resized
page. Aura enlarges or reduces project images to
occupy the entire new working page.

the project duration changes based on the new frame
rate. If the new rate is lower, project duration increases and Aura displays fewer frames per second. If the
new rate is higher, project duration decreases and
Aura displays more frames per second. For example,
if you change from 25 fps to 50 fps, you decrease
project duration by half. You need two seconds to
display 50 images at 25 fps, whereas you need only
one second at 50 fps.
When you click Stretch Project, the project duration remains the same. The number of frames
changes based on the new frame rate. If the new rate
is lower, the number of frames in the project decreases (fewer frames are needed for each second in the
project). If the new rate is higher, the number of
frames in the project increases (more frames are
needed for each second of project). For example, if
you change from 25 to 50 fps, you double the number of images in the project; you need 50 frames for
one second of display at 50 fps, but you need only
25 frames at 25 fps.
During time stretching operations, Aura adds missing frames or removes excess ones as necessary in
one of two ways. The method used depends on the
status of the Interpolation button.
Aura can provide a smooth change in frame rate
when Interpolation is selected. In this case, added
frames are interpolated between existing frames (or
neighboring frames may be merged when necessary)
by overlaying several frames with varying transparency. When Interpolation is not employed, layers are
stretched or shortened as required simply by copying
or deleting existing whole frames throughout the
duration of the project.
NOTE Once you choose Keep Project or
Stretch, you cannot undo the change.
You can change the starting frame/time code setting and mode by choosing Project > Start Frame
from the main menu. The drop-down menu beside
the entry field in the requester permits you to set the
value using either frame or timecode.

The Modify Project Panel

Frame Rate Changes
When you change the Frame Rate, clicking Keep
Project retains the existing number of frames, but

Aura VT 1.6

Starting frame/time code setting

Working with Video
A single video frame normally consists of two interlaced fields called the odd and even fields. Aura lets
you work independently with either field, preserving
valuable detail that is usually lost if the fields are
merged into a single image.
If you work with video, you should understand the
Field and Aspect Ratio settings. The Field setting
determines whether the Even field or the Odd field
comes first. (If you are not working with video fields,
set this parameter to None.) You also want to set
Start to Time Code. The even field is indicated on
the global timeline by a .0 appended to the time
code. The odd field uses .1. (e.g., 00:00:00:15.0,
00:00:00:15.1, 00:00:00:16.0, etc.)

Standard display

When you select Even or Odd, Aura displays an
even and an odd field for each frame along its timeline. If you choose Even, Aura creates the field of
even-numbered lines first (0, 2, 4, etc.) then it creates
the odd field (lines 1, 3, 5, etc.), for each frame. If you
use Odd First, Aura reverses the order in which fields
are created.
NOTE The field setting affects the order of the
fields when imagery is exported for use in a
video project. If you find exported sequences
flicker badly on your VT[3] video output, it’s
very likely the field order setting you are using in Aura
is incorrect.
Video projects are usually fielded when the project
calls for the addition of animated brushes. This
makes for smoother motions, and reduced flicker.
Otherwise, even when your project involves video but
does not require the addition of animated objects,
you may be able to save considerable time and system resources by not working in a fielded project
mode.
NOTE VideoToaster 2.0 uses Odd field first
for NTSC, while it uses Even first for PAL.
Video also does not use square pixels like most
computers do. Generally, video pixels are vertically
elongated. Therefore, a video image looks squashed
when you view it on your (square-pixel) PC monitor.
The Aspect Ratio settings let you view a video image
correctly on your PC monitor. The value is the height
to the width ratio of a pixel. An Aspect Ratio of 1.0
indicates square pixels. A ratio of 1.1 indicates the
pixel is 110 percent of the width (i.e., vertically elongated or tall).

Aspect Ratio display option active
NOTE The Aspect Ratio setting affects
only the display of your project and does not
impact underlying data. It is not possible to
actually modify the true aspect ratio of
imagery using this setting.

EXITING AURA
Select Quit from the File menu to exit from Aura.
A confirmation panel appears. Activate Save this
configuration? to save/update the current user configuration. This configuration will be used when you

The Quit Panel for exiting Aura
next start the program. Deactivate this option if you
do not want to save/update the configuration. If you
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don’t save your configuration, all user settings are lost
including keyboard shortcuts, temp directory settings,
Photoshop plug-in settings, and window positions.
The Leave and Stay buttons at the bottom of the
panel let you exit the program or abort the operation,
respectively.

THE AURA INTERFACE
Your project window is the large floating window
where you draw. The pull-down menu at the top of
the screen offers save and load options, edit functions, system settings, filters and your help settings.
The Menu panel, just below the menus, contains
shortcuts to common functions, panel display controls and editing state options. The Main panel contains icons that access the main functions.

NOTE When the Menu panel is docked at the
top of the screen, the icons are arranged horizontally. You can reposition the panel by
dragging the handle on the left edge.
If you have overlapping panels, you can bring a
panel to the front by clicking on its titlebar or on any
inactive area (a section that does not contain an icon,
button or field). You may also use the Depth button to
toggle an overlapped panel to the front or back. This
button is located on the right side of a panel’s titlebar
to the left of the close panel (X) button.
Some panels are resizable. They have a drag handle in their right-bottom corner, but can be sized by
dragging any edge or corner.

You can move any panel (including the Menu
panel) around the screen by dragging its title bar.
When you move a panel near the edges of other panels, panels will dock (i.e., tend to align) themselves;
docking can help you keep your work area neat and
tidy.
Menu Panel

Main Panel Tools Panel

Project Window

Layers Panel

Aura interface panels
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The Project Window Background
You draw and perform your image editing chores
in the project window. By default, the background
appears black, though it is actually transparent until
you paint on it. You can change the default color from
black if you wish, as discussed in Chapter 7.

The Project Window Controls
You can adjust the overall size of the project window by dragging any of the edges or corners. The
frame of the project window contains a number of
controls along the bottom and right edges.

ing the ALT key and dragging with the LMB directly in
the window.
The numeric keypad also allows you to move
around the screen. The 2 and 8 keys move vertically,
the 4 and 6 keys move horizontally, and the 1, 3, 7
and 9 keys move diagonally. The 5 key centers your
image.
NOTE You can access some of the project
window controls from the View menu.

Navigating
Choose Windows > Navigator Panel or click the
Navigator button on the menu panel and a small
panel appears.

Vertical Scroll controls

Aspect Ratio Display
One-to-one Zoom Factor
Fit to Project Window
Current Video input
Pan Project
Horizontal Scroll controls

Zoom controls

The project window’s lower border displays the
magnification ratio. You can change the magnification
using the various zoom controls. Use the + and - buttons to increase and decrease the magnification,
respectively. (You can also use the > and < keys or
ALT + RMB.) You can enter a magnification value
directly into the field.
Click the 1 (One-to-one Zoom Factor) button to
quickly display the image at 100%. Click the F (Fit to
Project Window) button to adjust magnification so
that you can view the entire image in the project window (Right-click on F to resize the project panel).
Click the V (Video Input) to display the VT[3] video
input in the project window. RMB opens the Video
Device settings panel, allowing you to select between
available sources.

Navigating the Aura interface

In this small panel, a red bounding box indicates
the area displayed on the current project window.
You can drag this box around with your LMB to pan
the contents of the window. Dragging in the window
with your RMB will scale the size of the bounding
box. Clicking the N button launches another project
window; this procedure is the same as choosing
View > New zoom window. The buttons on the
zoom window have the same effect as the identical
buttons on the project window.

NOTE See the previous discussion on
Working With Video for information on the
Aspect Ratio Display button.
When the image is larger than the project window,
you can use the scroll controls to navigate around.
Dragging directly on the Pan Project button pans the
image inside the window. You can also pan by hold-
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GENERAL OPERATION
FUNCTIONS
The Kill Function
The Kill function erases the current frame or selected frames of the current layer—respecting any selected areas. If you use the LMB, the image becomes
transparent. However, if you use the RMB, the image
fills with the B Color.
You can also choose Edit >Clear to clear theselected area.

you change the course of history in a fundamental
way and will not be able to get it back.
You can also access Undo and Redo from the
Edit menu.

The Re Apply Function
The Re Apply function should not be confused
with Redo. Re Apply redoes the last drawing operation using the current settings. This allows you to
repeat a step using, say, a different color or different
drawing tool. Simply undo the operation, change your
drawing options (e.g., select a new color) and then
press the ENTER key or choose Edit > Re Apply. The
shape is redrawn using the new options. You can
also use Re Apply on layers.

HELP MENU

The Kill or Clear function button

The Undo/Redo Functions

Aura features a help balloon system. When you let
the mouse pointer hover over an icon, button, text
field, or pop-up list, a pale yellow box appears that
provides information on the item’s function. You can
use the Help menu at the top left of the screen to
choose the type of help balloon that you want to see.
You can choose your preferred type of help bal-

The Undo function undoes the last modification
you made. This may be a drawn line, a filter application, merging of two layers, a change in the duration
or position of a layer, etc. The number of undo levels
is limited only by your memory resources. You set the
amount of memory allocated to undo on the Settings
panel, discussed in the next chapter.
Example of a Help balloon
NOTE Undo works mostly on drawing operations and each project has its own undo.
Some actions are not undoable, such as
Modify Project.

loons from the Help > Inline Help submenu. The Full
option, the default, displays the full amount of help
information and the Fast option displays an abbreviated version. Select None to disable this feature.

About Filters
The About Filters menu displays a list of the available plug-in filters installed for Aura. When you select
a list item, you launch a panel that displays various
information.

Undo and Redo buttons
The Redo function redoes operations that were
undone. As long as you have made no editing
changes, you can redo all the way back to the last
operation. Once you perform an operation, however,
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About Aura
The About Aura menu selection opens the Aura
information panel. The information on the panel
includes the program version, your registration information and credits. Click OK to close the panel.

Chapter 2:
File Management
and User Preferences
LOADING PROJECTS
Aura is a multi-document application, making it
possible to load and work on multiple projects at the
same time. You select the active project by clicking in
its project window or by choosing it from the
Windows menu.
NOTE You’ll need to click on the actual drawing area, not the title bar or window frame.
When you first run Aura, a blank project appears
using the last saved default configuration, as discussed in the prior chapter. If you wish to begin a
completely new project, choose File > New Project
or choose the New Project icon on the menu bar

near the top-left of the screen; the icon looks like a
blank paper with a folded corner. A panel appears
where you can set the new project’s properties.
If you wish to work on a previously saved project,
choose File > Load or choose the Open Project icon
on the menu bar near the top-left of the screen; this
icon looks like two file folders. In addition to loading
Aura project files (.aur), you can also load any of the
supported file formats to start a new project. When
you load an image or anim, Aura uses the image or
anim’s dimensions for the project size.
NOTE See the Appendix for a discussion of
supported file formats.

SAVING AND CLOSING
PROJECTS
A project consists of all layers and their settings.
When you save a project, Aura stores everything in a
single file. Aura maintains the order of the layers in
the list and their position on the time-line. The Save
and Save As functions are only for use with Aura
project files. The file format used is specific to Aura.
To share image data with other programs, use the
File> Export function.

The new Project panel

To save a project, choose File > Save or choose
the Save Project icon on the menu bar near the topleft of the screen; this icon looks like a floppy disk.
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Then use the file requester to locate a suitable subdirectory, and enter the project name or choose an
existing project. Choose File > Save As to save
using a new filename.
To close a project, simply click the close window
button on the project window – it’s the X button in
the top-right corner. You can also close the current
project by choosing File > Close Project or choose
the SaveProject icon, which looks like a single folder.
NOTE Closing the last open project automatically creates a blank new project.
Projects do not save keyframes or filter settings.
You must save these individually from the keyframe or
filter requesters. However, Aura does save the following items in a project: opacity maps, keyframed
motion paths, stroke recorded paths, filter settings,
custom brushes, and text brushes.

IMPORTING GRAPHICS
Importing means you want to add graphics to the
active project. To do this, select the file type (Image,
Sequence, Brush or AnimBrush) from the File >
Import submenu.
Generally, you should use Image to import still
images. If you import an animation as an image, only
its first frame is imported. If you import a
Photoshop® PSD file, Aura loads the entire image as
one layer. If you want to load each layer of a PSD file
into a separate Aura layer, load the file using File >
Load, instead of importing it.

If you choose the Stretch option, Aura enlarges
or reduces the image depending on the project page
size. Stretching your image can change its proportions. If you do not choose Stretch, Aura places the
image in the upper-left corner and crops off any part
of the image that falls outside the project window. If
you want to open a project that equals the size of a
certain image, load the image instead of importing it.

Importing Sequences
Select File > Import > Sequence to import an
animation file (e.g., RTV, AVI, FLC, Flyer, GIF, animbrush, etc.) or a series of images. The Load requester
you see will vary depending on the project settings.
For a project set to full frames, the requester reads
Full frames and Fix Motion. For fielded projects, the
requester offers Full Frames, Even and Odd options.
NOTE You can load an Aura project using
Image or Sequence. Aura loads the entire
project, including its various layers.
NOTE Aura will import SWF files (Macromedia
Flash files), but you cannot export in this file
format.
If the file you select in the file requester is an animation or part of a series of images, the Load
sequence panel appears. If you want to load a series
of images, select the first image in the series. Aura
automatically recognizes a sequence of images by its

NOTE See the Appendix for a discussion of
supported file formats.
Importing Different Resolutions
If the size of the image that you are importing is
not the same as the current project size, Aura asks if
you want to stretch the image to the current page
size.

The Stretch dialog box
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The Load Sequence panel

sequenced filenames, like Pic001.bmp, Pic002.bmp,
etc.
The Load Sequence panel provides file information and a preview window. Clicking the preview window launches the preview player, discussed in the
Layers chapter. You can also shuttle through the
frames by dragging the slider beneath the preview
window. If you hold the Ctrl key as you drag, the preview will update in realtime as you drag. Otherwise, it
won’t update until you release your mouse button.
By default, the In and Out fields, located to the
right of the Mark In and Mark Out buttons, reflect
the first and last frames in the sequence. If you want
to trim the head or tail of the sequence, adjust the
appropriate fields. You can visually set the In and Out
points by dragging the slider to the desired frame and
clicking the Mark In or Mark Out button.
The Duration field displays the frame selected by
the slider and the duration of the sequence (in
frames) separated by a slash. The duration is a result
of the In and Out point settings.

Video Options
Full Frame simply means that each frame in the
sequence is treated as a complete frame in Aura. The
other two options are special treatments for loading
interlaced video files.
With the Load Fields (Even first) option, Aura
obtains the first displayed image by interpolating
information between the lines of the even field of the
first image in the sequence. The second image
shown in Aura’s layer panel is the result of interpolating the odd field (of the first source image), and so
on. This option gives a stable image by interpolating
each loaded field to create a complete image. Load
Fields (Odd first) is the complementary option, placing the interpolated odd field first. You normally use
these options when you intend to use the animation
sequence as video again.
NOTE There is no universal standard that
determines which field comes first. However,
it should be very apparent if the wrong option
is used when you view the imported video,
since you will have essentially swapped the timeposition of every other (Aura-doubled) frame resulting
in severe interlace flicker. (Note: VT[3] video clips are
Odd first for NTSC and Even first for PAL.)
NOTE Using one of the Load Fields options
will double the number of total images displayed within Aura.
The Import Sequence panel provides two added
functions for dealing with video clips. The 480 lines

(Even) to 486 lines and 480 lines (Odd) to 486
lines switches adjust the vertical position of the fields
within Aura. These options are for use when you
work with 480 line file formats (like DV-AVI files) within
a 486 line high project, such as one suited to VT[3]’s
RTV file format. Selecting the correct option for the
file format you are working with is important to prevent field positioning errors on Export.
For NTSC DV files imported into a 486 Odd (D1
NTSC) Aura project, select 480 lines (Odd) to 486
lines. Aura offsets the imported sequence by 2 lines
down to maintain correct fielding while centering the
sequence. If dealing with 480 line ‘even first’ files
(such as the RTV format created by the version 1
VideoToasterNT) you should select 480 lines (Even)
to 486 lines. In this case, Aura offsets the sequence
3 lines to correct field order and center the sequence.

The PreLoad Option
When active, the Preload option loads the entire
animation into memory. When you deactivate
Preload, Aura loads the sequence as a read-only
layer by reading frames from your hard drive on an
as-needed basis. Therefore, non-Preloaded layers
load instantly. The sequence will appear red in the
Layers panel and you cannot edit it, though you can
move it as you would any other layer. To convert a
non-Preloaded layer to an editable layer, simply click
with your RMB and select Change to Preload layer.
WARNING Be careful using the Preload
option with video clips since they are often
very large and you may not have enough
memory.
Deactivating Preload can save a lot of memory.
Aura supports multiple non-Preloaded layers, which
are perfect for background layers that don’t need to
be edited. However, with large animation files, this
may cause your system to seem sluggish.
NOTE Non-preloaded layers cannot be painted on or processed directly in Aura VT, but
their opacity can be set using the menu
which appears when you click on them in the
Layer panel with your RMB.

Sizing Options
If the height and width of the imported images do
not match the project size, the Stretch to option is
available. The Stretch to option scales the images to
the project size. Stretching your image can change its
proportions. If you do not choose this option, Aura
places the upper-left corner of the images in the
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upper-left corner of the project window. Any portion
of the image extending outside the right and bottom
borders is trimmed off.
Frame Rate Mismatch Handling
If the frame rate of the imported sequence does
not match the project’s frame rate, activate Time
Stretching. This option automatically interpolates the
frames in the sequence to match the timing of the
project. Otherwise, the sequence will just be loaded
frame by frame, regardless of mismatched timing
issues.

Importing a Brush
Importing a brush (File > Import > Brush) is nearly
the same as importing an image. The big difference is
that instead of appearing in a layer (or layers), the
image will be attached to your pointer as a custom
brush, replacing any current brush. If the image consisted of layers, it will be flattened.
NOTE When you import a brush, it replaces
the current brush.

Importing an Animbrush
Importing an animbrush (File > Import >
AnimBrush) is almost the same as importing a
sequence, except you cannot load an Aura project.

Animations (e.g., RTV, AVI, animated GIF, animbrush,
etc.) or a series of images are acceptable.
Aura displays a panel that’s very similar to the one
that appears when you import a sequence. However,
since your imported animation will act like a custom
brush, there is no option to scale the image to the
project size when loading. Nevertheless, animbrushes can be scaled once loaded using the Edit Brush
panel.
Notice that the Load Animbrush panel includes an
additional option beneath the Video options. Use Fix
Motion to mix the even and odd fields of each image
in the sequence. This is sometimes called deinterlacing. This option uses the same technique as the
Filters > Video > Fix Motion filter. You typically use
Fix Motion to load video sequences for computer
display.

File Requester Preview
When you import files into Aura, you can right-click
on the icon in the file requester to launch a preview
panel. The preview panel lets you play, pause, stop
and loop the file if it is an animation. You can also
show a block of timecode over the preview by activating the Show Number option. The preview shows
the animation at its native resolution, so if the file has
a resolution of 640 x 480, then the preview will
expand to that size.

The preview panel from the file requester

EXPORTING GRAPHICS

Options available on the Load Animbrush
panel to import an Animbrush
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When you Export, you save the Aura project (or a
single frame) using a file format other than the native
Aura format (.aur). You should first select the desired
format from the File > Mode submenu.
The top section of the File > Mode submenu lists

the file formats capable of storing animations as one
file (i.e., AVI, DEEP, RTV, etc.). The formats listed on
the lower portion of the menu store individual images
only (i.e., BMP, ILBM, etc). When you export an
image as a Photoshop PSD file, Aura saves each
layer to a separate PSD layer.
The import and export menus give you an option
for Alpha, which defines how you import and export
an alpha channel. Your choices are PreMultiply,
Non-PreMultiply, Ignore (no alpha, 24 bit image)
and Alpha Only, which loads only the alpha channel
(use this when you would like to import or export the
mask of an image only).
The Blend Alpha with Stencil mode in the Export
menu lets you export an image or a sequence with
an alpha channel that comes from a Stencil.
When you select one of the file formats, a dialog

ors, compression method, etc. Please see the
Appendix for a detailed discussion on the individual
file format settings.

Exporting an Image
When you export an image, you save only the current image as it appears in the project window. Any
file format can be used, including those usually
reserved for animations (RTV, AVI, FLC, etc.)
NOTE Aura saves the background (e.g.,
Color or Check mode) in the image as well.
However, the effects of the light table will not
be saved. If the background is set to None, the
background will be transparent if the file format supports an alpha channel, otherwise it will be black.

Exporting a Sequence
When you export a sequence, Aura saves your
selected layers, or if no layers are selected, Aura
saves the entire project. All displayed layers are flattened. Depending on your chosen export mode, you
can export your sequence as a single animation file
(RTV, AVI, DEEP, etc.) or as a series of image files
(BMP, ILBM, etc.).

Filenames for Image Series
When saving a series of images, specify only a
root name in the file requester. Each saved image
uses the root name followed by a number corresponding to its position in the project. For example, if you
input Image as your basic name, Aura names your
new files Image0, Image1, Image2, etc. If the basic
name contains a number (for example Image10, file
numbering starts with this number (Image10,
Image11, Image12, etc.).
If a sequence contains at least 10 images, you
should specify a number in the basic name so that
the alphabetical order of files is the same as the order
of images in the sequence. If the number of images in
the sequence is more than 10 and less than 100,
place two numbers behind the basic number (like
Image00). If it is greater than 100 and less than 1000,
place three digits behind the basic name (like
Image000) and so on.

Video Mode Options
Available formats for export and import
box usually appears that allows you to set preferences for the selected format. These are options
include color depth, dithering method, number of col-

When you choose a video mode other than DEEP
or Flyer Clip, an options panel appears. For AVI or
QuickTime, it is a Windows panel that shows only
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video codecs that are installed on your computer, and
available compression settings. For more information
on these file formats and these panels, see the
Appendix.

Exporting a Brush
You can save a brush in any format. If the current
brush is animated, you save only the current brush
image.

Exporting an Animbrush
Exporting an animbrush is similar to exporting a
sequence, except there are no video interlacing
options. If you use one of the animation file formats,
all of the brush images are stored in a single file. (The
DEEP format is recommended for its compactness.)

TWAIN MANAGEMENT
Video Compression panel for AVI format
The RTV panel lets you choose Normal settings,
save an Alpha Channel to maintain transparency, or
activate Super Black. Super Black gives you an
effect similar to an alpha channel so you can export
hard edges cleanly. Super Black does not work on
partial transparencies. On the GIF panel or the FLC
panel you choose options for dithering and the
palette and number of colors to export. For more
information about these file formats, see the
Appendix.

You can access functions of the TWAIN system
directly from Aura. This is a common interface used
by digitizing hardware like scanners.
WARNING In order to use the File > TWAIN
options, Select and Acquire, The TWAIN
manager for your particular peripheral must
already be installed in your system. (Consult
the user manual for your equipment for more information.) Additionally, you must use a 32-bit version of
the TWAIN manager. Also, multiple simultaneous
scanning is not supported.
To select the peripheral, choose File > TWAIN >
Select and choose your desired peripheral from the
list. Choose File > TWAIN > Acquire to digitize an
image. The dialog box that appears will vary depending on the peripheral used. (For more information,
refer to its documentation.) After digitization, the
image appears on your Aura working page ready for
modification.

PRINTING

Above: The RTV panel.
Below: The Top portion of the GIF panel (bottom preview area not shown)
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To print the current project select File > Print. The
currently selected printer appears at the top of this
panel. If you click on the Setup button, you launch
the settings dialog box for your system printer.
(Alternatively, you can choose File > Configure
Printer.)
If you select the Single tab, Aura prints the current
frame. The preview window shows the placement of
the image on the output medium, displayed in white
(usually the printed page). Aura scales the image to fit
the output size. You can reduce the image size using
the Scale setting. If the image does not fill the entire
area of the medium, you can change its position by
dragging it with your mouse pointer. Click the Center
button to re-center the image.

Options on the Printer panel for printing a single
frame
If you select the Anim tab, you can print a storyboard (sequence) of images. The Rows setting sets
up a matrix with the same number of columns. Thus,
a setting of 2 creates a 2x2 matrix. The Step setting
controls how many frames to increment. Activate the
Image nbr option to include the frame number
beside each image. The control at the bottom of the
panel lets you scan through the pages that will be
printed out.
Click on the Print button to print with the current
settings.

CLIPBOARD COMMANDS
To store the current custom brush or your current
image in the system clipboard, select Edit >
Clipboard > Copy Brush to Clipboard or Copy
Image to Clipboard, respectively. When used with
an animbrush, only the first frame is copied. Aura displays an error message if you select this function
when there is no custom brush.
To use the contents of the system clipboard as a
custom brush or new layer, select Edit > Clipboard

Options on the Printer panel for printing a
storyboard
> Get Brush from Clipboard or New Layer from
Clipboard, respectively. The contents of the clipboard will replace the current custom brush or the
image will be placed in a new layer, depending on the
option you select. You cannot use this function unless
you have an image in the clipboard (i.e., no text, etc.).
Aura displays an error message if the clipboard is
empty.
NOTE Since these operations work with the
system clipboard, image data can be shared
between other applications as well.
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NOTE By default, Aura writes the 32 data bits
(24 color bits and 8 alpha-channel bits) of
images present in the clipboard. This type of
data may cause problems with some programs when you ask them to recover the contents of
the clipboard (usually using their Paste command).
However, you can force Aura to store only 24 color
bits of the images in the clipboard. This can solve
compatibility problems with other programs. (See the
discussion on the Aura25.ini file in the Appendix.)

MANAGING THE SPARE
IMAGE
The spare image is a storage space in which you
can place an image in order to use it with certain drawing modes, filters or simply for temporary storage.
Choose Edit > Spare > Swap spare to switch the
contents of the current frame (for the current layer)
with the contents of the spare image, or use the J
key. Choose Edit > Spare > Copy to spare to copy
the contents of the current frame and place it into the
spare image. The former contents of the spare image
are deleted. Choose Edit > Spare > Delete spare to
delete the spare image.

The Settings panel; General tab
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PREFERENCES
Aura offers various options that allow you to customize the operations of its interface, tools and functions. These options are found on the Edit menu.
Choose Edit > Settings panel to launch the Settings
panel.

Settings Panel: General Tab
On the General tab you can set the default directory location for the listed types of files. Aura stores the
current project partly in memory and partly on your
hard disk. Storage on the hard disk is done in a file,
which is located in the Temp location.
By default, Aura uses your system temporary
directory; however, you should select your drive with
the most free space. Your project can use quite a bit
of data, particularly if you edit video files. If you have
more than one (physical) hard drive, for maximum
performance, set your Temp location to a drive other
than that used for your system temporary directory.
The temp file should also be on a drive separate from
the drive Windows uses for virtual memory. You
should also use your fastest drive, if possible.

Keyboard Mapping
Click the Configure button beside Keyboard
Shorts to display the Configure Keyboard Shorts
panel. Here you can map Aura functions to specific
keys or key combinations.

The Keyboard Shorts panel: the left list shows current assignments while the right list shows available functions.
The list in the left window displays the current keyboard assignments. Keys are indicated in white and
assigned functions are indicated in black. The list on
the right displays all assignable Aura functions.
Functions currently mapped to a key are ghosted
while unassigned functions remain in black. If you
click on an assigned function (in the right window) the
keyboard assignment is displayed in the informational
field at the bottom of the panel. Aura updates keyboard shortcuts dynamically when you change
assignments or load a keyboard map (discussed
next).
NOTE When applicable, Aura displays keyboard shortcuts on the main menu.
To assign a function to a keystroke:
1. Highlight a keystroke in the list in the left window.
2. Highlight a function from the right window list. The

Assign button to the right of the windows becomes
active.
3. Click on the Assign button to map the key to your
chosen function. If the keystroke already has an
assignment and you wish to add to it (instead of
replacing it), hold the Ctrl key as you click Assign.
This way, you can assign multiple actions to one
key. For example, you could map Layer:make anim
and Layer:select all to the a key. If two commands
are mapped to one key, you can see the commands
joined by a plus sign in the information field at the
bottom of the panel.
To unassign a keystroke:
1. Highlight a keystroke in the list in the left window.
2. Click on the Unassign button.
You can save all of your settings for keyboard mapping to a file from the File pop-up menu and you can
load previously saved settings. Different users can
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access personalized shortcuts. Or if you’re feeling
wild, you can challenge yourself by loading a different
keyboard map each day.
Select Default Keymap to change all assignments
to their default settings. Clear Keymap performs a
global removal of all assignments from all keys and
key combinations, leaving you with a clean keyboard
map to rebuild in whatever combinations suit you.
HINT Aura has many helpful keyboard shortcuts mapped by default. There are also many
functions that are not mapped to specific
keys. You many want to spend a little time
reviewing both windows on the Configure Keyboard
Shorts panel.

Settings Panel: Display Tab
Generally, when you draw you will see the shape
and color of your brush attached to your mouse
pointer. Activate Hide Tools Preview to show only
the mouse pointer.

Offset lets you shift the colors in the monitor display. Essentially you change the hue when you set a
specific value in the offset field.
Gain can be equated to the saturation, or intensity
of your colors in the display. Normally you keep the
default value of 1.00. Higher values add more saturation and lower values decrease saturation.
Apply Gamma Settings to enable the LUT values
that you entered. Lock links the primary colors (RGB)
together.
WARNING Use great caution if you adjust
LUT. Example situations include a poorly
adjusted monitor with internal controls or no
controls at all, standardizing the display of
images using different videocard and monitor combinations, etc.
The DirectDraw option gives you support for
graphics cards that do not allow YUV display. If your
graphics card does not allow YUV display, select the
RGB setting beside DirectDraw. You can then see
your video in the project background.

Settings Panel: Interface Tab
From the Color Scheme pop-up menu, you can
select from several preset color schemes for the Aura
interface. You can modify individual settings by first
choosing one in the pop-up menu above the Color
Scheme pop-up menu and then selecting a new
color with the color selection button directly to the
right. Click the Reset button to reset the colors to the
defaults of the selected Color Scheme. You must
click the Apply button to apply any changes.

The Settings panel; Display tab
If you use a 16-bit display mode on your system,
the Best display mode automatically dithers your display. This may be helpful when viewing 24-bit images.
Choose Fast display if you don’t want the dithering.
Best is the only option for 24- or 32-bit display
modes.
The LUT area lets you to add a Look Up Table
over the project display. You use this feature primarily
for calibration (TV Gamma, Cineon File). Project data
is not affected; LUT affects only the display.
Gamma is a coefficient that determines the
brightness of the colors in the monitor display. The
default value of this coefficient is 1.00. With higher
values (1.8 is a typical value for CMYK printing) the
image looks lighter, and with lower values it looks
darker. The gamma settings are used to recalibrate
your monitor only. They never change the actual colors of the image saved on the disk.
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The Settings panel; Interface tab
The (Cursor) Over Projects setting determines
what your mouse pointer looks like when it is over a
project window.
The Magnet windows option makes it easier to
align floating panels with each other. As you drag a
panel near another, its edge will snap, or dock, to the

edge of the other panel. The No border option hides
the title bar and gives you just a little more space for
your working page – particularly if you undock the
menu bar as well.
You load and save files using file requester dialogs.
These requesters provide access to the various drives
on your computer (hard disk, CD-Rom, etc.) and
allow you to navigate their directory structures. The
File Requester settings let you choose between your
standard system file requester or Aura’s custom file
requester, discussed below.
The Never Confirm option, when active, will suppress confirmation dialogs when erasing or overwriting files.
If you want to be able to place a project window in
front of Aura panels, deactivate the Always Behind
Panels option.

Operating the Aura File Requester
Files in the current directory appear in a scrollable
list in the upper portion of the requester. The current
directory is identified by the Path input field. When
the Icon button is active, certain file types, like Aura
project, DEEP, ILBM, and TIFF format files, may automatically display a thumbnail image as the file icon.
To the right of the icon are the filename, creation date
and time, file size, and, if applicable, file resolution
and number of frames (for animations). Deactivate the
Icon button to show only filenames in the list.

When the icon is an exclamation point, Aura recognizes the file format, but no thumbnail is available.
You can display a temporary thumbnail and preview
the image by clicking on the item with your RMB. For
animations, you can play a preview by right-clicking
the icon. If the icon is a black question mark, Aura
does not recognize the file format.
NOTE For information on the preview window
that appears when you right-click on an item,
please see chapter 7.
Click the Scan button to update/create the icons
for all recognized files in the list. This does not re-read
the directory, however. To do that, click in the Pattern
input field and press the Enter key. Aura temporarily
retains scanned thumbnails during your Aura session.
NOTE Aura is more advanced than most
paint programs in that it does not rely on the
filename extension to determine the file format. For example, Aura will automatically recognize and load a JPEG format file called Picture.gif.
Of course, such naming will likely cause confusion if
you plan to use the image in other applications.
From the Volumes pop-up menu you can select
the hard drive partition, CD-Rom drive, removable
device, etc. You select a subdirectory (folder) in the
current directory with the Directories pop-up menu.
Clicking on the .. button takes you to the parent
directory, if you are not in the root directory.
You can manually input a full path in the Path input
field using the form: Drive:\subdir\subdir. If you click
in the Path input field, you can use your Up Arrowkey
and Down Arrowkey to cycle through previously used
paths.
NOTE If the number of items exceeds a certain amount, Aura replaces the pop-up menu
with a scrollable window. Simply select the
desired item and click OK.

The Settings panel; Display tab

The Pattern input field contains “*.*” by default. It
uses the standard MS-DOS filename pattern matching conventions so an asterisk (*) is a multiple-character wildcard. As such, “*.*” lists all files that have a
period (.) in their name. An asterisk by itself, “*”, will
list all files, even ones without a period. “*.tga” will
display only files with the file extension “.tga”. A question mark (“?”) is a single-character wildcard.
“d???.t??” will list all files four characters or less,
starting with the letter D, whose file extension started
with the letter T. So files like Doug.txt, Des.tif, etc. will
be listed.
To select a file, double-click on it in the listing, single-click on it and then click OK, or enter its name in
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the File input field and press the Enter key. To cancel
the operation click on the Cancel button.

Video Input

HINT It may take a little time to get used to
the Aura file requester; however, it is highly
recommended that you use it because of the
additional information that it provides.
NOTE You must use the Windows File
requester to access files on a network.

Settings Panel: Memory & Cache
Tab
Here you can set the amount of memory to set
aside for undos and data caches to your hard drive.
Select Automatic to let Aura automatically manage
the cache size.

The Settings panel; Memory and Cache tab
Video Grabber panel: Input for Aura VT
NOTE The location of the Cache data is set
on the General tab using the Temp location
setting.

VIDEO GRABBER
You access the Video Device panel by choosing
Windows > Video Grabber. This panel lets you
choose a video source that you can grab for your
Aura projects and a video output to which you can
send an Aura project. You can also use the RMB on
the V button of the project window to open this
panel.
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You will normally select your VT[3] as the active
device using the Device setting. The Input selection
lets you choose the input from the VT[3] source, such
as Program, DSK, and so on. Format will automatically correspond to your VT[3] project preferences.
The Mix field lets you mix the value between the
video background and the current Aura project.
When mix equals 0, your project sits over video, and
when mix equals 100 the video sits over your project.
Mix affects your Project window only when you set
Video Background to enable.
Use the Apply on menu to specify where to store
your grabbed images. With the New Layer you place
the image on a new layer of your project. With
Current Layer you place the grabbed image on the
layer where you are currently working. If no frame is
selected, Aura pastes the image after the current

frame in the current layer; if a frame is selected, Aura
replaces the current frame with the grabbed image.
The Length field defines the length of your
grabbed image in frames. The default length of your
grabbed image is 5.
The Field menu has options to set how Aura handles fields. Double grabs fields as they are; it does
not change them. Odd mixes fields with odd first (for
NTSC sources). Even mixes fields with even first (for
PAL sources). Mix blends the fields together
Click on Grab to grab frames from your video
input. All functions for Grab can be accessed by
shortcuts; for example you can set Grab to respond
to a footpedal or an external keypad for a stopmotion
animator.

The Load button loads existing surface images into a
new Aura project scaled to fit them. Save overwrites
the original texture image.
HINT You may find it necessary to use
LightWave’s image Replace function to update
the texture held in LightWave.

The Video Grabber Device option also lets you
select LW Viewer, to access data from the
LightWave® Viewer plug-in. This enables you to use
Aura to view and modify surface texture imagery for
objects currently loaded in LightWave3D® (when the
LightWave hub is enabled).

Video Grabber panel: Input for Aura VT
The Options tab reveals a panel allowing you to
set the location on your system of the LightWave
configuration file. Aura must be able to locate this file
for the plug-in to function. The file is named lx3.cfg,
and is normally located in your personal user folder
within C:\Documents and Settings. You can also set
the Color used for LightWave UV map overlays under
this tab.
Video Grabber panel: Input for Aura VT

Video Output
When the LW Viewer is selected, the Settings button opens a panel named LightWave Viewer offering
a number of options. The Objects menu is used to
designate the LightWave object whose surfaces you
wish to work with. For an object which has UV maps
assigned, you can use the two options under the
UVs tab to designate which UV map you wish to
work with.) When a UV map is selected, the
Overlay option will become available in the Video
Grabber panel, enabling you to view the current UV
map over your Aura project window, where it can
serve as a guide to creating your texture maps.
The Surfaces tab permits you to specify an active
Surface, surface attribute (Channel), and image
(Texture) of the selected object for editing in Aura.

Enable makes Aura’s imagery available to your
VT[3] device. With Refresh enabled, you get realtime
output on your display device. When you deactivate
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Refresh, Aura updates the output only when you
release the mouse. You can access shortcuts for
Video Grabber by clicking the RMB over the V button
from the project window.
NOTE This option is mandatory if you are to
see Aura output on the VT[3] Program output
when you select AuraVT as a source in the
Switcher panel or DSK.

DISPLAY OPTIONS.
The Display Options panel, which appears when
you choose Windows > Display Settings, sets the
visibility attributes for certain drawing features.

Project with Paper background
If you want to see the crawling ants outline for
selected areas, activate the Selection option.

‘Crawling ants’ selection outline
The Display Options panel
You can make the Grid and/or Guides visible from
this panel. You can also change the line color and
intensity from this panel. These options, discussed
later in the chapter, affect only the display of these
features and don’t enable them.
A Stencil, discussed in Chapter Seven, is used to
mask out drawing areas. You can make the stencil
visible, as well as adjust its color and intensity.
Paper, discussed in Chapter Six, is like drawing
on selectable surface. If you want the paper surface
visible on the background, activate this option. Paper
is visible only if you can see some portion of the
background.
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If your animation will be viewed on a television, be
aware that viewers will not see the entire image.
Activate Safe Area to display outlines that indicate
the safe text (the inner border) and safe action areas
(the outer border) for television. To allow for the differences in the display of different brands and designs
of television sets, you should use this guide to ensure
that text and action elements of your animations
remain on screen when it is important that they be
seen.

Full Screen Mode
The Full Screen mode is an alternative to working
in a project window. You have less control over how
Aura displays the image in this mode. You activate
the Full Screen mode by clicking its button on the
menu panel or by choosing View > Full Screen.

The menu panel with Full Screen icon indicated

Project with Safe Are display activated

The image in the last active project window
appears in the top-left corner, probably beneath
some panels. You can reposition it by holding the Alt
key and dragging the image. You can interactively
zoom in or out by using Alt RMB.

You can adjust the color and intensity of the lines,
as well as adjust the relative positioning of the two
borders by adjusting the Out Area and In Area settings from their default values of 5% and 10%,
respectively.
The Field Chart option activates a crosshair chart
similar to a 12-field chart as used in the film industry.
It divides the camera view into quadrants, and each
quadrant has 12 segments.

Project in Full Screen mode

Project with Field Chart activated

VIEW OPTIONS
You have several options on the View menu that
affect how you work on a project.

Multiple Views
Choose View > New zoom window to open
another project window for the current project. You
can open multiple windows for a single project. Use
this to view different zoom levels simultaneously. You
can edit the project from any of the windows.

To switch between projects in Full Screen mode,
just select a project from the bottom of the Windows
menu. To switch back to the Windows mode, deactivate the Full Screen button or choose View >
Windows.
NOTE You can use the same keyboard shortcuts/menus used in a project window to
zoom and pan.

The Full Page Display
The View > Show Full Page function displays the
entire project on your screen, scaling the image down
if necessary. This is simply a preview mode – you
cannot draw in this mode. Click your LMB to return
to the original Aura display.
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THE GRID
The grid constrains drawing to the intersections of
a grid. Your mouse pointer then tends to move from
one intersection to the next, rather than from pixel to
pixel. To activate the grid, simply select the Grid button from the Menu panel.

Click the Use Brush Size option to use the
dimensions of the current brush as the grid dimensions. Setting this option allows you to quickly fill in
an image with several copies of a brush in a checkerboard pattern.
The Show option controls the display of the grid.
(See also the previously discussed Display Options.)
The Snap option enables the grid’s influence. Aura
automatically activates both of these options when
you activate the Grid button on the Menu panel.

GUIDES
Guides, similar to grid lines, force drawing functions to occur along defined lines. This is great for
aligning text and graphics. To use guides, activate the
Guides button on the Menu panel.

Clicking on the Guides button with your RMB will
open its settings panel.

Project with Grid option activated
Clicking on the Grid button with your RMB will
open its settings panel. The Start X and Start Y settings define the coordinates of the grid origin point.
This allows you to move the grid within an image
without changing its size. The Width and Height settings represent the horizontal and vertical spacing in
pixels between each grid line.

Grid settings panel
To create a guide, click the Set button. When you
drag your mouse over the image, you automatically
create vertical and horizontal guides that intersect at
your mousepointer.

Grid settings panel
Click the Set button to graphically define the
above grid settings. Simply drag your mouse pointer
to determine the grid origin and size.
NOTE You may want to deactivate the Grid
function before using the Set option.
Project with Guides activated
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To create just a vertical or horizontal guide, keep
your mouse pointer on the grey area bordering the
image.

DISPLAYING COORDINATES
When you choose Windows > Coordinate Panel,
a small panel appears. In the panel you can read the
position of the mouse pointer in the screen (X, Y) and
the color values underneath the pointer (RGB). If your
pointer moves off the image, the appropriate values
are highlighted in yellow. If you use the Shift key to
lock axes (discussed in the next chapter), the locked
axis is highlighted in yellow. A small preview area provides a magnification of the area surrounding the
pointer.

Moving the guides
NOTE You can create multiple guides.

Click the Reset button to clear all guides.
The Show option controls the display of the
guides. (See also the previously discussed Display
Options.) The Snap option enables the guides’ influence. Aura automatically activates both of these
options when you activate the Guide button on the
Menu panel.

The Coordinates panel
The two rows at the bottom show context-related
info, like length and angle for lines and splines, width
and height for rectangles, A and B (two radii) for the
ellipses, etc.

Example using guides to place text
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Notes:
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Chapter 3:
Drawing and Selection
Functions
DRAWING FUNCTIONS
The drawing functions determine the shape of
what you draw with the various drawing tools, discussed in the next chapter. For example, when you
draw freehand lines, rectangles, or other shapes,
Aura’s selection function lets you define areas to work
on and define restricted areas.
Some of the drawing function buttons have multiple states. Successive clicks will cycle through the
available functions. For the drawing functions, this is
usually an outline and a filled option.
You can apply the current shape with the Enter
key; you select the shape, color and drawing mode
you want and Aura applies it in the current layer. You
can change layers – and even change colors and
drawing modes – and apply the shape in multiple layers using the Enter key. Holding your Shift key down
will constrain your mousepointer direction (in increments of 45 degrees) based on the initial direction of
movement. If you click a drawing function with the
RMB, Aura brings up its settings panel. Note that you
can designate an RMB simulation, where you access
the RMB with a specific key. You set the simulation
as a keyboard shortcut, (see Chapter 2); Wacom
tablet users may find this shortcut handy.

DRAWING DOTTED
FREEHAND LINES
Activate the Freehand dotted line function to make
a dotted line with the current brush and current drawing tool (i.e., Pen, Mechanical pencil, Brush tool, etc.).
When you draw the line, Aura applies the brush in the
image at the location of the pointer. As soon as you
finish the operation, Aura will apply the brush again at
your new pointer position, and so on. The application
speed of the brush varies depending on its size and
selected options. The spacing between the various
brush applications varies depending on the time necessary to draw the line and the pointer displacement
speed.

HINT Use the Shift key feature to help you
create perfect circles and squares.
Drawing with a Dotted Freehand Line
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The Freehand dot function makes a single instance
of the brush when you first click.

DRAWING FILLED FREEHAND
SHAPES
The Freehand Filled shape function is simply a
filled version of the Freehand function. When you
release the mouse button, the first and last points of
the line are connected by a straight line and Aura fills
all surfaces delimited by this outline. The fill takes into
account certain options, such as color range, opacity
mapping, and so on.

Drawing with a Freehand Dot

DRAWING CONTINUOUS
FREEHAND LINES
The Freehand function lets you draw a free form
line with the current brush and current drawing tool
(i.e., Pen, Propelling pencil, Brush tool, etc.). Unlike
the Dotted Freehand Line function, Aura applies the
brush continuously between each position of the
mouse pointer as you drag.

Drawing with a Filled Freehand shape

DRAWING STRAIGHT LINES
The Straight line function draws a straight line
between two points using the current brush and current drawing tool (i.e., Pen, Propelling pencil, Brush
tool, etc.). To draw lines, you drag your mouse pointer. The initial drag point is the starting point of your
line. As you drag, an elastic line follows your pointer
movement. The line ends wherever you release the
mouse button.

Drawing with a Continuous Freehand Line

NOTE When using complex or large brushes,
you may need to draw using slower mouse
movements.

Drawing with a Straight Line
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DRAWING FILLED POLYGONS
The Filled Polygon function draws a filled polygon
by defining an outline with a series of straight lines.
The fill takes into account certain options, such as
color range, opacity mapping, as discussed later.

Dragging the initial tangent for a Spline Curve

Drawing with a Filled Polygon

2. Release your mouse button. You can adjust the
point’s position by simply dragging it around. You can
also adjust the tangent by dragging either end of the
tangent.
3. Create the additional points by dragging out
another tangent.

Creating a Solid Polygon
Your first click in the work area defines the starting
point, then an elastic line follows the movements of
your pointer. Each successive mouse click defines
another vertex and a new elastic line begins from that
point. Use any of the following options to complete the
polygon:
• Click on the starting point with your LMB.
• Click your RMB.
• Press the Enter key.
With the final two options above, you draw a
straight line between the first and last vertex of the
polygon and Aura fills all areas delimited by the outline.

Erasing with a Solid Polygon

Creating the additional points for a Spline Curve
4. You can break a unified tangent by holding the
Ctrl key while dragging one end of a tangent.

You can erase with a shape by using the Filled
Polygon, which is similar to the cut brush function.
Begin with the RMB, create your shape with successive LMB clicks and then choose one of the options
above to close the shape. Aura erases the area in the
current layer with your shape.

DRAWING SPLINE CURVES
With the Spline function, you can draw a smooth
curved line using bezier curves.
To draw splines:
1. Begin by dragging out the initial tangent.
Normally, you should drag out the tangent in the
direction of curve.

Breaking a unified tangent on a Spline Curve
5. If you want a closed curve, you can connect the
two end points by selecting Close Spline from the
RMB pop-up menu.
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To clear the existing curve and start over:
Press the Esc key or select New Spline from the
RMB pop-up menu.
To delete a point from a curve:
Place your mouse pointer over a point and select
Delete Point from the RMB pop-up menu.
To add a point to a curve:
Place your mouse pointer over the curve and
select Add Point from the RMB pop-up menu.

DRAWING FILLED SPLINE
CURVES
You can draw a filled shape with spline curves
using the same techniques described above.
However, when you apply the curve, Aura fills the
shape. If the curve is not closed, Aura fills the shape
as if it were closed using the two end points.

Closing a Spline Curve
NOTE Splines do not have to be closed.

6. You can apply the current Drawing tool along
the curve by selecting Apply Spline from the RMB
pop-up menu or pressing the Enter key.

Drawing a filled Spline Curve
Apply the current Drawing tool along a curve

To move the entire curve:
Place your mouse pointer off the curve and hold
the Ctrl key as you drag your LMB.
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DRAWING RECTANGLES

DRAWING ELLIPSES

The Rectangle function draws a rectangle outline
with the current brush and current drawing tool (i.e.,
Pen, Mechanical pencil, Brush tool, etc.).

The Ellipse function draws an ellipse outline with
the current brush and current drawing tool (i.e., Pen,
Mechanical pencil, Brush tool, etc.). You can set two
different ways to define a circle with the Circle setting
on the Shape Settings panel. This panel appears if
you right-click on the Ellipse button.

Drawing a Rectangle
When you first select the Rectangle tool, your
mouse pointer changes to large crosshairs. The initial
drag point is the first corner of your rectangle. As you
drag your mouse, an elastic box follows the pointer
movements – giving a preview the final rectangle.
Release the mouse button when the pointer reaches
the location you want for the opposite corner of the
rectangle. The rectangle is then drawn.

Usually, you want to use the Center setting, which
defines the initial drag point as the center of your circle.
As you drag your mouse, an elastic circle follows the
pointer movements – it shows you the appearance of
the final circle. Release the mouse button when the circle is the desired size. Aura then draws the circle.

DRAWING FILLED
RECTANGLES
The Filled Rectangle function draws a filled rectangle. You use this function just like the regular
Rectangle function, except the rectangle is filled when
you release the mouse button.

Drawing an Ellipse

Drawing a Filled Rectangle

When you draw a circle based on an existing circle
in your image (e.g., a wheel), it is often difficult to find
its precise center and radius. In such cases, you may
want to use the 3 points setting, which allows you to
define a circle using three points on a circumference.
Click once to establish the first point on the circle’s
circumference. Then, as you move your mouse, an
elastic circle follows your pointer movements. One
side of the circle is locked to the initial point. Click
again to set the second point. The elastic circle continues to follow your pointer movements, but the circle is locked to the two established points. Click a
third time when the circle is the desired size. Aura
then draws the circle.

3.5 Aura VT

DRAWING FILLED ELLIPSES
The Filled Ellipse function draws a filled ellipse. You
use this function just like the regular Ellipse function,
except Aura fills the ellipse when you release the
mouse button.

FLOOD FILL
The Flood Fill function fills areas of the image with
the foreground color. To use this function, select the
function and then drag your mouse pointer in the area
to be filled. As you drag around, you see the fill area
displayed. Release the mouse button to complete the
operation. Move your pointer off the image to abort.
The paint spreads pixel by pixel (horizontally and vertically) to the (computed) bordering edges of the area.

Adjusting Fill Borders
Access the Flood Fill settings panel by clicking on
its icon with the RMB. The Fill pop-up menu lets you
tailor how the fill border is defined. Color & Density,
(the default), stops the fill when the paint reaches a
pixel with a color or opacity different from that of the
start pixel. Color only stops the fill when the paint
reaches a pixel that is different only by color – density
is ignored. Density only stops the fill when the paint
reaches a pixel with a different transparency level –
color is ignored. Luma stops the fill when the paint
reaches a pixel with a different luminosity level – color
is irrelevant. B color stops the fill when the paint
reaches a pixel using the B color.

Left: The Shape settings panel. Right: Fill pop-up
menu on the Shape settings panel
HINT Color only may sometimes work better
when the filled shape has an antialiased edge
because the pixels usually have identical colors but different density.

Border Tolerance Range
When Range is set to 0, any deviation from the initial
pixel color is considered a border. Thus, if the initial pixel
has an RGB value of 255, 0, 0, a pixel with an RGB
value of 254, 0, 0 is considered a border. Setting
Range to a higher value allows each of the RGB channels to vary by that amount before a pixel is considered
a border. As such, if Range is 2, the colors (254,0,0),
(253,0,0), (254,2,2), (0,2,1), etc., are not considered a
border for an initial pixel color of 255, 0, 0.

Using Flood Fill to select and fill an area.
Here the black clothing was selected
and replaced with a lighter color.
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Range set at 25 on the
Flood Fill settings panel

NOTE A Range setting of 255 will result in no
border detection.
With the Expand option, you can set an amount
of pixels to expand the fill. You use this option to
avoid artifacts from anti-aliased edges by filling up to
or over the border.

Left: Fill without Expand. Right: Fill with Expand of 1.

FILLING SHAPE OPTIONS
See Chapter 5 for information on filling shape
options.

THE SELECTION FUNCTIONS

Settings for Selection on the
Tool panel
replaces the current selection with the new selection
that you make.
The Smooth setting will feather the outside edges
of selection areas that you draw. If you change the
smooth setting, your change affects only new selections that you make. It will not affect existing selections.

The selection functions allow you to create masks
in various ways. All painting operations affect only the
selection area. From left to right, the five buttons
allow you to define a selection area using: a rectangle, ellipse (circle), freehand shape, spline and flood
fill (magic wand).

Left: Smooth > 0. Right: Smooth = 0

Selection buttons on the Main panel
The selection functions work just like the related
drawing functions discussed earlier in the chapter,
except that they define a selection area. When a
selection function is active, the Tool panel contains
settings for selection operations.
The top pop-up menu sets the action that occurs
when you use the LMB. Generally, you will leave this
set to Add because you can always use the RMB to
subtract from an existing selection area. The Sub
option lets you subtract areas from the existing selection each time you use it. Replace completely

Enable AAliasing, to apply default smoothing to
the edges of your selection and eliminate stairstepping. For AAliasing, you do not need to enter a
Smooth value, the default smooth action occurs
automatically. When AAliasing is not enabled (and you
do not use Smooth), the outline of your selection will
not be smoothed.
To reverse the selection area, click the Invert button. To clear the selection, click the Clear button.
Using the buttons at the bottom of the panel, you
can cut or copy the selection to a new layer or custom brush. Use the Crop button to crop the project
using the selection for a new project.
NOTE If the selection area is not rectangular,
a bounding box surrounding the selection
area is used.
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NOTE Aura’s stencil function, discussed in
Chapter 7, also allows you to limit the
paintable area.
Remember that you can change the selection display to hide the crawling ants, as discussed in
Chapter 2. You can find a tutorial on the selection
tools, Lesson Eight, in the Aura content directory.

On the Tool panel, you have options to independently move the image and/or selection. You can also
choose to activate or deactivate antialiasing. With
AAliasing ON, you can pan at a subpixel level, which
means you can pan at less than 1 pixel. With
AAliasing off, subpixel panning is not available.

THE PANNING TOOL
The Panning tool is similar to the Transform tool.
When you drag your LMB, you use the mode selected
on the Tool panel. Wrap tiles the image as you drag
to fill in the spaces and Shift does not tile the image.
(Dragging with your RMB will use the Shift mode.)
Settings for Panning on the Tool panel
WARNING There is no Apply function, like on
the Transform and Wrap tools. Changes are
immediate. If you release your mouse button,
you lose any part of your image that falls off
the image area. Use undo to get it back.

Panning Tool option

Panning a Layer
1. Pan the single frame where you want it.
2. Hit undo.
3. Select the entire layer.
4. Hit enter to re-apply to entire layer

THE TRANSFORM TOOL
The Transform tool lets you manipulate your image
or sequence interactively in the project. This is somewhat like cutting the entire image or sequence out as
a brush, manipulating it, and then pasting it back
down. This tool is great for sizing video for a picturein-picture effect.

The Transform button on the Main panel

Top: Pan with Shift mode
Below: Pan with Wrap mode
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Using the Transform Tool
Import an image, then select the transform tool;
the preview activates automatically.
To reposition the image, drag with your LMB.
To scale the image drag with your RMB.
To rotate the image, hold the Ctrl key and drag
your LMB.
NOTE Rotation occurs only on the bank angle
with the Transform tool.

Using the Fill option to tile an image with the
Transform tool

Rotating and scaling an image with the
Transform Tool
The Tool panel displays settings for the Transform
tool.

You can independently set whether you move the
image and/or selection area using options on this
panel.
The Panning X and Panning Y values reflect the
amount of horizontal and vertical movement, respectively. Scale sets the amount of sizing and Angle sets
the amount of rotation. You can edit these fields manually, if you desire.
The Center button will center the image, retaining
any scaling and rotation. Click Reset to reset the
panel to its default values.
Click the Apply button to apply the settings to the
image. If you select another function/tool without
applying first, you will discard all settings.
NOTE When you use layers, you affect only the
current frame of the current layer unless you
select other frames. To move an entire layer, you
can also use the Panning filter (see Chapter 8).

Transforming a Layer
Select all frames in your layer, then turn on the
Transform Tool. Move, scale or rotate the image. Hit
Enter to reapply your transformation to the entire
layer.
Settings for Transform
on the Tool panel
If you set the top pop-up menu to Fill instead of
Once, you can tile the image (that is, you repeat the
image horizontally and vertically across the work
area).
HINT The fill mode works well with layers that
have transparency; try placing a large logo in
the center of the screen and then scale down
the logo so it repeats.
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THE WRAP TOOL
The Wrap tool lets you stretch and scale an image
by adjusting the position of its four corners. To move
the entire area, click and drag with your LMB. To size
the entire area, hold the Ctrl key as you drag your RMB.

If you set the top pop-up menu to Fill instead of
Once, the image is tiled (that is, it is repeated horizontally and vertically).

Using the Fill option to tile an image with the Wrap tool

Stretching and scaling with the Wrap tool
The Tool panel displays settings relating to the
Wrap tool.

You can independently set whether you move the
image and/or selection area with options on this
panel.
The four pairs of XY settings define the position of
the four corners. (1 = top left, 2 = top right, 3 = bottom right, and 4 = bottom left) You can edit these
fields manually, if you desire.
When the Preview button is active, which is the
default, you can graphically adjust the bounding box
around your image with handles at each corner. With
Preview off, the bounding box disappears and you
use only the fields on the Wrap tool panel to input
numerical changes.
Click Reset to reset the panel to its default values.
Click the Apply button to apply the settings to the
image. If you select another function/tool without
applying first, you will discard all settings.
NOTE When you use layers, you affect only the
current frame of the current layer unless you
select other frames. To wrap an entire layer, you
can also use the Wrapper filter (see Chapter 8).

Settings for Wrap on the
Tool panel
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Vanishing Point
When you use this tool, the image eventually disappears off in the horizon at two points called the
vanishing points. This may be outside the borders of
your project window and, thus, not visible. If a vanishing point is within your project’s borders, it appears
as a small square. You can drag these points to alter
the perspective shape.

On the Crop tool panel, you enter the coordinates
where your selection marquee begins in the Begin X
and Begin Y fields. You specify the size of the selection marquee in the Width and Height fields. The
Lock Aspect button is selected by default when you
select this tool. With Lock Aspect selected, Aura
constrains the proportions of the selection area to a
fixed ratio. With Lock Aspect unselected, you can
independently adjust the height and width of your
selection area. To crop your selection and create a
new project window, hit the ENTER key or the Crop
button on the Crop tool panel. Once you crop out an
area, Aura creates a new window that uses the original filename preceded by “crop-.”

Selecting the crop area with the Crop tool and the
Tool settings panel

THE ZOOM TOOL
Top: Fill mode. Below: Once mode

THE CROP TOOL
The Crop tool lets you select a portion of your
image to cut out as a new project. When you select
the Crop tool, Aura places a rectangular selection
area in your image that you can move with your LMB.
You can adjust the size of the selection area by dragging the lower right corner with your RMB, or you can
specify values in the Crop tool panel.

The Zoom tool lets you zoom into or out of areas of
your project, from a range of 1 percent up to 10,000
percent. With the Zoom tool selected, you zoom in, or
magnify, an area, by clicking with your LMB. To zoom
out of an area, click with your RMB. When you use
this tool, you zoom in or out of the area in the image
that is beneath the magnifying glass.

The Zoom button on the Main panel

The Crop button on the Main panel

HINT While any tool is selected, you can use
the > key to zoom in and the < key to zoom
out of your images. You can also zoom in and
out graphically if you hold the ALT key and
drag with your RMB.
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Chapter 4: Drawing Tools
Aura provides several drawing tools for your use.
These tools work in conjunction with the drawing
functions (freehand, straight line, rectangle, ellipse,
etc.) discussed in the previous chapter.

THE TOOL PANEL
When you choose a drawing function, the Tool
panel displays the tools, the brush shape and related
options.

The Tool panel should be visible by default; however, if it isn’t, click the Tool panel button on the menu
panel.

The Tool panel button on the menu panel
The ten buttons at the top of the Tool panel activate drawing tools. The settings on the Options tab
change based on the active tool. Beneath the ten
buttons is the drawing mode pop-up, discussed in
Chapter 6.
NOTE The Tool panel will change its appearance based on the active function.

COMMON SETTINGS
Many of the tools offer settings that are common
to multiple drawing tools, like power and size.
Brush Shape
When available, the brush shape controls appear
at the top of the Options tab.

Example of the Tool panel
using the Airbrush

The left window gives you a preview of the brush.
The right window gives you a profile preview of the
brush. This is essentially a cross-section of one-half
of the brush. On the next page are some examples
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To delete a point, select it by clicking on it and
then click the Delete button.
You can save and load files for the profile curves
from the Files pop-up menu. You also have a reset
option on this menu.
The Profile Editor offers three options for editing
your curve: Linear, Spline and Polynomial. When you
activate the Linear option, the curve changes direction abruptly from point to point. With Spline, the
curve travels smoothly through the points. If you
choose Polynomial, you produce a rounded curve
based on an algebraic calculation.

Brush shapes for the
Airbrush
with the cross-section superimposed over the brush
preview to show you the relationship.

Examples of available Brush shapes
Double-clicking the profile preview window brings
up the brush profile editing panel.
To add a point to the profile curve, click and drag
your LMB in the graph area. When the point is in the
desired position, release your mouse button.

Adding a point in the Profile curve
To move an existing point, click on the point with
your LMB to select it and then drag it. (Note that you
can drag only the two default points along their
respective edges.) You can flip the entire curve horizontally or vertically by clicking Flip X or Flip Y button.
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Top: Linear. Center: Spline. Bottom: Polynomial.

Use the up and down arrow buttons on the preset
selector to cycle through built-in profile curves, which
you can use as is or alter it. Click the preview window
to use the selected preset.

accomplished by diminishing the opacity (transparency) of pixels along object outlines. As the pixels
become more and more transparent, the colors covered by these pixels become more and more visible.
Generally, you want this function active.
Aura features subpixel antialiasing. As such,
antialiasing is actually based on the position of your
pointer within a pixel!

Subpixel antialiasing
Aspect - Aspect stretches or squashes the brush.

The preview window and arrow buttons for Builtin profile curves
NOTE When your mouse pointer is directly
over a point, you can use the right-click popup menu as a shortcut to some of this panel’s
features.

Common Parameters
Many of the tools share the same parameters. The
following list describes the available parameters:
Angle - Angle rotates your brush. Use in conjunction with Aspect values of less than 100%

Aspect = 30%
Drying - Drying controls the behavior of the paint
when you pass over an existing line made with the
tool in a previous brush stroke. If activated, the paint
will dry between strokes. Therefore the new line will
cover the old line. If deactivated, the new and old
lines will mix together, which may modify the borders
of the old line.

Angle = 35% (Aspect = 30%)
AAliasing - Antialiasing smoothes the edges of the
paint and therefore eliminates stairstep or jaggies that
can appear on the edges of objects. Antialiasing is

Left: No drying. Right: Drying active

Left: Antialiased edge; Right: Non-Antialiased edge

Note, the paint will never dry during the same
brush stroke (i.e., while you continue to hold your
mouse button down). However, it dries automatically
when you change the current color, the gradient, the
frame, the spare, the paper, the project, the mode,
the stencil, the channel preserve and the undo.
Opacity - Opacity globally controls the transparency of the line drawn. Lower values result in a transparent, less opaque, brush stroke.
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Power - Power is the maximum intensity of the
stroke in percent. It works with Opacity to control the
density of the ink applied.

Clicking on the connection button displays a popup menu. You can select from various input characteristics that will vary the parameter dynamically.

Reset - Click this button to return parameters to
their default values.

Speed - Speed changes based on the velocity at
which you move your cursor.
Direction - Direction uses a different value based
on the direction you are drawing.

Size - Size is the radius of the brush in pixels. If
you have a scrollwheel mouse, you can adjust Size
with it.
HINT As the Size increases, screen updates
may occur more slowly. Above a certain size –
which will vary depending on the power of
your system – you should choose the Dotted
Freehand Line function for freehand tasks.
Step - Step indicates the number of pixels
between each application of the brush as you draw. If
not active, the step is automatically computed based
on the brush size.
NOTE Not all parameters are available with all
tools.

Size and Direction at 15
Orientation - Orientation is similar to Direction,
but lines get thinner at two opposing points. Use this
parameter to mimic the effect of a calligraphy pen.

Gradients
See the next chapter for information on gradients.
Connection Buttons
Many of the tool parameters have a green connection button to the left of the numeric input field.

Size and Orientation at 15
Fade - Fade will fade out your parameter over distance.
Random - Random adjusts the selected parameter randomly.
Tablet-related Items
Pressure - Pressure connects pressure on a tablet
to the tool parameter. When you use minimum pressure, the intensity of your line is near zero. As you
press harder, the intensity becomes closer to the
Power setting and becomes equal to it when you
reach maximum pressure.
Altitude - The Altitude changes depending on the
vertical angle of the stylus, if supported by your
tablet.
Azimuth - The Azimuth changes depending on the
rotational heading of the stylus, if supported by your
tablet.
Connection buttons on the
Airbrush tool
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The Reset button adjacent to each curve restores
the curve to its default appearance (diagonal).
The speed Limit value sets the maximum pixels
per 1/100th of a second. For example, you can connect size to speed. Then, the higher the limit you set,
the faster you must move the cursor to approach the
normal size setting.
The Fade setting determines the distance where
the parameter is totally faded, in pixels. The higher
the fade value, the longer it takes the brush stroke to
fade.
Finger Wheel - The Finger Wheel lets you adjust
the parameter interactively with the FingerWheel if
that option is available on your mouse or stylus.
NOTE The parameter’s (e.g., Size, Rotate,
etc.) normal value on the Tool panel is usually
used as a base value for changes made by
the connection settings.

NOTE If used with the line tool, the fade is
always evenly distributed along the length of
the line.
The Orientation angle sets the narrow direction. A
value of 0 makes horizontal strokes narrow and 90
makes vertical strokes narrow.

The Reset button returns all connection to none
and all values to their defaults.
The Options menu item brings up the Connection
Settings panel. Here you can set options for some of
the above input parameters.

Left: Orientation at 90 degrees.
Right: Orienation at 0 degrees
The Direction angle sets the direction your mouse
must travel to get the base setting (on the Tool panel)
– essentially, the no effect angle.

The Connection Settings panel
Speed uses a sensitivity curve. By default, the
curve is a straight diagonal line. Therefore, any action
on the line (increasing the pen size, pencil opacity,
etc.) will increase in proportion to the cursor displacement speed.
You can modify these curves by dragging your
pointer on them. Bowing the curve upward, for example, will increase the effect on the line proportionately
more than the increase in applied speed. Conversely,
if you bowed the curve downward, the effect on the
line will work less quickly than the applied speed. You
would need to move the mouse faster to obtain the
same effect on the line.

4.5 Aura VT

THE AIRBRUSH TOOL

THE OIL BRUSH TOOL

The Airbrush tool sprays paint on the screen. The
more paint you spray at a specific location, the
denser the color you obtain. On most tablets, you
can apply the airbrush by using the Finger Wheel.

The Oil Brush tool lets you paint like you were
squeezing oil paint out of a tube. The lines you draw
will seem raised.

Line drawn with the Airbrush tool

THE PEN BRUSH TOOL
The Pen brush tool draws a solid stroke.

Line drawn with the Oil Brush tool
The Grain option defines the stiffness of the brush
bristles. The available options, from softest to stiffest,
are Silk, Soft, Medium, and Hard. With stiffer settings you will see more highlights in the brush strokes
from the (imaginary) bristles.

Grain pop-up menu for the Oil Brush

THE CHARCOAL PENCIL TOOL
Line drawn with the Pen Brush tool

MECHANICAL PENCIL TOOL

The Charcoal Pencil tool leaves greasy particles
under the pointer. Larger Size settings create a
chalk-like effect.

The Mechanical Pencil tool draws one-pixel lines.

Line drawn with the Mechanical Pencil tool
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Line drawn with the Charcoal Pencil tool

THE WET BRUSH TOOL
The Wet Brush tool draws with a very diluted
paint, like watercolor. When you paint with the Wet
brush, you produce a transparent stroke.

HINT This is great for using with the Charcoal
pencil for smearing and smudging like a traditional artist.

THE SPECIAL BRUSH TOOL
The Special Brush tool smears and smudges the
underlying pixels.

Line drawn with the Wet Brush tool

THE WARP BRUSH TOOL
The Warp Brush tool distorts the underlying pixels.
Use it on pictures to make a gooey mess!

Smears and smudges with the Special Brush tool

Options in the Special Brush pop-up menu

Smear Mode

Distortions to image created with Warp
Brush tool

The Smear mode leaves smeared color behind the
brush, as if you passed your finger over fresh paint. It
can give a pencil or pastel appearance if used with a
medium-sized brush and the FreeHandLine function.
Furthermore, parallel brush strokes in a certain direction can create an effect similar to brush strokes on a
canvas or photographic motion blur.

Use the mode pop-up menu to choose the direction of the warping.

Warp pop-up menu

Smear Mode distortion of the Special Brush Tool
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HINT Use the Smear mode with the AirBrush,
to take advantage of the smoothness of this
tool (powerful at the center and soft around
the outlines, if you keep the default setting).

Shift Mode
With the Shift mode, the brush smudges everything over which it passes, as if these elements were
blown away by the wind. You will get a completely
different effect than with Smear mode, which leaves
some essence of the original color. The Shift mode
moves portions of the image while more or less maintaining their link with the rest of the image.

Distortion using Shift mode for the Special
Brush tool
As with the Smear mode, use the AirBrush to
soften the effect of the Shift mode. With the
AirBrush, the link between the moved parts and the
rest of the image remains stronger. Don’t hesitate to
adjust the Opacity of the AirBrush tool to 100% with
a very high envelope so that the lightness of the
effect is sensitive only on the edges of your stroke.
Otherwise, shifted areas may appear blurred or transparent.

1. In the first approach, load an image, choose
Edit > Spare > Copy to Spare (0r press Shift+j) to
copy the image to the spare buffer.
2. Clear the screen. (or fill it with white, black or
gray.)
3. Select Impress mode and draw a series of very
short strokes or small dots adjacent to each other
with a round brush. The contents of the spare image
appear gradually in an impressionist style.

Impress for the Special Brush
used with a clear work area and a
Spare image
HINT You usually get the best results if your
paint spots are small).

In the second approach to using Impress, you use
the same image for the current image and the spare
image (rather than clearing or filling the screen). The
effect looks something like what you obtain with the

Mixer Mode
The Mixer mode is very similar to the Shift mode,
except your A Color is mixed in with the colors.

The Impress Mode
The Impress mode uses one of the colors in the
spare image to draw on the current image. It can create an effect similar to an impressionist painting
(hence its name). If there is no spare image, this mode
is ghosted (i.e., unavailable) on the pop-up menu.
Using Impress
You can use this drawing mode in two different ways.

Aura VT 4.8

Impress for the Special Brush
used with image on work and a
Spare image

Smear mode, but whereas Smear mode degrades
the image until it eventually becomes completely
blurred, Impress mode enables you to retain as
much precision as you want by adjusting the size of
the brush.

THE TEXTBRUSH TOOL
The TextBrush tool lets you create a brush using
one line of text and any TrueType® font in your
Windows font directory. You can set the text size and
give it special attributes like rotation, outlines, glows,
borders, and so on. Once you set your options, you
can paint with your text, one letter at a time, you can
apply the entire string as its own brush or you can
create a custom brush of the string. When you create
a custom brush, you can access all of the options
available to custom brushes, which are discussed
later.
You can learn methods for creating text effects
from the tutorial in the Aura content directory, Lesson
Three.
You enter your text in the input field near the bottom of the TextBrush panel. You can enter as much
text as you like, however, Aura creates only one line
for your brush. Notice the arrow button beside the
text input field. You can click on this arrow to access
a history of the text strings you’ve entered. Aura
saves this history with your configuration when you
elect to save that on exiting the program.

Text Options
Select the desired font using the pop-up menu at
the top of the panel. If you have a lot of fonts on your
system, a font selection window appears instead of a
pop-up menu. Use the vertical slider to search for the
name of the required font in the list. Select it by double-clicking it, or single-click and then click OK. You
can cycle through your available fonts by clicking the
up or down arrow buttons. Aura previews the text in
the project window with all its attributes. Bring the
mouse into the project window and the text attaches
to the cursor.
The Script pop-up menu is used with foreign
character sets.
The Size value represents the character size in
pixels and cannot be less than 4.

Plain Text
The XScale setting lets you change the character
width as a percent. A value of 100 percent is normal
and 50 percent would make the characters half as
wide. The value can exceed 100 percent and can
even be negative. Negative values will reverse the
characters horizontally.

XScale= -50%
The Space setting is similar to Track (discussed
below) except that it is absolute and not relative to a
character’s width. A value of 0 applies normal spacing. If you activate both options, Aura averages
together their effects.

Space= 25%
The Italic setting applies a slant to your characters. Positive values slant to the right and negative to
the left.

Tool panel for the Text
brush

Italic= 99%
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The Rotate setting rotates the text by the given
angle in degrees. The rotation occurs around the
center of the text line. Positive values will rotate the
text counter-clockwise and negative values clockwise.

Rotate= 25%
The Track setting modifies spacing between characters relative to the character size. A value of 100
percent gives normal spacing and 0 places the characters on top of each other. Negative values reverse
the order of characters.

Track= 85%
The Opacity setting sets the amount of transparency to apply to the text. A low value makes text
barely visible and 100 gives totally opaque text.

Opacity= 50%

The Border setting draws a border of 1 to 16 pixels around characters using the color to the right of its
button. Essentially, it is a filled version of Outline that
retains the A color for the text interior. The value
defines the border thickness in pixels. You can change
the border color by clicking the color-selection button.
Border and Outline are mutually exclusive.

Border= 5
The Glow setting creates a glow from 1 to 48 pixels around the characters. The value defines the glow
thickness in pixels. You can change the glow color by
clicking the color-selection button.

Glow= 15
To activate a text parameter, click on its button.
The button then becomes highlighted. You also can
activate a parameter by changing its value, either by
entering a new value or using its mini-slider. Aura
applies only active parameters to the text brush you
create. To deactivate a parameter, simply click on its
highlighted button. If you edit an input field and then
press the Enter key, your cursor will automatically
jump to the next input field. Click the Reset button to
reset all parameters to their default values.

The Text Input Field
The Outline setting creates an outline of the text
with a completely transparent interior. The value
defines the width of the outline in pixels.

Outline= 2

Using the text input field at the bottom of the
panel, you can enter a single line of text for your text
brush. All standard editing operations specific to Aura
text fields apply to this text line. When the cursor is in
the text field, you can automatically create the brush
using the current settings by pressing the Enter key.
The B button, beside the input field launches a panel
that you can resize to enter a longer string of text;
Aura still allows you to enter only a single line.

The Smooth setting antialiases the edges of characters. The value indicates the power of the smoothing applied. High settings make the text blurry.

Smooth= 10
Text input field on the Tool panel
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Using Your Text
When you select Letter and drag your mouse,
Aura adds the text one character at a time using your
active drawing function. When you select Word,
Aura attaches the entire string of text to your mouse
pointer like a brush. When you drag your mouse,
Aura paints with the entire string.

LMB. If you select Rnd, Aura applies random letters
from your text until you release the LMB. For all of
these options, when you release the mouse button
and begin again, Aura applies the text string from the
beginning (except, as you might expect, random).
HINT You can use the Stroke Recorder filter
to animate the TextBrush when you apply your
text with the Letter option. See Chapter 8:
Filters for information on using the Stroke
Recorder.

Text brush using Letter

Pop-up menu of animation options for
Text Brush
Text brush using Word
If you apply your text by Letter, you can select
animation options from the Anim pop-up menu near
the bottom of the Text tool panel. Choose Once and
Aura applies your string of text once while you hold
down the LMB. Choose Loop and Aura continuously
applies your text until you release the LMB. When
you choose Ping, Aura continuously applies your
text, and when it reaches the end of the string it
applies the text from the reverse direction. Aura continues cycling back and forth until you release the

You can create a custom brush (discussed later)
from your text settings, by clicking the Create Brush
button. The text string attaches to your mouse pointer,
just as it does when you select the Word option. You
can adjust aspects of the Custom Text brush as you
would for any other custom brush and you can apply
it just as you would apply any other drawing tool.
NOTE You cannot create a Custom Brush
with the Letter option; Aura automatically
applies the entire string as a brush.
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NOTE The numeric info to the left of the
Create Brush button indicates the length of
the brush in pixels.

still image, or it may be built up from a sequence of
images cut out from an animation. In the latter case,
the brush is called an animbrush.

Cutting out a Custom Brush
Aura offers a number of CutBrush functions on the
Main panel that you can use to create a custom
brush. From left to right, the four buttons are
Rectangle, Polygon, Freehand and Magic Wand.
NOTE Use the b key to toggle through the different

Custom brush created for text using Create Brush
option

The Text Tool Connection
When you paint with text, you can apply it with any
drawing tool, such as the line tool or the circle tool.
You can use the connection options to produce text
in a circle or on a spline, or connect Fade to size so
text starts out big and gets small. Lesson Three of
the tutorials will teach you how to work with text and
connection; you can find the tutorials in the Aura content directory.
The following images show some examples of how
you can manipulate text with the connection options:

CutBrush buttons on the Main panel
custom brushes.
Aura always takes the brush cutout from

Custom Brush tool on the Tool panel
the current image in the current layer. [The Custom
brush tool (Tool panel) is automatically selected after
this operation.]
Left: Changing the Size based on the Direction
Right: Changing Rotation based on Direction

CUSTOM BRUSHES

NOTE If you select another drawing tool or
choose a built-in brush after cutting out a custom brush, the new tool’s brush replaces the
custom brush. However, the custom brush will
reappear when you select the Custom brush tool.

In addition to pre-defined brushes, Aura lets you
cut out images and draw with them. This type of
brush is called a custom brush. When you draw in
the Color mode, Aura applies all custom brush colors
in the image. The custom brush may either contain a

The Rectangle CutBrush function cuts out everything located within the rectangle that you define by
dragging with your mouse. You can constrain the
area to a square by holding the Ctrl key while you
draw. This works just like drawing rectangles.
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the icon and then click in the area to be filled. This
works just like the Flood Fill function (Main panel). The
fill area spreads pixel by pixel (horizontally and vertically) to the bordering edges of the area. The border
is determined on a pixel-by-pixel basis.
You change the selected cutout area dynamically
by dragging your mouse pointer around the image.
When you are satisfied with the selection area, simply
release the mouse button.
Making a Rectangle CutBrush
The Polygon CutBrush function cuts out everything
located within the polygon that you define. It works
just like the Polygon Filled function (Main panel). You
define the starting point with the first click in the
working area. An elastic line then follows the movements of your pointer. Each successive mouse click
defines another vertex and a new elastic line begins
from that point. To complete the polygon, click the
RMB or press the Enter key. Aura draws a straight
line between the first and last vertex of the polygon.

NOTE This function shares the same fill settings as the Flood Fill function. Right-click the
button to open the Shape Settings panel.

Copying and Cutting the Brush
Generally, if you use the LMB to make the cutout,
Aura simply copies the selected image to form the
custom brush. However, if you use the RMB, Aura
cuts out the selected area and the area in the image
becomes transparent.

Making a Polygon CutBrush
The Freehand CutBrush function cuts out everything located within the freeform shape you define by
dragging your mouse. It works just like the Freehand
Filled function (Main panel). When you release the
mouse button, Aura connects the first and last points
of the line by a straight line.

Making a Freehand CutBrush
The Magic Wand CutBrush function is yet another way to cut out a brush. To use this function, select

Top: Magic Wand selection
Center: Magic Wand with LMB
keeps the image.
Bottom: Magic Wand with RMB
cuts the image.
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When you have a CutBrush function active, the
Tool panel will display some options. Here you can
change the LMB operation and make it cut out the
area. The Smooth setting will blur the edges of your
cutout based on the number of pixels you enter. A
larger number gives you more blurring.
AAliasing applies default smoothing to the edges
of your cutout selection and eliminates stairstep; for
AAliasing, you do not need to enter a Smooth value,
the default smooth action occurs automatically. When
AAliasing is not enabled (and you do not use
Smooth), the outline of your cutout selection will not
be smoothed.
Keep will keep your current CustomBrush settings. If you disable Keep, the cutbrush settings are
stored as a new CustomBrush, when you enable
Keep, your settings replaces the current
CustomBrush.

4. Double-click on the layer bar to select all
frames, or right-click and choose Select All. A solid
yellow bar will appear beneath the layer bar indicating
that all frames have been selected.

Select All to select animation layer
5. Select the Rectangle CutBrush function and
drag out a rectangle over the project window.

Settings for the CutBrush on the Tool panel
Drag out rectangle and cut out animbrush

Animbrushes
In addition to static custom brushes, you can also
use a series of images, creating an animated brush or
animbrush. These animbrushes are used in the same
way as any other brush.
To create an animbrush:
1. Start Aura with the standard configuration. To
create an animbrush, you need to cut it out from an
animated layer; we’ll use one from the Aura content
directory. (For more information on animated layers,
see the chapter on Layers.)
2. From the File menu, choose Import >
Sequence, and select an anim file.
3. After you load the animation, you will see it displayed as a layer on the Layers control panel.

Animation layer created after importing sequence
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6. Because you have selected more than one
frame, Aura asks if you want to cut out an
Animbrush. Click Yes. If you don’t blink you will see a
progress gauge flash by, Aura cuts all of your selected frames and attaches them to the cursor for painting.
7. Click the CLR function button to clear the
screen.
8. Slowly drag your LMB over the project window.
You’re drawing with video as the brush cycles
through each frame of the anim you cut out.

Drawing video with the animbrush

9. Clear the window again, then click your LMB
and paste each image on individual frames.
Notice that at the bottom of the CustomBrush
panel there is a slider that lets you scrub through the
animbrush. You can see a preview in the project window. Wherever you leave the slider, is where the animbrush begins in the sequence as you paint.
Beneath the slider and the Reset button, Aura also
lists the frame number and total frames for the animbrush.

Tool panel for Custom Brush

Right: Using slider to
scrub the animation

If the Brush mode button is activated, the brush
retains its color. However, if Stamp is active, the
brush’s color is entirely replaced by the A color. If there
is no variation in opacity in the brush, the entire brush
shape will appear as a solid color with the Stamp
mode. Also notice that more options appear in the
drawing modes menu when you choose Stamp. The
pop-up menu for drawing modes appears when you
select the Color button under the various drawing
tools. (For more about drawing modes, see Chapter 6.)

Left and Right: Example frames from animation
You can use animbrushes in all operations that
use custom brushes (drawing, perspective, filters,
etc.). If you drag an animbrush, your brush will cycle
through each image. If you apply a function that uses
a custom brush to a series of frames in an animation
layer, one of the images of the animbrush will be
applied in each selected frame. Animbrushes also
use the same settings as normal custom brushes.

Custom Brush Options
Once you have a custom/anim brush, you can use
it to draw with any drawing function. You can draw
with the brush in the same way as with any other
tool. Lesson Two in the Aura content directory shows
various approaches to working with custom brushes.

Left: Brush mode for the Custom Brush tool Right:
Stamp mode for the Custom Brush tool
When cutting out a brush, you often will select
superfluous transparent areas surrounding the part of
the image you are actually interested in. These transparent areas are useless when drawing since you are
essentially drawing with nothing. The Optimize button crops out all transparent areas around the
perimeter of the brush and, therefore, reduces the
memory required by the brush. (See also the discussion on the optimize function on the Edit Brush panel,
discussed later.)
The Handle setting determines where the brush is
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attached to the mouse pointer. If you choose
Custom, crosshairs will appear on the brush. (Note:
You must place your mousepointer in the project window.) Drag your LMB to position the handle wherever
you wish.
If you have an animbrush, the Anim pop-up menu
determines how the individual frames are cycled after
each is pasted.
None applies only the first frame in the animbrush
as you move your mouse.
Once cycles through all of the animbrush frames
once when you apply the brush. After the brush
applies all images, it applies nothing to the work area
until you release the mouse button and apply the
brush again.
Start&Once cycles through all frames of the animbrush once, then the repeats the final frame. When
you apply the brush again, you apply only that final
frame of the animbrush. You can return to the beginning of the animbrush by using the slider beneath
Anim menu, (discussed below).
Loop cycles continuously through the animbrush
until you release the LMB.
Ping-Pong cycles through the animbrush until it
reaches the end and then it cycles back to the beginning. The brush continues to ping-pong through the
animbrush frames until you release the LMB.
Random cycles randomly through the various
frames of the animation.
Pressure uses the amount of pressure applied by
your stylus, if you use a tablet, to determine how to
apply the animbrush. With a low amount of pressure
you apply only the first frame; as you increase pressure you cycle through the animation.
Speed is similar to Pressure. If you move your
mouse slowly, you apply only the first frame and as
you increase speed you begin to cycle through the
animation.
Direction uses the direction of your mouse pointer
or stylus to determine which frames the brush
applies. If you travel in one direction then the brush
applies the same frame, but when you change direction, the brush cycles to the next image.
The slider beneath the Anim pop-up menu indicates the current animbrush frame. That is, the frame
that will be pasted upon the next use. The information display at the bottom will indicate the frame /
total frames.

The slider for current animbrush frame
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Editing the Brush
Clicking the Edit button at the top of the Options
tab on the Tool panel will display the Edit Brush
panel. This is where you can make changes to the
active custom brush.

The Edit Brush panel
Applying Changes
As you change variables on the panel, Aura shows
a realtime preview of your change in the project window. Any changes you make to the brush on the
panel need to be applied before you can use them.
This is done by clicking the Apply Changes button.
Resizing the Brush
At the top of the panel, the first three buttons in
each row allow you to quickly change the size of the
brush.

Resize buttons on the Edit Brush panel

On the top row, the X2, Xx2 and Yx2 buttons will
double the size, double the vertical size and double
the horizontal size, respectively. On the lower row,
the /2, X/2 and Y/2 buttons will halve the size, halve
the vertical size and halve the horizontal size.

Custom brush after Rotation
clockwise (lower button). As with resizing, you also
have the option of entering a precise rotation value in
the Angle field.
Brush after %2
You also have the option of entering precise pixel
values in the Width and Height fields.
To graphically alter the brush size:
1. Click the Width or Height M button. A bounding box will appear.
2. Drag your LMB to resize the bounding box. To
constrain the resizing to your initial direction, hold the
Shift key.
3. The resized brush will be displayed temporarily
after you release the mouse button.
4. Click Apply Changes to apply the new settings
to the brush.
5. Activate the Lock Aspect option to force the
numerical and graphical changes to maintain the
same aspect ratio.
You should be aware that in most cases enlarging
and then reducing a brush will likely not result in a
brush identical to the original. However, you can
achieve some interesting effects by scaling down a
brush and then scaling it back up.

To graphically rotate the brush:
1. Click the Angle M button. A bounding box will
appear.
2. Drag your LMB to rotate the bounding box. You
can achieve more precise adjustments by moving the
mouse pointer away from the center of rotation.
3. The rotated brush will be displayed temporarily
after you release the mouse button.
Flipping the Brush
The fifth buttons from the left will flip the brush
horizontally (top button) or vertically (lower button).

Flip buttons on the Edit Brush panel

Rotating the Brush
The fourth buttons from the left will rotate the
brush 90 degrees clockwise (top button) or counter-

Rotation buttons on the Edit Brush panel

Custom brush after Y Flip
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Other Brush Editing Options
You can apply a border around the non-transparent perimeter of the brush by setting the Border
value, in pixels, to the desired thickness.

Custom brush after B color added

OPACITY MAPPING
Custom brush after applying border
The right-most button on the top is an Optimize
function. While this option is active, it crops out all
transparent areas around the perimeter of the brush.
This differs from the Optimize function on the Tool
panel in that it does not change the underlying brush
data.

You can use opacity mapping to define degrees of
transparency for different areas of the brush. When
this option is not selected, (which is the default status, your brush applies the image with the image’s
original opacity levels.

The Optimize button on the Edit Brush
panel
The right-most button on the lower row takes the
B color and fills in the transparent areas. Areas that
are 100 percent opaque (i.e., non-transparent) will not
be affected. You can toggle this option on or off.
Opacity mapping area on the Edit Brush
panel

The B-color fill button on the Edit Brush
panel
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To edit the Opacity Mapping, click on its preview
window in the Edit Brush panel. The Opacity
Mapping panel launches; this panel offers the same
options as the Opacity Mapping panel available for
the Colors tools, which is discussed in depth in
Chapter 5. You can apply Opacity Mapping to any
custom brush whether you created it from an image
or from text.

Tool panel. Each tool’s bin will have some predefined
default brushes you can use, but you can also save
brushes you create for later use. A brush, in this
case, is essentially the result of all of the settings on
the Options tab. The number in red is the size of the
brush.
To use a brush in the bin, simply left-click on it. It
will become the active brush. If you right-click on the
empty part of the bin, a menu will appear allowing
you to add your current brush to the bin (Put Brush)
or reset the bin to the default brushes (Default
Brush).
NOTE When you open the menu, it selects
Put Brush by default; you can simply click
your RMB on the empty part of the bin to add
the current brush to the bin.

Custom Brush with text using Opacity Mapping

BRUSH BINS
All of the drawing tools (airbrush, penbrush, etc.)
have a brush bin, accessed on the Bin tab on the

For custom brushes, an Import Brush menu item
appears. If you select it, a file requester will appear
where you can load an image file into the bin.
If you right-click directly on a brush, you will have
some additional options.
Add Brush - Adds the current brush to the bin.
Get Brush - Uses that brush. Same as clicking
with LMB.
Swap Brush - Swaps the active brush with the
brush in the bin.
Delete Brush - Deletes the brush in the bin.
Default Brush - Resets the bin with the default
brushes. Be careful with this one, there is no way to
undo!
NOTE Custom brushes, particularly animated
ones, can use a lot of disk space if stored in
a bin. To free disk space, delete them if they
will not be used again.
For custom brushes, Export Brush and Mode
menu items appear. These are shortcuts to the File >
Export > Brush and File > Mode menu items.

Default brushes in the brush bin
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Notes:
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Chapter 5:
Working With Colors
You have many ways to choose the colors with
which you draw. With gradients you have the power
to paint with a rainbow of colors.

THE COLOR PALETTE PANEL

The Color Palette visibility button on the Menu panel
You can use the Color Palette panel to adjust the
A or B color using RBG or HSL color models. There
also are several special color picking features.
There are two buttons at the top of the Color
Palette panel – no matter which tab you select. The
active button determines whether changes affect the

A color on the left and
B color on the right

A Color (left) or B Color (right) on the Color Palette
panel. (Click the desired color button to activate it.)
NOTE Clicking the button already selected
places you in the color picking mode, discussed later.

COLOR SYSTEMS
All colors can be described using a set of basic
components and there are several color systems,
each with its own color theory. The systems are distinguished by the components that each uses to
describe colors. On the Slider tab, you can adjust
colors using the RGB and HSL color systems.
Modifying the color settings in one system automatically modifies the color settings of the other.

The Slider tab showing
RGB and HSL sliders
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In RGB, color is described by red, green and blue
components. The value of each component is
between 0 and 255. This mode is considered
additive, because the three components create white
at their maximum values.
In HSL, color is described by hue (pure color), saturation (amount of color) and luminosity (brightness).
The value for hue is between 0 and 359 (i.e.,
degrees) and between 0 and 255 for the other two
components.
The color bands beneath the color system sliders
show you the colors available at different slider positions. If you see a color you want in a slider bar, simply drag the slider over the color.

On the Mixer tab, there is a mixer area where you
can create your own hues, by mixing the A Color with
existing colors. This allows you to act like a traditional
painter and choose a color without using the sliders
and without restricting yourself to the hues in the
palette or an image.

Using the Picker Tab
Using LMB to smear colors with
the A color in the Mixer area

Left: The picker area on the Picker tab
Right: RMB pop-up menu for the picker area
On the Picker tab, you can vary a selected color
parameter using the slider on the right edge. Choose
the Picker color mode with the pop-up menu that
appears when you click your RMB over the picker area.
To choose a color, drag your LMB over the pick
area and then release to pick a new color. As you
drag, the corresponding RGB or HSL values will
appear at the bottom of the panel – click on this display to cycle between RGB and HSL.

Drawing in the window with your LMB smears all
colors together, adding in the A Color as well.
If a color you want appears on the mixer window,
hold your Ctrl key and drag your LMB. The corresponding RGB or HSL values will appear at the bottom of the panel – click on this display to cycle
between RGB and HSL. Release your mouse button
to choose a color.
If you right-click the mixer area, a special pop-up
menu appears.

Mixing It Up

Mixer area on the Mixer tab

Aura VT 5.2

RMB pop-up menu for the Mixer area

The top section lists some default mixers and any
user-defined mixers.
NOTE Any change you make will affect the
selected (checked) mixer. Don’t worry about
default mixers because you can easily revert
back. However, you may want to save any
custom mixers.
If you select Pick Color, you choose the color in
the pixel beneath your mouse pointer when you open
the menu.
Clear Mixer clears the mixer area to the B Color.
To start a new mixer, select New Mixer. Aura then
prompts you for a name. You can copy the currently
active mixer using the Copy Mixer menu item. Use
Rename Mixer to rename the currently active mixer,
or Delete Mixer to delete it.
You can save the current mixer area as a file for
later use by selecting File > Export Mixer. These
files can be reloaded later by choosing File > Import
Mixer and you can actually import any Aura supported image. However, the mixer window is only about
170 x 97 pixels. Images are loaded starting in the
top-left corner and any excess gets cropped off.

Color Palette bin
between RGB and HSL.
You can add a color to the palette by scrolling
down to the end and then clicking in the blank (grey)
area. This will add the current A Color.

An image loaded into the mixer area
To return to the default mixers, choose File >
Default Mixers. Note that this will delete any userdefined mixers you may have created, so you may
want to save them first.

Color Palette Bin
Selecting colors on the Bin tab is somewhat like
choosing a color from the Picker tab, except colors
are displayed in an array of color squares. To choose
a color, drag your LMB over the palette area and then
release to pick a new color. As you drag, the corresponding RGB or HSL values will appear at the bottom of the panel. Click on the display to toggle

RMB pop-up menu for the bin palette area
If you right-click the palette area, a special pop-up
menu appears on which the top section lists some
default palettes and any user-defined palettes.
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NOTE Any change you make will affect the
selected (checked) palette. Don’t worry about
default palettes because you can easily revert
back.
However, you may want to save any custom
palettes.
Selecting Replace Color will replace the color
square beneath your mouse pointer with Color A
when you open the menu.
Swap Color lets you swap the colors of two
palette squares.
To Swap Color, first click on a palette color – it
becomes highlighted. Next, move your mouse pointer
over the other color and right-click. Choose Swap
Color and the two colors will swap positions.
Spread generates a continuous range of hues
between two colors in the palette.
To Spread, first click on a palette color – it
becomes highlighted. Next, move your mouse pointer
over the other color and right-click. Choose Spread
and the palette squares between these two colors will
now contain a gradation of hues. (Note that both colors must already exist on the working palette.)
To remove a color from the palette, right-click over
it and choose Remove Color.
To start a new palette, select New Palette. Aura
prompts you for a name. You can copy the currently
active palette using the Copy Palette menu item.
Use Rename Palette to rename the currently active
palette, or Delete Palette to delete it.
You can save the current palette as a file for later
use by selecting File > Save Palette. These files can
be reloaded later by choosing File > Load Palette.
Generally, you will load a color palette file that you
saved previously. However, you can actually load any
file that Aura recognizes. If the file is an indexed color
format, its color palette will be loaded. If the file is not
color indexed, like an AVI or JPEG file, Aura computes the palette based on the image (first frame, if
an animation).
To return to the default palettes, choose File >
Default Palettes. Note that this will delete any userdefined palettes you may have created, so you may
want to save them first.

dropper
method, which allows you to select any color used
on any pixel visible on the interface.
To choose the A or B Color:
1. Click on the A/B Color button. Your mouse
pointer changes to an arrow with a question mark.

Cursor changes to question mark

2. If you want to set the A Color, drag your LMB.
For the B Color, drag your RMB.
As you drag around the screen, several things
happen. First, the A or B Color changes based on the
color of the pixel beneath your mouse pointer.
Second, if you’ve selected the Slider tab on the Color
Picker panel, the RGB and HSL values will also reflect
the values for the color of the pixel beneath your
mouse pointer.
3. Release your mouse button when you find your
desired color.

Picking the A and B Colors
As discussed in Chapter 1, Aura has two colors
available at any one time, and they are displayed on
the color selector button on the Main panel. The center color is the A Color and the surrounding color is
the B Color. The A Color is the main drawing color.
The B Color is used only when a particular function
requires a second color.
HINT Use the Color: Invert A/B command,
mapped to the n key, to swap the two colors.
You can change either color using the eye

Aura VT 5.4

NOTE Simply clicking your mouse (after you
have clicked the A/B Color button) will
accomplish steps 2 and 3 in one motion.

Picking Other Colors
Many panels throughout Aura allow you to select
colors. These settings will have color selector buttons. These selectors work just like the A/B Color
button except you will set only one color and you can
use either mouse button.
HINT Make sure the desired color is visible some-

where. You may want to use the Picker, Mixer
or Bin tabs on the Color Picker panel.

Generally, you will want this function active.

Gradients
The Gradient option controls how paint is poured
into filled shapes. It allows you to fill with several colors instead of using a single uniform color. Some of
the drawing tools, like the AirBrush, give you
an option to draw with gradient ink.
NOTE When you draw with a gradient, Aura
applies the gradient based on the density of
the ink used. Zero density corresponds to the left end
of the gradient and 100 percent corresponds to the
Two color selector buttons at the
top of the Layers panel

FILLED
SHAPE SETTINGS
When you select a filled drawing function, the Tool
panel becomes the Filling Shape panel. Here you can
set how you want the shape to be filled.

Gradient area on the Filling
Shape panel

Filling shape panel
The pop-up menu at the top of the panel lets you
choose the drawing modes for your shape; the drawing modes are discussed in Chapter 6.
The Smooth setting will smooth out the transition
from the fill to the edge. Higher settings will blur the
edge.
Opacity controls the transparency of the fill. Lower
values will be more transparent.
AALiasing (i.e., Antialiasing) smoothes the edges
of the fill. This eliminates stairstep or jaggies.

LMB Gradient presets on
the Filling Shape panel
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right end.

ent fill, discussed later.

When the Gradient option is active, you can click
your LMB on the gradient display and select from
various presets. (Note that APen and BPen refer to
the A and B Color.) You also can select any custom
made gradients you create from this popup.
The Result display shows the combination of the
Color and Alpha displays. You can independently
adjust the Color and Alpha settings.
Filling With a Gradient
If you use a Gradient fill, only an outline of your

Aura fills shape with gradient
When you release your mouse button, the gradient
colors will fill the shape.
Beneath the gradient bar on the Filling Shape

Making the fill shape outline
shape appears when you first use your selected filled
drawing function, (see Chapter 3).
Next, you need to drag out a vector. Generally, the
direction and length of the vector will affect the gradi-

Gradient options buttons
on the Filling Shape panel
panel are some option buttons that determine how a
gradient fills a shape.

Dragging out the vector
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Gradient fills from Left to Right: for linear, radial, mirror, surround, and square radial
Aura offers five different types of gradient fills: lin-

ear, radial, mirror, surround, and square radial.
Global Gradient Controls
If you click on the gradient display with your RMB,

RMB gradient panel
the Gradient panel appears. Here you can edit the
existing gradient, as well as create custom gradients.
The top three rows of buttons control global gradient operations. The pop-up menu at the top-left lets
you select from default presets and any gradients you
have created. This menu also determines the active
gradient to which edits are applied.
With the File pop-up menu, you can save a gradient to a file, as well as load one you previously saved.
You also can choose Default Gradients to reset the
available gradients to the default presets; however, be
careful because resetting erases any new gradients
and adjustments you’ve made.
To create a new gradient from scratch, click the
New button, then enter a name. To remove the active
gradient, click the Delete button.
You can copy the active gradient by clicking the
Copy button. The copy (or any other existing gradient) can be renamed by clicking the Rename button.
You can reverse the gradient by clicking the Invert
button.
The Noise value introduces a random grain in the
gradient. If you click or drag your mouse pointer over

Noise at 53% in the Result display

the color display, it changes the random seed value
and thus the random noise pattern.
Customizing the Color Component
A gradient always has at least two keys, one at the
beginning and one at the end. You cannot move
these keys, but you can alter them.
You can change an existing key by clicking on it. If
you click with your LMB, you are merely selecting it
as the active key.
Each key independently uses one of the three
Color modes indicated at the bottom of the panel.
The key can use a custom color (left), the A Color
(middle), or B Color (right). You can change the cus-

Color swatches at the RMB gradient panel base
tom color by clicking on the color swatch and selecting a color as you would normally.
If you click on a key with your RMB, a pop-up
menu appears that provides shortcuts to the color
mode settings, to picking a color and to deleting. You

RMB pop-up for color swatches
also can delete the active key by clicking the Delete
button at the bottom of the panel.

Adding and moving a key to the Color display
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You can add a key by simply clicking your LMB
beneath the Color display.
You can move interior keys (i.e., not the two end
keys) by simply dragging. This changes the placement of where the gradient actually reaches the color.
HINT If an interior key is active, it will jump to
your mousepointer position if you click your
RMB, but it will not jump past any other keys.
You can also change the transition between two
keys by moving the small triangle that appears
between two keys above the display. By default, Aura

The Alpha component for gradients

Top: Default transition position.
Bottom: Transition close to next key
If you place the transition point right on top of a
key, you create a sharp jump to the next key.

Sharp transition created by placing arrow over key
places the triangles equidistant from each key.
You can center a transition point by clicking your
RMB over it and selecting Center from the pop-up
menu. If you move keys, the transition points also will
move relative to the keys.
HINT Two identically colored neighboring keys
will create a solid color between them.

NOTE You cannot delete or move the starting
and ending keys.

alpha key by setting a new value in the Alpha input
field at the bottom of the panel. A value of 100% represents a completely opaque color, and a value of 0%
creates a completely transparent color. A color
becomes less visible as its alpha value decreases.
Aura uses a checkerboard pattern as the background.
NOTE The available controls at the bottom of
the panel are different if the active key is an
alpha key or if it is a color key.
If you right-click an alpha key, the pop-up menu
contains a shortcut to delete the key and set the
alpha value.

Brush Wrapping
The Brush Wrapping option lets you fill a shape
using the current brush. Aura gives several options
for filling the shape horizontally (Width) and vertically
(Height). The Stretch setting stretches or compresses the brush linearly so that it occupies the entire
Width or Height of the shape to be filled. The Tile
setting duplicates the brush to fill the shape. The
Wrap setting distorts the brush to fill the shape.

Customizing the Alpha Component
Editing the Alpha display works just like editing the
Color display, discussed previously. The only difference is that instead of picking colors for each key,
you set a specific alpha value.
NOTE The Alpha component affects only filled
drawing functions.

You can change the alpha value for the active
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Top: Stretch for Width and Height.
Next Page: Tile Wrap for Width and Height

Here is a simple filled rectangle using the default
opacity map settings. (Note that a checked background has been used to make the effect stand out.)

You cannot use Gradient and Brush Wrapping at
the same time. Any range application option is automatically deactivated when you select Brush
Wrapping. Similarly, all brush wrapping options are
automatically deactivated if you select Gradient.

Opacity mapping

Filled rectangle with default opacity map setting

Usually when you fill a shape, you use one or more
opaque colors. Opacity Mapping lets you vary the
transparency of the color(s) used. Shapes are no
longer uniformly filled with opaque color, but rather
with color of varying opacity (transparency) throughout the shape. The Opacity Mapping Preview shows
you what the current opacity map is. White indicates
opaque areas and black indicates transparent areas.

Notice how the rectangle’s color is totally opaque
at its bottom-right corner and totally transparent at
the opposite corner.

The Opacity Mapping Preview on
the Filling Shape panel

Opacity Mapping Panel
Click on the Opacity Mapping Preview to open the
Opacity Mapping panel. Here you can customize the
opacity map.

The Opacity Mapping Display shows the current
opacity map. Opacity variations are defined using the
X-axis and Y-axis curves. On the X-axis curve, higher
points have more opacity than lower points. The
default setting has 100% opacity on the right side
and 0% on the left. On the Y-axis curve, points on the
left have more opacity than points toward the right.
The default setting has 100% opacity on the bottom
and 0% on the top. The combination of both curves
yields opaque areas in the bottom-right and less
opaque areas in the top-left.
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Editing Opacity Curves
The Opacity Mapping Display contains a representation of the opacity mapping. It continuously shows
the changes made to either curve. You can drag
existing points on either curve with your LMB to
adjust the opacity mapping. However, the end-points
can be moved only along the edges. You can add
new points by clicking your LMB in the curve edit
areas and dragging your mouse. Release your mouse
button when the point is correctly positioned.

Opacity Mapping with Linear curves for X
and Y axes

The pop-up menu between the curve displays lets
you choose the type of curve you want to use for
Opacity Mapping. When you select the Linear option,
the curves abruptly change direction from point to
point. For smoother transitions, you can select
Spline, while Polynomial creates a curve based on
an algebraic equation. You can set the type of curve
differently for each axis. For example, you can use
Linear for the X axis and use Polynomial for the Y
axis.

Opacity Mapping with Linear Y axis and
Polynomial X axis
If you right-click in a curve edit area, a pop-up menu
appears. The menu gives you a short cut to the curve
types and to invert options. The Invert X flips the curve
horizontally and the Invert Y flips it vertically.

Opacity Mapping with Spline curves for X
and Y axes
Curve edit area RMB pop-up menu
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The Copy to button will copy the active curve to
the other curve. The active curve is the one with the
highlighted point – only one point can be highlighted.
The Swap button will simply swap both curves.
Preset Curves
In the lower-left corner, you will find the presets function. You can cycle through the available presets by
clicking the up and down arrow buttons. If you find one
you like, just click on the little preview window.
Application Modes
The buttons at the bottom of the panel control
how the opacity map fills the shape. You use the X
and Y buttons to select the application mode of the
Opacity range for each curve.

X-axis curve after Invert X
If you click your mouse button directly in the
Opacity Mapping Display, you will get mountain
curves for the Linear option or bell-shaped curves for
the Spline option. If you continue to drag your
mouse, you will move the position of the tip points,
which correspond to the densest area.

Preset curves preview and arrow buttons

Linear curves after clicking in the Opacity
Mapping display area
Global Edit Functions
Using the File pop-up menu, you can save and
load Opacity Mapping curves. You can also reset the
panel to its default settings from this menu.
The FlipX and FlipY buttons will flip both curves
horizontally and vertically.

Application mode buttons for Opacity range
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NOTE You can deactivate a curve by clicking
once on the active mode button. Then, no
button is highlighted.
With the uniform mode, Aura applies the
curve uniformly over the entire shape to be
filled, as a function of the largest dimension (width for
the X curve or height for the Y curve) of the shape.

Linear mode results
a vector (an elastic line). When the vector is pointing in
the desired direction, release your mouse button.

Uniform mode
With the elastic mode, the opacity range follows
the outline of the filled shape. The curve is
stretched or compressed so that its width or height is
equal to the width or height of the shape to be filled.

With the centrifugal mode – available only for
the X curve – Aura applies the opacity range
around a center that you define. After you draw your
shape, drag your mouse to define a vector (an elastic
line). Your initial dragging point will be the center.
When the vector is the desired length, release your
mouse button.

Dragging the vector for the Centrifugal mode

Elastic mode
NOTE The elastic mode may generate some
irregularities in the range when used on complex shapes that have sudden changes.
The linear mode is similar to the uniform mode,
except you can define the direction and extent.
After you draw your shape, drag your mouse to define
Centrifugal mode results
NOTE The modes for the X and Y curves can
be set independently.

Dragging the vector for Linear mode
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Chapter 6:
Drawing Modes and
Paper
DRAWING MODE SELECTION
Generally, you apply color with the drawing tools (airbrush, pen, etc.) using drawing functions (freehand line,
lines, etc.). However, you also can lighten, blur, colorize,
and apply other effects as you draw. Aura always shows
the current Drawing Mode in plain text on the pop-up
menu button at the top of the Tool panel. The default
mode is Color. Use this pop-up menu to select a different mode.

NOTE The available modes will vary depending on the current drawing tool.

SPECIAL ERASING FEATURES
When you draw with the LMB, you use the current
drawing mode. The RMB accesses the Erase drawing mode. However, if the Dry option is off (Tool
panel), you erase only the current stroke and do not
erase other areas of the frame. Otherwise, you use
the normal Erase mode. If your tablet has an eraser
tip, you can use it to erase as well. With these features, erasing is always available without having to
formally select the Erase drawing mode.

COLOR MODE
Aura uses the Color drawing mode by default when
you select a drawing tool. When you draw, you apply
the A color to the current image of the current layer.

Left: Color pop-up menu button on Tool panel
Right: Color pop-up menu button on Filling Shape panel

Color Mode over image in
current layer
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BEHIND MODE
The Behind mode paints only on areas that have
little or no opacity – that is, transparent areas.

Second tree cloned in Panto
Mode
To adjust the offset:
Behind Mode in transparent
areas of layer
For example, suppose you drew a pattern on a
transparent background and now you want to draw
on the background again without modifying the pattern. Using the Behind mode, you can draw as you
would normally on the transparent background, but
you can’t draw anything on the opaque pattern.
Furthermore, you retain the opacity variations that
smooth edges of the drawing. (For the opposite
effect, see the discussion on Channel Preserving at
the end of this chapter.)

1. Right-click the drawing function button (e.g.,
AirBrush, PenBrush, etc.) to display the Shape
Settings panel.
2. Click the Set button. Place your mouse pointer
over the approximate source area. Drag your LMB to
the approximate target area – an elastic line appears.

ERASE MODE
The Erase mode removes opacity, and color along
with it. Since this mode is always accessible using
the RMB, in most cases, you will not have to select
this drawing mode directly.

Elastic line source and target settings for Panto
3. Release your mouse button.

Erase Mode on current layer

PANTO MODE
The Panto mode – short for pantograph – lets you
clone (rubber stamp) one area onto another. When
you select this mode, a second offset crosshair pointer will appear. This marks the source area. The two
pointers will move in unison as you move your
mouse. When you draw, Aura copies everything that
is under the offset pointer to under the normal pointer.
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The X and Y settings indicate the horizontal and
vertical offset between the two points, in pixels. You
can edit these fields directly.
The Panto mode is extremely useful for touching
up scanned images. For example, if you want to
erase dust or scratches on a portrait, simply move
the second pointer to an intact area of skin and then
draw with the normal pointer over the piece of dust.
Aura copies the intact skin and makes the dust disappear.
HINT Use the airbrush to help make the
copied area as smooth as possible.

MERGE MODE

LIGHT MODE

The Merge mode lets you rub through one image
into another. Merge is similar to Panto, except that
the source area is on a separate image. It is sort of
like stripping off paint from an old dresser to reveal
the underlying wood grain. The source image must
be stored on Aura’s spare image (an internal scratch
image buffer). If you do not have a spare image,
Merge mode is ghosted (i.e., unavailable) on the popup menu.

The Light mode is the opposite of the Shade
mode. The brush lightens all colors. Several passes
over the same location will increase the effect. This
mode has no effect on totally transparent areas.

Lightening the current image

COLORIZE MODE
Merging a spare image with
the current image
To use the merge mode:

1. Load an image and choose Edit > Spare >
Copy to Spare (or press Shift+j). This copies your
image to the spare image buffer.
2. Clear the image, then select a drawing function
and a medium size brush. The AirBrush is ideal for
this work.
3. Select the Merge mode and draw a few
strokes. You’ll see the contents of the spare image
appear under your brush.
You can use the Merge mode to limit the effects of
filters to specific areas of an image. If you copy an
image to the spare image buffer before applying a filter, you can subsequently merge parts of the unaltered original image into the filtered one. Use Merge
with text and generate texture in your characters.

SHADE MODE
As its name suggests, the Shade mode shades
(i.e., darkens) colors wherever the brush passes.
Several passes over the same location will intensify
the effect. This mode has no effect on totally transparent areas.

The Colorize mode colors everything with the
brush, using the foreground color. Colors are modified during this operation, but their luminosity (brightness) remains the same – you get the same effect
using light grey or dark grey. However, since saturation may also be effected, sometimes you get colors
that are more intense than the original colors.
NOTE The effect of this mode is not cumulative, so painting the same area repeatedly will
not change your initial result.

TINT MODE
The Tint mode is similar to the Colorize mode,
except Colorize maintains only the luminosity of colors in the original image, whereas Tint maintains the
color, luminosity and saturation. The Colorize mode
will color grays (in red, green, etc.), but the Tint mode
will have no effect on grays. The Tint mode is sometimes more efficient than Colorize, particularly
because it respects gray levels.
NOTE The effect of this mode is not cumulative. Several passes over the same location
with the same color will not change your initial
results.

GRAIN MODE
The Grain mode adds a subtle random grain to
your image as you draw. It is ideal for creating granular texture in unnaturally perfect computer images.
Basically, it adds random amounts of shaded pixels
to an area. The foreground color has no effect on this
mode.
Darkening the current image
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NEGATIVE MODE
The Negative mode lets you paint using the negative of the underlying colors.

Before Grain

After Grain

SMOOTH MODE
The Smooth mode generates a slight blur with
your brush. Big brushes and/or repeated passes over
a location can increase the effect of this mode.
Smooth smoothes the pixels of an image, smoothes
the grain of a digitized image, or creates field depth
on 3D images, which often seem to lack depth.

Areas of image painted with Negative
mode

SHARP MODE
The Sharp mode sharpens an area by increasing
the contrast of adjacent pixels. Use this to bring out
details in a blurry image. This mode can cause
unwanted pixelization.

Line with Smooth mode blurs the edge of the curve

NOISE MODE
The Noise mode draws with the foreground color,
like the Color mode, but adds random noise instead
of varying opacity. Thus, if you use a brush with color
at 100% opacity – usually when Power is 100% –
Aura applies a solid color. If that same brush has
areas with lower opacity, like along the edges, Aura
applies those areas as random noise instead of lower
opacity.

Before

After Sharp mode
HINT Lower the Power of the drawing tool to
allow more control over the amount of sharpening.

EMBOSS MODE
The Emboss mode makes an area appear raised
or stamped.

Before
Left: AirBrush, Color mode, 100% Power.
Middle: Noise mode, 100% Power. Right:
Noise mode, 50%
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After Emboss mode

SOLARIZE MODE
The Solarize mode blends an area with the negative of itself.

information and multiplies the inverse of the A color
and the image colors. The resulting color is usually
lighter. Screening with black leaves the color
unchanged. Screening with white produces white.
The effect is similar to projecting multiple photographic slides on top of each other.

CHANNEL PRESERVING

Before

After Solarize mode

SATURATE MODE
The Saturate mode increases the amount of color
saturation in an area. You can use this mode to
enhance the colors in a washed-out image.

UNSATURATE MODE
The Unsaturated mode decreases the amount of
color saturation in an area. Use this mode to help
tone down an image with oversaturated areas of
color that seem unnatural.

ADD MODE

You can independently preserve color channels,
which prevents operations from affecting them. The
channel buttons are located on the menu panel. From
left to right, they are the transparency, red, green and
blue channels. When active, the button will be highlighted.

Channel buttons on the menu panel
If you preserve the transparency channel, your paint
will adhere only to places where is there is already
paint. This allows you to replace color – but not opacity – as you draw. The transparency channel is similar
to a stencil (alpha mask), but is effective only where
there is already some color. This works quite well with
layered images. (Using the transparency channel is the
opposite of the Behind drawing mode.)

The Add mode takes the color information in each
channel and adds your A color to the image colors.
The resulting color is usually lighter. Drawing with
black leaves the color unchanged. Drawing with white
produces white.

SUB MODE
The Sub (subtract) mode subtracts the image colors except for the A Color. The resulting color is usually darker. Drawing with black leaves the color
unchanged. Drawing with white produces black.

MULTIPLY MODE
The Multiply mode takes the color information in
each channel and multiplies the A color by the image
colors. The resulting color is usually darker.
Multiplying any color with black produces black.
Multiplying any color with white leaves the color
unchanged. When you’re painting with a color other
than pure black or white, successive strokes with a
painting tool produce progressively darker colors, if
Drying is active. The effect is similar to drawing on an
image with magic markers.

SCREEN MODE
The Screen mode takes each channel’s color

Replacing color by drawing with the transparency
channel
For example, suppose you drew a red pattern on a
transparent background and you want to draw details
in the red without modifying the background. If you
preserve transparency, you can draw as you would
normally on the opaque red, but you will not be able
to draw anything on the transparent background (i.e.,
where opacity is zero). Furthermore, opacity variations
that smooth edges are retained on the outlines of
your red pattern.
If you preserve any of the RGB channels, operations will not affect the preserved channel(s) no matter what color you may be drawing with.
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PAPER TEXTURES

CUSTOM PAPER TEXTURES

Aura can adjust the density of the ink you apply, as
if you were drawing on a textured surface. You activate this feature by clicking the Paper button on the
menu panel.

You can create custom paper textures since they
are just image files whose brightness levels are used
to apply the paper texture – color information is
ignored. The files must be saved to the Papers subdirectory of the main Aura directory. Tileable images –
those that can be placed side by side without a visible seam – work best, but this characteristic is not an
absolute requirement.

The Paper button on the menu panel
To select a paper texture, right-click the button.
The Paper panel will appear.

‘Spunky’ as a custom paper texture

Paper panel, examples of paper textures, and paper
settings
Click on any icon to select that paper texture. Use
the scrollbar to see more icons.
You can adjust the Hardness setting to vary the
overall effect of the paper texture. The Invert option
will invert the texture effect.
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NOTE When you create your own paper textures, they are available only after you restart
Aura.

Chapter 7: Layers
The concept of layers in a paint program is common these days. With layers, you organize your work
by placing various elements of your images in different layers, making it much simpler to modify elements
without affecting others. Layers are placed on top of
each other and mixed in realtime taking into account
the transparency of each element.
Aura, however, takes layers a giant step beyond
the norm by allowing you to manipulate them in time.
Layers can be animated, even holding moving video!

THE LAYER PANEL
The Layer panel defines the beginning and duration of each layer in time, and the order in which layers are overlaid. (If you are starting from a blank new

working page, you will see only a single layer.)
If the Layer panel is not visible, click its visibility
icon on the menu panel.

The Layer button the menu panel

TIMELINE ANATOMY
The global timeline is the graduated scale at the
top of the panel. By default, Aura lists frame numbers
from 0, increasing to the right. You can use this as an
overall reference in determining the length of a project.

Timelines on the Layer panel
Local timelines appear beneath their corresponding layer bars. These will not necessarily match the
global timeline, if, for example, the layer starts at a
frame other than 0.

LAYER LIST
The Layer panel in the Aura interface

Aura lists layers beneath the global timeline. The
order of the layers determines how Aura composites
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them to form the resulting image. Each layer can
have independent transparent properties, which are
interpreted from top to bottom. The top layer in the
list forms the foreground and is placed in front of all
other layers. If any part of the top layer is transparent,
the contents of the next layer in order can be seen
behind it, and so on through the stack of layers. Each
subsequent layer appears behind the layer above it,
but in front of all others, until you reach the last layer.

A video layer is similar to an animation layer
except you can apply only limited changes to this
layer. You create a video layer by importing an animation, image sequence or video clip without checking
the PreLoad box in the import requestor, as discussed in Chapter 2. Video layers cannot be sized or
affected by filters, however they have a built-in alpha
channel and can be moved in time and looped. Use
video layers to bring in loopable elements or background video.

Video layer
NOTE Non-PreLoaded layers load instantly
no matter how large the file.

THE CURRENT FRAME
Four layers in the layer list: Untitled, Tut06-1, Tuto6-2,
Tut06-3
You use the slider to the right of your layers to
scroll the list vertically and the slider beneath the layers list to scroll horizontally.
NOTE Although not technically a layer, the
background, discussed later, may be visible
beneath all layers.

You can identify the position of the current frame
by a white rectangle on the global timeline. Two vertical red lines border the left and right sides; these
lines indicate which images in the various layers are
included in the current frame. To change the current
frame, simply click on a frame on the global time line.
You also can scrub the layer by clicking the LMB and
dragging in the global timeline.

LAYER TYPES
Aura offers three types of layers: image, anim and
video layer. An image layer contains a single still
image, represented by a blue bar. Note that an image
layer can occupy more than one frame, just like an
animation layer. However, that layer uses the same
picture for every frame. This is the default layer type;
when you first create a layer, it is an image layer.
The current frame input field displays the number
of the current frame. You can enter a value here to
jump to a specific frame.
Image layer
An animation layer contains a sequence of
frames, represented by a series of thumbnail images.
For this kind of layer, the picture can vary in each
frame. You create an anim layer, by clicking the RMB
on the layer itself and selecting Make Anim.

Animation layer
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NOTE You cannot select a current frame that
is before the beginning or after the end of the
current layer (discussed later).

THE LAYER COLUMN
The Layer column holds the layer icon, which usually shows a thumbnail of the image for the layer at
the current frame.

last frame in time, for any layer. For the Layer heading, the first two numbers state the location of the
selected layer’s first and last frames, while the third
number shows the last frame for that selected layer.
You can change the time format to a timecode
format (HH:MM:SS:FF.field) by clicking on the Layer

Layer title bar with time references in Frames
Above the layer icon is the layer name. To the left
of the layer name is the minimize/maximize layer button. When the layer icon is visible, the layer is maximized and the button displays a minus sign. Click this
button to minimize/maximize all selected layers. The
button changes to a plus sign for a minimized layer.
Click it again to maximize the layer.
The Layer column also has an associated pop-up
menu, which you can bring up in a number of ways:
• Click the downward-facing triangle button
• Click the layer name or
• Right-click the layer icon

column heading. Here, you can choose between
Time (i.e., frames), the default, Timecode, or Fields
(if you use a project with fielded data).

Layer title bar with time references in timecode format

Layer column pop-up menu
The functions of this menu are discussed later;
however, generally, they affect the layer beneath your
mouse pointer when you open the menu and not the
current layer.

Timecode Format
By default, Aura shows all time references in
frames. In the titlebar for the Layer panel, you will see
a heading for Project and one for Layer and beside
each heading there are three numbers. For the
Project heading, the first two numbers indicate the
location of the project’s first and last frames, and the
third number is the length of the project. That is, the

Click on the Layer heading to
change the time format
NOTE When you use Timecode, the frames
(i.e., FF) will increment to seconds based on
the project’s Frame Rate setting. If you use
Fields, the field value will be 0 or 1. The timecode displayed for NTSC projects using a Frame
Rate of 29.97 will be in dropframe format, whereas a
Frame Rate of 30 invokes a non-dropframe timecode
display.
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THE CURRENT LAYER

Adding Layers

Aura carries out all operations (drawing, applying
filters, etc.) in the current layer. This layer is light gray
in the list.
Aura gives you several ways to select the current
layer. First, you can simply click the layer icon. You
also can use your Up and Down Arrow keys to
change the current layer. Finally, you can click anywhere in a layer’s local timeline – this also selects the
current frame.

There are two basic ways to add more layers: add
a new blank layer or import an image/sequence. To
add a new blank layer, just click the New button on
the Layer panel or choose New Layer from the Layer
column pop-up menu. The new layer automatically
becomes the current layer. For information on importing a file, see Chapter 2.
Normally, Aura places your new layer above the
current layer in the list. However, if you hold the Shift
key while you click the New button, Aura places the
new layer below the current layer.

SELECTING LAYERS
You can select layers for certain operations like
deleting and moving. Click on a layer icon to select it.
To add to the selection, hold the Shift key and click.
You can also select a layer and Shift-click to select a
layer several layers away, which also will select all layers in-between. To add certain layers to the selection
without selecting layers in-between, Ctrl-click the layers you want.
You can select all layers by choosing Select All
from the Layer column pop-up menu or by doubleclicking any layer icon. Choosing Select Layer will
select the current layer as well as the layer beneath
your mouse pointer when you opened the menu.
You can deselect layers by clicking in the Layer
column, outside of the layer icon.

LAYER OPACITY
In controlling opacity at a pixel level, you also can
set the overall opacity for each layer. Do this by
selecting the layer and then adjusting the Opacity
setting. Each layer can have its own independent setting and Aura updates your changes to layer opacity
in real-time.

The Opacity field on the Layer panel

LAYER ORGANIZATION AND
SIZING
You can add new blank layers or create additional
layers by importing existing image files. Layers also
can be graphically organized any way you want. This
includes changing a layer’s position in time as well as
its playback length (duration).
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NOTE Initially, new layers created by the use
of the New button will be named Untitled. If
the new layer was created by loading in an
image or animation sequence instead, the
layer will be named for the file loaded.

Naming Layers
The very first item in the Layer column pop-up
menu indicates the name of the layer. If you select
this, a dialog box appears that you can use to
change the layer name. Click on OK to set the new
name or click on Cancel to keep the old name.
Naming layers is important when organizing your
project; you should name each layer as it is created.
You also can set up a keyboard shortcut to rename a
layer.

Copying and Pasting Layers
You can copy selected layers to an internal buffer
by choosing Copy Selected Layers from the Layer
column pop-up menu. You can copy layers to the
buffer and delete them from the project in one step
by choosing Cut Selected Layers. Unless you select
and highlight a layer, the Copy Layer and Cut Layer
options appear ghosted in the menu. If you select a
layer but do not highlight it, (a yellow border on the
layer icon), simply left click it again.
If you have no layers selected, you can paste the
layers in the buffer above the current layer by choosing Paste Layers. If you have layers selected, the
pasted layers replace the selected layers. You can
even cut, copy and paste layers between different
projects.
In the same menu, you have an option to
Duplicate Layers. When you select this option, you
automatically copy and paste any selected layers.

Deleting Layers
You can delete the current layer (and other select-

ed layers) by clicking the Delete button. (Alternatively,
you also can choose Delete Selected Layers from
the Layer column pop-up menu.)

STENCIL OPTIONS
To the left of the Layer column is the Stencil column. The top button turns the layer into a stencil.
Yellow indicates an active stencil and gray means
inactive. The lower button inverts the stencil effect.
White represents the default stencil and black represents the inverted stencil.

The Stencil shapes restrict you from painting outside
of the shapes. Note that on the Layer panel, the two
stencil layers are hidden
NOTE You may want to hide stencil layers,
which is discussed next.

NOTE Aura’s selection functions, discussed
in Chapter 3, also allow you to limit the
paintable area.

HIDING LAYERS
When you turn a layer into a stencil, Aura disregards its position with respect to the stenciling operation. The Stencil acts as a mask and therefore, on
any other layer in the project, you can paint only
where there is paint in the Stencil layer. You can have
multiple stencil layers, which are aggregated together.
You also can use animated layers as stencil layers,
which allows you to create moving masks.
When you turn on Stencil, you also activate the
global stencil option on the menu panel. You can use
this option to globally turn the stenciling function on
or off.

If you click the S at the top of the Stencil column,
a pop-up menu appears where you can turn off
Stencil for all layers (Clear all stencil) or toggle the
invert state for any stencil layers (Invert all stencil).
Creating a stencil
You can create a stencil from any tool or shape in
Aura, and you can use special effects such as opacity mapping, paper or filters for interesting results. You
must first create the shape that you want as your
stencil on a new layer, along with any special effects
that you want to include. After you’ve made all of
your adjustments, you convert the layer to a stencil.
Once you have converted a layer to a stencil, you
cannot make any changes to the stencil image unless
you turn off Stencil.

To the left of the Stencil column is the Hide Layer
column. When a layer is visible, the box in this column is green. If you click the box, the box turns red
to indicate that the layer is hidden.

The Hide Layer box on the Layer panel
NOTE You cannot hide the current layer. If the
layer you want to hide is the current layer,
select a different layer as the current layer first.
You also can use the Layer Display mode to display just the current layer or all layers (normally).
Clicking the Display button (or pressing = ) will toggle
between All and Current.

The Display mode on the Layer panel
If you click the H at the top of the Hide Layer column, a pop-up menu appears where you can unhide
all layers (Show all Layer) or hide all layers, except
the current layer (Hide all Layer).
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NOTE The display mode and hide-layer
attributes affect which layers will be used
when exporting an image or a sequence (but
not saving a project). Hidden layers will not
show up in an exported image or sequence.

bar will follow the movement of the pointer by
stretching or contracting.

CREATING ANIM LAYERS
Creating a new layer using the New button creates
an image layer by default. To convert it into an animation layer, choose Make Anim from the Layer column
pop-up menu. (Alternatively, you can also choose
Make Anim from the pop-up menu that appears
when you right-click over the layer bar.)

Drag the handles on either side of the layer to adjust
the layer duration
Image vs. Anim Layers
When you adjust an image layer, you simply modify
the duration of the still image display in the project.
For example, if you move the start tab to the left, the
image display starts earlier in the project. If you move
it to the right, the image display starts later in the
project.
When you adjust the duration of an anim layer, you
must decide how you want Aura to interpret the
change.
Increasing a Layer’s Length
When you release the mouse button after increasing a layer, a special panel appears.

The Make Anim option in the Layer column pop-up
menu
NOTE The Make Anim menu item will not
appear if the layer is already an anim layer.
Also, if the layer was not preloaded (i.e., it is
uneditable) a Change to PreLoad Layer
menu item appears, which allows you to convert the
layer to a regular anim layer.

Adjusting the Starting Frame and
Duration
Both image and anim layers have a starting frame
and duration. The position of the left edge of the layer
bar – relative to the global timeline – indicates the starting frame and the length of the bar indicates its duration. You change the starting position of a layer by simply dragging the layer bar left or right with your mouse.
To move the entire layer in time, just drag it left or
right with your mouse, but don’t drag on the beginning or ending handles, described below. Generally,
you cannot make a layer begin before frame 0. however, if you hold the Shift key down, you can position
a layer to begin in a frame preceding 0.
To change the duration of a layer, you must drag
the handles located on either side of a layer. The layer
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Increase Layer Length panel with
Stretch and Interpolate activated
If you accept the default settings, which use
Stretch with Interpolate, Aura modifies the duration
of the layer and attempts to keep the data (relatively)
intact. It does this by interpolating missing images
when you increase the duration of the layer, or it
superimposes a number of images by degrees of
transparency from the original layer into the same
image if you reduce duration. If you choose not to
Interpolate, Aura changes the layer duration by
duplicating frames.

Instead of the Stretch mode, you can use the
Repeat mode, which has several options.
The Loop option fills the added frames by repeating the existing layer starting with its first frame. It
continues to loop through the layer, from start to finish, until no additional frames are needed.
The Ping Pong option is similar to Loop, except
the repeating starts with the end of the existing layer,
works back to the front, front to back, etc. – back
and forth, like a ping pong ball.
The Hold Last option simply repeats the last
frame to fill the increased duration.
HINT Use Hold Last to get a brush to hold
position after you animate it; for example, a
logo that flies in and stops. Stretch the layer
out for as long as you want to hold the logo in
the project and select Hold Last.
Decreasing a Layer’s Length
When you decrease a layer’s length, a special
panel appears.

will see a dark gray bar extend from the end of the
layer bar.

Loop modes for anim layers on the Layer panel
NOTE For operations like merging, Aura
treats the repeating frames as if they actually
exist.
NOTE You can increase or decrease layers
when you have multiple layers selected. Aura
applies your changes to all of the selected
layers.
Rearranging Layers
As explained previously, layer order determines
how Aura interprets your final result. As such, layer
order is extremely important. You can easily rearrange
layers by dragging layer icons.
To move a layer in the list:
1. Place your mouse pointer over the layer icon,
and press and hold your LMB.

Decrease Layer Length panel with
Stretch and Interpolate activated
You can either use the same Stretch and
Interpolate settings, as discussed above, or simply
trim off the end frames using Cut Frames.

Layer Loop Mode
The end of your project is the last visible frame
that can be from any layer. Layers that end before
this normally just stop and are not considered for
frames past their end. You can change this using the
layer Loop option. This option, in effect, can automatically fill the frames after the layer’s end, up to the
length of the project.
The option has three settings. Repeat mode will
simply loop through the layer, from start to finish, over
and over. Ping Pong repeats by using the end of the
existing layer, then working back to the front, front to
back, like a ping pong ball. The Hold Last option
simply repeats the last frame.
When you set a Loop mode other than None, you

Place mouse pointer over the layer icon
2. Drag your mouse pointer up or down, as
desired. As your pointer passes between layers, a
thick yellow line will appear. This indicates a dropping
point for your layer.
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To merge a layer in the list:
1. Place your mouse pointer over the layer icon,
and press and hold your LMB.

Drag mouse pointer; thick yellow line indicates a
dropping point
3. Release your mouse button. The layer is moved
to the new position. Your project window will be
updated immediately to account for the new layer
order.

Release mouse button to place layer in new position
NOTE You can move layers when you have
multiple layers selected. Aura applies your
changes to all of the selected layers.

Merging Individual Layers

2. Drag your mouse pointer over the target layer.

3. Release your mouse button and a dialog box
appears. You can just use the default Color mode to
paste the layer over the target layer or use the popup menu to select a different drawing mode. (Drawing
modes are discussed in Chapter 6.) The Stamp
option will stamp the layer using the A Color. Activate
the Erase Source option if you want to delete the
source layer after it is pasted.

You can merge layers using the drag-and-drop
method. When you work on a project, you usually
create several layers in which you will place various
elements of your image or sequence. Thus you can
modify one part of your project, without affecting the
other parts. When you finish working on some elements in your project, you can collect them in the
same layer. Then you can act on several elements at
the same time without constantly repeating the same
operation.
NOTE Merging a layer over another is like
making the entire layer into a custom brush.
You can paste it down using many of the
same drawing modes.

Above: Merge Layer dialog box offers options for pasting the layer
Below: Tree and sun from Tut06-3 pasted into Tut06-2
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NOTE Merging layers also takes into account
preserved channels, discussed in Chapter 6.

Other Merging Options
The Merge button contains some other merging
options.

The Merge pop-up button on the Layer panel
If you have multiple layers selected, you can
choose Merge Selected. They will be merged top to
bottom so you may want to re-order them before
using this function.
Merge Visible will merge all of the layers that are
not hidden.
Merge All flattens the contents of all layers into a
single layer. The duration of the resulting layers is
equal to the total duration of the project. This means
that if you apply this function to two layers, one of
which contains frame 0 to frame 10, and the other
contains frame 8 to frame 20, the resultant image will
go from frame 0 to frame 20. Only the first layer will
be present from frame 0 to frame 8, both layers will
be overlaid from frame 8 to frame 10, and only the
second layer will be present from frame 10 to frame
20.

FRAME EDITING
In addition to globally adjusting the position and
size of layers, you also can move individual frames
around in time, as well as insert new frames in a layer
or delete existing ones.

Selecting and Unselecting
Frames
You can reorganize layers and you also can cut
and paste frames within the same layer or between

layers. To use these commands you must first select
one or more frames. Do this by simply dragging on
any layer’s local timeline.
You also can select the current image and subsequent images in the layer by pressing on the
Shift+Right Arrow keys, or you can select the current
image and previous images in the layer by pressing
on the Shift+Left Arrow keys.
To deselect this selection, click nearly anywhere in
the layer list area.
To select all images in a layer, choose the Select
All from the Layer column pop-up menu, or doubleclick on the layer itself. To select a specific frame,
choose Select Image from the menu.
NOTE If you use the CLR function, discussed
in Chapter 1, on selected frames, they will all
be cleared.

Cut and Paste Operations
After you select your frames, right-click over the
layer bar. Choose Copy Selected Images to store
the contents of the selection in a temporary memory
buffer. If you’d like to also delete the frames, choose
Cut Selected Images.

Right-click over layer bar to copy or cut selected
images
Once you’ve copied or cut your frames, the
Paste Images menu item becomes available.
Choose it to insert frames before the current frame.
Note that if part of the current layer is selected, the
pasted frames will replace those selected frames.
You also can choose Duplicate Selected Images
from the menu to add one or more copies of the current frame. Aura inserts the duplicate frames after the
current frame in the layer. When you use this command, a dialog box appears that lets you set the
number of frames to add. If you want to add only
blank frames, you can choose Insert Images.
You can reverse the order of selected frames in
one step by choosing Reverse Selected Images
from the pop-up menu.

Drag on the layer’s timeline to select one or more
frames
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USING THE LIGHT TABLE
Aura includes a light table (also called onion skinning) that can simultaneously display up to seven
frames before and after the current frame of an anim
layer. (If the current layer is a still image layer, this
option is not available.) The before-after frames are
for reference only and are ghosted (displayed with
variable opacity depending on their distance from the
current frame). Each layer can have its own independent light table settings.
You can set the opacity of the light table for each
layer; the default value is 50%. To adjust the opacity,
RMB on an anim layer, and choose Light Table
Parameters. Or RMB on the light table’s toggle button
(the middle button) to launch the Light Table Opacity
panel.

NOTE To leave the Light Table active without
showing previous or future frames, drag the
previous or future cells in the Light Table display to the center. You cannot turn off the
preview cells by clicking the center cell.

THE PROJECT WINDOW
BACKGROUND
The project window is where you draw and perform your image editing chores. The default is none,
which appears to be black but is actually complete
transparency or no color. You can change the background using the Color pop-up menu located in the
top-left corner of the Layer panel.

The Color pop-up menu on the Layer panel

The Light Table option activated on the Layer panel
You specify the number of frames to show by
clicking in the light table cells to the left or right of the
center button. (You also can drag your pointer over
the cells.) The selected cells turn yellow. When you
select cells to the right, Aura shows frames that follow the current frame. When you select cells to the
left, Aura shows preceding frames. You even can
select cells on both sides, if desired.
Clicking on the center button toggles off the light
table. Clicking it again restores the selected cells. To
specify whether the Light Table displays in front or in
back of the current frame, go to the menu at the top
of the screen and select Project > Light Table, then
choose between Front or Back.
NOTE Ghosted frames are for reference only;
you can draw only on the current frame and
layer.
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Two color settings on the Layers panel can affect
the background. They are indicated on the two color
selection buttons to the right of the pop-up menu. If
you select Color from the pop-up menu, Aura uses
the color shown on the left button. If you select
Checked, Aura creates a checkerboard pattern with
both colors for the background.

Checkerboard pattern for background

HINT A Checkerboard background works
well when it is critical to be able to see the
transparency between layers and the background.

NOTE When exporting an image or
sequence, the background is included as part
of the saved image. However, if the None
option is used with a 32-bit export file mode, like
TGA 32, Aura saves the transparency of the various
layers as an 8-bit alpha channel.

VIEWING AN ANIMATION
To view your animation, you can use the VCR controls near the top of the panel or you can scrub the
timeline. The play button in the middle of the VCR

Preview controls on the Layer panel

preview is built in 4:4:4 RGB color space with an
alpha channel. A YUV preview is built in 4:2:2 YUV
color space without an alpha channel. A YUVA preview is built in 4:2:2 YUV color space with an alpha
channel
To display timecode over your preview, activate
Show TC. Enable Play All to play all frames in your
project; frame rate will be disregarded. Disable this
option to play the preview at the correct frame rate
for the project; the preview may drop some frames.

Remote Panel for Previews
You can run a preview by clicking on the play button or choosing Windows > Remote Panel. The
Remote Panel opens, and here you can change settings while your preview runs. You also can change
your project’s navigation functions while a preview
runs (e.g., navigator panel, Project windows buttons
such as Pan, Zoom, Fit, 1:1, and shortcuts like Alt +
LMB/RMB).

controls launches a remote control. From the remote
control you choose the options for running your animation in the work area.

Preview Settings
Aura offers three types of previews that work with
the remote control: RealTime, Proxy, and Render.
You select a preview setting by clicking your RMB on
the play button, or choosing Windows > Preview
Settings. You also can launch this panel by clicking
on the Proxy bar in the main menu.
The RealTime preview creates an animation on
the fly and always reflects the current state of your
project. Frames are dropped, if necessary, to achieve
the projects frame rate.
The Proxy preview is created while you work in
Aura. The preview file is stored in the temp directory,
and frames that are not yet rendered are built during
the playback.
The Render preview is created before the playback and saved on disk. The next time you play your
project, Aura re-renders only frames that have
changed since you saved the project.
Aura also offers the Format option, which lets you
choose the colorspace for your preview. An RGBA

Remote control to play previews
Interfaces
Two interfaces are available on the Remote panel.
The L, or layer, mode plays the entire project or a
selected sequence. The R, or range, mode plays the
range that you define by using the M in and M out
(Mark In and Out) buttons, which are available only in
Range mode.
The speaker button enables or disables sound
during the preview. The clockwise button enables or
disables Loop mode. So, if you want the preview to
repeat when it reaches the end, activate Loop mode.
Scrubbing the Project
You can scrub along the project by using the slider.
The default position of the slider represents the current frame.

The Preview settings panel

The Proxy bar on the main menu

• Use the RMB to scrub and keep the current
frame when your release the slider.
• Use the LMB to scrub and change the cur
rent frame to cursor position when you release
the slider.
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VCR Buttons
The VCR buttons should be familiar. The upper
row contains the basic controls: Previous Frame,
Play, Next Frame, and Stop. The lower row lets you
jump to the beginning, rewind, fast forward, and jump
to the end. Also, you can RMB over the VCR buttons
to open the Preview Settings panel.
Keyboard Shortcuts
Keyboard shortcuts let you override the remote
panel:
Esc stops playback and Aura returns to the
current frame position
Space/Enter stops playback and Aura jumps
to the current slider position
When you play a preview, the Aura interface is
locked, so only the Remote Panel is active. However,
you can use Alt + LMB/RMB during preview playback.
Frame Rate
The buttons below the VCR controls let you
change your frame rate while you play your preview.
Double-click on a setting to change the frame rate
value to the current project frame rate. Click with the
RMB to enter a specific frame rate in an input field.

Scrubbing the Timeline or a
Layer
Scrubbing the timeline means that you drag your
cursor along the timeline and see the project play in
the work area as you drag. You can drag with your
RMB and when you release it, Aura returns to the
original frame you selected before you scrubbed.
Drag and release with the LMB and Aura selects the
last frame under your cursor.
You also can scrub a layer, so that you see only
the action of your selected layer in the display area.
Drag the mouse down, and you change the current
layer. Move outside of the layer panel to return to the
original layer. Drag with the RMB, and the preview
shows only the action of the current layer.

The Auto Fit pop-up menu on the
Layer panel
the magnification to show the first and last (filter)
keys. Fit to Sound will adjust magnification to the
length of any sound clip that you’ve loaded.
You also can change the layer magnification by
placing your mousepointer over the Z button (located
beside the Auto Fit button) and dragging left (zoom
out) or right (zoom in). If you zoom out, you will see
more of your layers at one time and the interval corresponding to a frame will become narrower. However,
since the size of the frame thumbnails remains constant, not all of them will appear.

USING AUDIO
You can load the audio from AVI, WAV and MOV
(Quicktime) formats into an Aura project. Simply click
on the pop-up menu button (downward-facing arrow)
and select Load Sound. The audio will play when
you play your project. (Aura also lets you load audio
from RTV formats.)
Once the file is loaded, a waveform graph will fill
the layer bar area. You can use this as a reference for
events occurring in the audio file.

Layer Display Magnification
The Auto Fit pop-up menu is in the top-right corner of the Layer panel beneath the background color
options. The menu items allow you to quickly adjust
the layer magnification. Fit to Project will adjust the
magnification to fit the entire project. Fit to Layer will
adjust the magnification to the length of the current
layer. Fit to Image is the maximum magnification. Fit
to Selection will adjust the magnification to the
length of the selected frames. Fit to Keys will adjust
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The Audio pop-up menu on the Layer panel
If you need to offset the start of a loaded sound,
you can simply drag the waveform graph with your
mouse. For a more precise adjust, select Offset from
the pop-up menu. In the pop-up dialog, enter the offset in seconds. Activating Lock in the pop-up menu
prevents you from being able to drag the waveform
with your mouse.

If you activate the Audio Jog option on the popup menu, you can hear the sound as you shuttle
through your project by dragging your mouse pointer
over the global timeline. This option offers you a few
menu items: None if you prefer not to hear audio,
Scrub Only to hear audio only when you scrub the
file, and Always to hear audio when you scrub or jog.
To clear a loaded sound, select Delete Sound
from the pop-up menu. This will remove the sound
from your project, but not affect the actual file on your
hard drive.
NOTE Audio is exported with the AVI, and
QuickTime file formats. Aura also exports
audio with the RTV file format.
NOTE If your audio device is not free, this
may prevent you from being able to load a
sound file. Also, Aura may continue to use the
audio device until you exit, even after the sound file is
deleted from the project.
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Notes:

Aura VT 7.14

Chapter 8: Filters
Filters carry out complex operations such as creating relief, smoothing, and transparency as a function
of the color, on one or more images. There are two
types of Aura filters: integrated (built-in) and external
(plug-ins). With the Aura plug-in architecture, you can
add new filters, new functions, and new tools to your
software. A number of plug-ins are supplied with
Aura.

INSTALLING AND REMOVING
PLUG-INS
All plug-in files stored in the Aura Plugins directory
are automatically installed when you start the program. Plug-in files are grouped by type by placing
them in subdirectories of the Plugins directory. To add
new plug-ins, simply copy them into a suitable subdirectory. To remove a plug-in, move the appropriate
file out of the Plugins directory or delete it.

APPLYING FILTERS
You access Aura filters from the Filters menu.
Initially, you will see the groups of filter types. Just
navigate down from the group to select the desired
filter. Generally, a new panel will appear when you
select a filter.
You apply a filter to the current image or to selected frames in the current layer by clicking the Apply

Aura Filters menu
Filter button on the filter panel. Most filters include a
preview window that previews the effect of the filter
on a thumbnail image, if the Preview option on the
panel is active. This display changes as you modify
the filter settings. If the preview doesn’t update, click
the preview window. A few filters use the project window for previewing.
NOTE With most filters, you are allowed to
have only one panel open at any one time.
Selecting a different filter will close the previous filter’s panel before opening the new one.
NOTE To apply a filter to only a portion of
your image, use a selection function or use a
stencil layer to indicate a target area.
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ANIMATED FILTERS
You can keyframe many of the filters. That is, you
can set different values at different frames. Aura will
automatically compute any needed values between
the keyed frames.
NOTE Not all filters may be keyframed. Filters
are keyframable if they have a variable. If you
select a keyframable filter, it shows up in the
local timeline of the currently selected layer.
Keyframable filters are marked with the icon
in this manual.
There are several buttons you should be aware of
on the Layer panel.

Mosaic filter with a keyframe bar in the Layers panel

2. Click on the plus sign (+) to the left of the filter
name, Mosaic, to expand the keyframe bars. Initially,
keys (short for keyframes) are created at frame 0
using the filters default values for each of the filter’s
animatable parameters.

The Create+, Delete+ and Auto Key buttons on the
Layer panel
Clicking the Create+ button creates a key at the cur
rent frame for all of the parameters of the
currently active filter. Clicking the Delete+
button deletes all selected keys.
The Auto Key button controls the Auto create key
mode. Generally, numerically changing a
parameter will automatically create a key for
that parameter only.
HINT We generally recommend that you keep
the Auto Key active.

Mosaic filter with expanded keyframe bars for default
values

3. By selecting a different current frame and then
adjusting any of the filter’s parameters, you create
additional keys, but for only the changed parameters.
(Note that Auto Key is active.) Here, we created a
new key for only the Mosaic Width parameter. Note
how the top keyframe bar indicates where a key
exists for any of the filter’s parameters.

To select a key:
Click the plus sign on the keyframe bar. If you click
the top-most plus sign, all of the parameter keys for
that frame will be selected. You can select multiple
keys in different frames by holding your Shift key.

To Keyframe a Filter:
1. Select the desired filter from the Filters menu.
Here, we selected the Mosaic filter. Notice that the filter name appears in the layers list beneath the current layer and at frame 0, there is a keyframe bar that
looks like a plus sign (+) between two white handles.
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Mosaic filter with a key for Width parameter

4. Like a regular (image) layer bar, you can move a
keyframe bar in its entirety by dragging it left or right.
If you drag the top keyframe bar, all of the lower bars
will move in unison.

You also can drag an individual parameter independently. Notice how the top keyframe bar updates
to reflect the new key positions.

Clearing a Keyframed Filter

Moving the Mosaic filter keyframes

Keyframe Data

5. It is important to remember that all of this animates only the filter parameters. To actually add the
filter, you must apply it. To apply the filter only at a
certain frame, select it as the current frame and click
the filter’s Apply Filter button. To apply the filter over
a range of frames, select them as usual using the
layer’s local timeline. The appropriate values at each
processed frame will be used.

Subframe Moving
You can drag an entire keyframe bar or individual
key with subframe accuracy. This allows you to have
keys that don’t reach the set value exactly at a frame,
but rather, at some point in time between frames. To
do this, press and hold the Ctrl key after you click
your LMB to drag a keyframe bar or individual key.

Basically, there is no need to clear a keyframed filter from the Layers panel. It does nothing unless you
formally apply it. When you close the filter panel, the
filter keyframe bar will disappear. You can, however,
clear all of the keys by selecting Reset from the File
menu on the filter’s panel. Note that this clears all
keys, including the initial frame 0 keys. You also can
use Ctrl + R, which is the keyboard shortcut for resetting a filter. To learn more about keyframing filters,
refer to Lesson Ten in the Aura content directory.

You also can save and load the keyframe data
to/from a file from the File menu on the filter’s panel.
Note that the last used filter keys will be retained in
the project for future use.

Path Menu
Using the KeyFramer filter, you can create animated envelopes for certain types of parameters, like
position, rotation, etc. If you have defined a
KeyFramer path, you can use that data to control
some filters instead of creating the keys for the filter
the normal way. Such filters will have a Path menu.

Keyframe Pop-up Menu
If you right-click over the keyframe bar area a special pop-up menu appears. Selecting Create Key will
create keys for all parameters at the current frame.
Delete Key will delete selected keys. The Select All
menu item will select all the keys for all frames.

Right-click the keyframe bar for the pop-up menu
Copy Keys copies all of the selected keys to an
internal memory buffer. Cut Keys does the same
thing, but also deletes them. You can paste the data,
starting at the current frame, by choosing Paste Keys.

The Panning filter has a Path menu
The filter’s parameters that use the KeyFramer data
will be listed in the Path menu. Select the KeyFramer
path you wish to use. You can assign all (appropriate)
parameters to the same path using the All Keys item.
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BASIC FILTERS
Mirror
The Mirror filter allows you to flip the image horizontally, vertically or both.

The reflecting line for Mirror
Extended
The Mirror Extended
filter produces a reflected image similar to when an
object is reflected in a lake.
The Set button lets you graphically set the position
of the reflecting line over which Aura generates the
mirror image. The Pivot X and Y fields let you numerically set the horizontal and vertical position of the
reflecting line. The Angle field indicates the angle of
the reflecting line in relation to the picture. To adjust
the angle graphically, hold the Ctrl key and rotate the
line with your LMB. You can change the opacity of
the reflected image from the Opacity field.

Mosaic
Mirror panel with preview
NOTE Although you also can flip the current
image (without using a filter) with the [ (horizontal flip) and ] (vertical flip) keys, those function only on the current image. The Mirror filter also
can work on a range of selected frames in a layer.

The Mosaic filter produces a pixelized effect. The
image is replaced by a set of colored macro-pixels of
a definable size. Each macro-pixel color comprises
the average of the original pixel colors it covers. You
can pixelize an image with (Smooth) or without a
smoothing (Linear) effect selected using the Mode
pop-up menu.

Mirror Extended

Mosaic panel with preview

Mirror Extended panel
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The Width and Height fields set a specific size for
the macro-pixels. These two values may be different,
resulting in rectangular pixels instead of typical
squares. As the macro-pixel size increases, the image
becomes more undefined, therefore if you want to

retain the basic concept of your image, keep the
width and height values fairly low.

Panning

NOTE The preview window applies the effect
as if it were proportionately the project window. As such, the applied mosaic effect will
often be smaller than it appeared in the preview window.

Negative

Panning panel

Negative panel with preview
As its name implies, the Negative filter transforms
an image into its negative. The color of each pixel is
replaced by its complement (black becomes white,
red becomes cyan, blue becomes yellow, etc.). There
are no settings for this filter.

Noise

The Panning filter works like the Panning tool (Main
panel). It moves the contents of the image in a given
direction and distance. The image is tiled while panning, so as parts of the image go off one side of the
screen, they reappear on the opposite side. Use the
Panning filter instead of the Move tool when you need
to move a range of (selected) frames in a layer, when
you need to shift things a very precise amount, or
when you want to animate the effect.
NOTE The panning tool works well with layers that contain brushes or anim brushes with
alpha. Use it to move a keyed element or
logo brush.

Noise panel with preview
The Noise filter adds randomly dispersed pixels in
random directions and distances. Shift defines the
maximum distance of pixel shift. All pixels are shifted
at random by a distance between 0 and this value.
Intensity defines the percentage of pixels shifted in
the image. The amount of the effect increases as this
number increases.

The Mode menu lets you choose how to apply the
panning operation. Wrap repeats the image so that
you create a tiling effect. Shift offsets the image from
its original position.
You can set exact panning parameters by entering
the desired pixel values in the Pan X and Pan Y input
fields. You also can set these values graphically by
clicking the Set panning button. A large crosshair will
appear beneath the pointer when you are over the
project window. Drag your mouse button and an
elastic line will follow your pointer. This line shows the
direction and distance of the shift. The Pan X and
Pan Y values automatically update as you move the
pointer and the preview window will also change
accordingly. Release the mouse button when you are
satisfied with the applied shift.
NOTE For information on the Path menu, see
the Motion filter KeyFramer.
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Posterize

Wrapper
The Wrapper filter allows you to change the perspective of the current CustomBrush or Layer –
essentially pivoting it in 3D. When you select the
Layer mode, you affect the current image in the current layer. For the CustomBrush mode, you must
first either cut out or import an image to serve as the

Posterize panel with preview
The Posterize filter lets you set the number of tonal
levels for each color channel in an image and then
maps pixels to the closest matching level. A setting of
2, for example, yields six colors, two for each of the
RGB color channels.

Solarize

Left Side: Setting the XYcoordinates visually
Right Side: Wrapper panel with preview
custom brush. Then, when you apply the Wrapper filter, the brush is pasted down into the image.
You can numerically set the four corners of the
new perspective area using the four XY coordinate
pairs, but it is simpler to set them visually by clicking
the Set button. You also might want to choose Reset
from the File menu to make sure the shape begins
with each point in one of the four corners. Then you
simply drag each point from the corner to form the
new perspective shape. Points can even be dragged
off the image area. You can reposition the entire outline by holding the Ctrl key and dragging with your
LMB. Holding the Ctrl key and dragging with your
RMB will scale the outline.
As such, you cannot drag a corner to where the
image would, in theory, wrap over on itself. If you
attempt to do this, a large red X will appear on the
panel preview.
Changing the shape of your layer or custom brush
will create the illusion of perspective. If visible, you
also can drag the vanishing points to alter the perspective shape.
NOTE See also the discussion on vanishing
points for the Wrap tool in Chapter 3.

Solarize panel with preview
The Solarize filter takes a negative and a positive
of the image and blends them together.
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If the Apply option is set to Once, the default setting, Aura applies the layer or custom brush only
once. Setting this pop-up menu to Fill will tile the
image.

HINT If you blur the opacity of brushes and
animbrushes you can create a soft edge or
remove jagged edges.

Center Blur

Apply set to Fill for the Wrapper Filter
If you use the CustomBrush mode with an animbrush and you selected multiple frames, each brush
image is applied to one of the selected frames in the
layer.
NOTE You can use the Wrapper tool to composite a picture-in-picture at perspective, or
use it in conjunction with the Pixel Tracker to
paste brushes or video onto moving video. See
Lesson Ten in the Tutorials folder in the Aura content
directory.
Center blur panel with preview

BLUR FILTERS
Blur

The Center Blur filter creates a zooming affect by
sweeping a motion blur over areas outside of a
defined focal point.
The Center X and Center Y fields let you set the
coordinates in pixels for the center of the blur. The
Radius determines the image area that remains unaffected by the blur. Power sets the amount of motion
blur in percent.

ChromaBlur

Blur panel with preview
The Blur filter applies a smoothing blur effect to the
image. The amount of this smoothing is variable and
you can apply it to the Image or just its Opacity.
When applied to the Opacity, blurring mostly affects
element outlines.
Blur represents the power of the blurring, which
increases as this value increases.

Without Chroma Blur

With Chroma Blur

This filter is provided to assist with difficult chromakeying tasks associated with some digital video
sources. Blur represents the radius of the blur
applied.

8.7 Aura VT

Video recorded in certain DV formats (25 Mbps
variants like miniDV, DVCAM, and DVCPro) runs into
some issues when chromakeyed. The problem stems
from the 4:1:1 (NTSC) or 4:2:0 (PAL) digital sampling
used by these formats.
Simply stated, the black and white tonal values in
DV imagery are much better resolved than the corresponding color values are. The eye is relatively forgiving of this compromise. Reasonable sharpness in the
luminance channel suffices to convince us that the
image is sharp, even though the color channels are
heavily pixilated due to the lower sampling used.
Chromakeying, however, depends on chrominance
values in determining transparency; and DV’s chrominance values are decidedly “blocky.” A slight blur
applied solely to the chrominance channels reduces
the apparent “blockiness” of the color values, while
retaining the sharpness of the underlying luminance
values. This can produce a much better key.

Crazy Blur

Directional Blur

Directional Blur filter
The Direction Blur filter adds a motion blur to an
image, which makes the blur effect dynamic.
The Power field sets the length of the motion blur
in pixels. The higher the number in this field, the more
blur is applied to the image. The Direction field sets
the angle of the motion blur, which is the direction of
the blur.

Gaussian Blur

Crazy Blur panel with Impress option
previewed
The Crazy Blur filter combines blurring with special
processing effects. Use the Mode pop-up menu to
choose the desired effect. Below the Mode menu,
you enter the range in pixels for the radius of the
Crazy Blur effect in the Radius field. A lower radius
produces a less pronounced affect.
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Gaussian Blur panel with preview
The Gaussian Blur filter blurs the image using a different algorithm than the Blur filter. With Gaussian
Blur, the pixels are weighted unevenly in each
processed sample and decrease from the center to

edges according to a bell-shaped curve called gaussian. Gaussian Blur tends to provide a softer blur than
the Blur filter.
NOTE Gaussian Blur works best for keyframing a blur because it uses floating point values
for smoother transition over time.

COLOR FILTERS
Black and White

Radial Blur

When you choose the Black and White filter, you
convert a color image to a grayscale image. You
must set three parameters to achieve the effect
based on the following equation:
Y=R*CoefR + G*CoefG + B*CoefB.
You enter values in the fields for Red, Green,
Blue. To see your changes as you make them, click
on the Preview button. You can see your change to
each channel in the project window.

Color Adjust

Radial Blur filter

The Radial Blur filter creates an image blur similar
to the effect of a camera banking or tilting around a
focal point.
The Center X and Center Y fields let you specify
the pixel coordinates for the blur; these coordinates
are the center around which the blur and rotation
occurs. The Power setting determines the percentage of radial blur to apply to the image. A lower percentage applies a weaker blur and therefore tilts the
image less, and higher percentage will blur and tilt the
image more. Best Mode displays the blur using more
system resources, which gives you a better quality
blur. You can toggle this option on or off.

Use the Color Adjust filter to adjust the
Brightness, Contrast, Saturation and Gamma for
an image. With this filter, Aura applies the preview
feedback in your project window.
The Brightness field measures the amount of
white in your image and will accept positive or negative values – positive values add more white to your
image, while negative values will add more black.
Contrast refers to the difference in brightness
between the lightest and darkest areas of your image
as measured by levels of grey. Positive values produce greater contrast by removing greys and intermediate colors; negative values produce less contrast
by adding levels of grey.
Saturation refers to the intensity of color for each
pixel. Positive values produce greater color intensity
by removing grey so that colors reaches their purest
hues, while negative values tend toward greyscale as
more color is removed.
The Gamma setting adjusts the colors in the
image based on a curve that ranges between .01 and
5.0. Values below 1.0 darken the dark and midtone
areas of the image while increasing contrast. Values
above 1.0 lighten the light and midtone areas of the
image while increasing contrast.
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The Color correction graph

Color Adjust from left to right:
Default; Brightness -25%; Brightness 50%; Contrast
50%; Contrast -75%; Gamma 3.00; Gamma 0.30.

Color Correction
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The Color Correction filter allows you to adjust colors based on brightness regions. There are three
regions:
Highlights, Midtones and Shadows. These are
selected using the tabs at the top of the panel.
Master is a global setting encompassing all regions.
You might think of these as defining where the adjustments will be made.The middle portion of the panel
contains a series of sliders. These add or subtract the
corresponding color component: Temperature,
Magenta, Luminosity, Red, Green, Blue and Alpha
channel.
As you adjust any of the color components, you
will see corresponding color curves appear that
reflect your settings. Note that there is only a red,
green, blue and alpha adjustment curve.
Temperature, Magenta, Luminosity use the appropriate combination of these when adjusted.
Let’s jump down to the graph. The horizontal axis
of the graph corresponds to the original brightness
values of the pixels and the vertical corresponds to
the new brightness values. The default diagonal line
means no pixels have been changed to new values.
Also on the graph, there are three distinct curves
that correspond to the three regions. Essentially, the
curves define what area is affected when you select
one of the regions. The Shadow region corresponds
to the curve that starts in the top-left corner and
descends to the bottom-middle of the graph. The
Highlights region starts at the bottom-middle and
ascends up to the top-right of the graph. The
Midtone curve is overlayed on top and begins in the
lower-left, ascends to the top-middle of the graph
and then ends in the lower-right.
You can redefine the curves by dragging any of
the four white triangles. This not only allows you to
reposition the curves, but also to change their shape.
The shape and position of the curve determines how
the adjusted color parameter is applied to the selected region. Where the curve is high, a greater amount
of change will occur. Where the curve is low, less
change will occur.

Above Left: Shadow
curve.
Above Right: Highlights
curve.
Left: Midtones curve

for darker ones. Gain is similar, but fades the effect
off at the ends. This will minimize the pixels that get
pegged at the maximum and minimum possible values.
Below is a comparison of Gamma (dotted black
line) and Brightness (dotted white line) both increased
(for different color components) using the default
Midtones curve (solid gray). Notice how both peak at
the height of the Midtones curve. The Brightness line
is applied purely based on the Midtones curve. The
Gamma line, however, falls off at a different rate.
It is important to note that each color component
can be set differently for Gamma, Contrast, Gain
and Brightness. Moreover, each region can have its
own combination of settings.

Let’s move back to the second row of tabs. The
Gamma, Contrast, Gain and Brightness tabs determine how the color component affects the pixels in
the selected region.

Comparison of Gamma and
Brightness with the default
Midtones curve

NOTE All color corrections are in effect
regardless of what is displayed on the current
set of sliders.
Drag the white triangles on the
Color Correction graph to redefine curves
Using the Gamma or Brightness of the pixels will
achieve similar results. The difference will occur at the
ends of the region. Brightness uniformly increases
/decreases the color component over the entire
region. Gamma tends to keep upper and lower values undisturbed.
Using the Contrast of the pixels increases the
color component for brighter pixels and decreases it

Gamma, Contrast, Gain and Brightness tabs

On the Reset pop-up menu, choose Reset
Ranges to return all of the region curves to their
default state. Reset Current will restore the default
settings for only the currently displayed color components. Reset All resets all panel settings to their
default state.
The Preview option will let you use the project
window to preview your settings.

Color Eraser
Use the Color Eraser filter to remove all but the
defined color hues from an image. The Hue color
determines the base color that will be left in. The easiest way to set this is to use the color selection button on the panel and select the color from the image
itself. However, you can set this value numerically as
an angle in degrees around the displayed color
wheel, with zero degrees corresponding to three
o’clock.
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Color Factory

Color Factory panel
Use the Color Factory filter to mathematically modify the red, green, blue and alpha color channels of
the selected images. To set this filter, enter the formula to be carried out on each component in the appropriate field.

The Range expands the defined range by the
number of degrees set. As you adjust this value, you
will see the white outlined pie shape expand or contract. All of the hues within this area will be left alone.
The Fade settings set a falloff range outside of the
Range to give you a smooth transition. This setting is
indicated by black lines.
You can adjust the Hue value by dragging the pieshaped outline with your mouse.
You may reverse the effect of your settings by activating the Invert option.
The Plot tab shows the color wheel with only the
image’s colors mapped on it. This often will make it
much easier to define your area, particularly with photographs.

The arithmetic operators + (addition), - (subtraction), * (multiplication), and / (division) are supported.
You also can use parentheses to define operational
priority. If you do not use parentheses, operations are
carried out from left to right. The following variables,
which are case sensitive, also may be used:
r
g
b
a
x
y
l
h

value of the red pixel component
value of the green pixel component
value of the blue pixel component
value of the alpha pixel component
x pixel coordinate
y pixel coordinate
image width
image height

Color Histogram

Color Histogram panel

Plot tab with image colors only
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The Color Histogram modifies an image by changing the distribution of color, luminosity or opacity in
the image. This filter can affect different components
of the image (red, green, blue, luminosity or opacity).
For example, you can use this filter to reduce the
global opacity of an image to make it more transparent, or you can increase its global luminosity to make
it lighter.

The five tabs on the panel determine which channel will be modified: Luminosity, Alpha (i.e., opacity),
Red, Green or Blue.
The distribution graph shows two different pieces
of information: on the black column graph, you see
the relative number of pixels with all the possible values of the selected channel, while on the blue line
graph you see the cumulative percentage of pixels
using the channel. Channel values (e.g., red=0 to
255) are shown along the horizontal axis. The relative
number of pixels matching that channel value (black
column graph) and percent used (blue line graph) is
shown on the vertical axis of the graph. A red vertical
line marks the position of the highest concentration.
The Log option increases the amplitude of the
black graph for non-zero values.
These graphs will give you information on the
color, luminosity and opacity that make up an image,
which can be difficult to determine by just looking at
it. For example, the luminosity values for a bright
image on the black graph would be skewed toward
the right, that is, towards the maximum luminosity
values. A dark image would be skewed toward the
left. An image that had a lot of dark reds would have
a black graph skewed towards the left for the Red
component. If an image had no blues, the black
graph for the Blue component would be flat and low.
The Source and Destination Arrows
The source and destination arrows allow you to
redistribute the component values. In essence, warp
the values to a new shape. Essentially, the graph will

Before and After adjusting Destination arrows on the
Histogram

maintain its peaks and valleys; however, you can
reposition them by expanding and contracting ranges
you specify.
The Arrow number pop-up menu lets you set the
number of arrows available for editing. More arrows
give you greater control over how the values are
redistributed.
The upper set of arrows represent key positions in
the graph that you define. The lower set represent
where you want those positions to migrate to. Areas
between are interpolated based on the relative neighboring slider positions. If matching top and bottom
arrows are at the same position, no change occurs at
that point. However, their position will affect the interpolation that occurs between their neighboring
arrows.
Slide the arrows by dragging them with the mouse
pointer. You also can click on an arrow with your RMB
and a question mark appears beside the pointer. Drag
your mouse around the image. The value of the pixel
under the pointer, as it relates to the selected channel,
determines the arrow’s position. A green line appears
in the graph indicating the pixel channel value.
Release the mouse button to position the arrow.

Chroma Keyer
The Chroma Keyer filter uses pixel chrominance
(i.e., color) values to alter the transparency of parts of
an image. This is often called chroma keying. That is,
certain color hues are keyed out of the picture, such
as when a weatherman appears over computer
graphics. Aura’s filter modifies an image’s opacity by
determining the difference between each pixel and a
chosen reference color hue. This type of operation is
often used with a blue background, called a bluescreen.
The easiest way to set the Hue to be keyed out is
to use the color selection button on the panel and
select the color from the image itself. However, you
also can set this value numerically as an angle in
degrees around the displayed color wheel, with zero
degrees corresponding to three o’clock.

Chroma Keyer with Hue keyed out of door.
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The Range expands the defined range by the
number of degrees set. As you adjust this value, you
will see the width of the white outlined pie shape
expand or contract. All of the hues within this area
will be keyed out. The Hue Fade setting sets a falloff
range outside of the Range to give you a smooth
transition between keyed and non-keyed areas. This
is indicated by black lines.
Saturation defines a saturation limit above which
color hues become completely transparent.
(Saturation is the amount of the color hue.) If the
value is 100, only pure hues become transparent. If
the value is 0, all hues between the pure hue and the
completely desaturated hue become transparent.
This setting is depicted in the color wheel by extending the white arc towards the center as the setting is
decreased.
Saturation Fade defines a transition area (i.e., fall
off). Saturation above this limit becomes partially or
completely transparent. This value is between 0 and
the Saturation value. This setting is depicted in the
spectrum by moving the point of the pie piece outward toward the edge of the spectrum.
You can adjust the Hue value with your mouse by
dragging the pie-shaped outline with your mouse.
You may reverse the effect of your settings by activating the Invert option.

ColorKeyer panel
parts of an image. Pixel opacity is determined by its
distance from a selected reference color.
To choose the reference color, click the Color button. This operates just like any other Aura color
selector operation.
If the red, green, or blue value of a color differs
from the RGB value of the reference color by no more
than the Range value, it is considered completely
transparent. So, if the reference RGB Color was 200,
100, 100 and the Range was 10, RGB: 190, 105,
95, RGB: 209, 105, 102, etc. would be transparent.
Fade defines a transition area between fully transparent and fully opaque colors. This avoids abrupt
changes in transparency. Totally transparent pixel
RGB values that are within the Fade value are proportionately transparent. A pixel is opaque when the
difference between its color and the reference color
exceeds Range plus Fade.

CrossKeyer

Plot tab with image colors only
The Plot tab shows the color wheel with only the
image’s colors mapped on it. This will often make it
much easier to define your area, particularly with photographs.

ColorKeyer
While the Chroma keyer filter mimics the traditional
way colors are keyed out, this filter uses a more computer-like method. Instead of using color hues, it uses
pixel RGB color ranges to alter the transparency of
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CrossKeyer panel
The CrossKeyer is similar to the ColorKeyer but it
allows you to pick which color to keep or drop.

NOTE Setting up the CrossKeyer in VT [3] is
different from the Aura procedure.
To use CrossKeyer:
1. First, click on the Keep button and then use the
mouse to drag around an area you want to keep.

The Edge setting defines the softness of the
selection area. Higher values will give you more
sharply defined edges between areas that are
opaque or transparent, while lower values will apply a
softer transition between edges.
By clicking Learn you tell Aura to remember the colors so it can apply the filter over a series of frames.
NOTE You must click Learn before you click
Apply.

LumaKeyer

Select an area to keep

Another traditional method for keying out colors is
luma keying, instead of using color hues (chroma keying), this filter uses the pixel luminosity (i.e., brightness) to affect the transparency of parts of the image.
It modifies pixel opacity as a function of how close
pixels are to a reference luminance that you choose.

2. Then click on the Drop button to drag around
the colors you want to drop.

Select colors to drop
3. Select the Apply button to apply the filter.
Here’s the result:

After applying the CrossKeyer filter
The Mix setting defines how much of the adjacent
colors are selected using a range between 0.00 to
1.00. As you approach 1.00, the CrossKeyer captures more colors to add to the dropped region.

LumaKeyer filter set to key out Luminance values of
255 with a low fade falloff
On the Ramp tab, the black to white gradient represents the luminosity spectrum. The red line indicates the keyed values. The vertical position of the
line is the amount of transparency. If the line is at the
bottom, pixels with the corresponding luminosity values are fully transparent. If the line is at the top, the
opposite is true.
You can choose the base reference luminosity by
clicking the Lum color picker button. A question mark
appears adjacent to the pointer. Choose a point on
your image that represents the general area to be
keyed. You also can edit the value directly or drag
your mouse over the spectrum. The maximum possible Lum value is 255.
The Range value sets a range of values around
the Lum setting. Depending on the Lum setting, you

8.15 Aura VT

will be limited to possible values. That is, no part of
the defined range can go past 255 or 0 luminosity.
The Low Fade sets up a falloff range on the low
side of the range. The High Fade sets up a falloff
range on the high side of the range. You will see this
as an angling of the red line.
The Level value sets the intensity of the transparency.
You may reverse the effect of your settings by activating the Invert option.
The Plot tab shows the luminosity with only the
image’s values mapped on it. This will often make it
much easier to define your area, particularly with photographs.

The color range used by the filter can be established in two ways. By default, it uses your current A
and B colors. You can change these, then click the
range bar on the panel to update the range in the filter panel. The left-most color will be the A color and
the right most will be the B color, with a smooth gradient in between. Alternatively, if you activate Aura’s
Gradient tool and set a gradient there, clicking on the
filters range bar will be updated to display the new
gradient.
HINT You can get effects like sepia tone
images by using a color range that goes dark
to light using similar tones. Negative effects
result when the range goes from light to dark.

Standard LUT

Plot tab on the LumaKeyer shows
luminance values in an image

The Standard LUT (look-up table) filter applies a
transformation to a given component of each pixel in
the image. You can modify the Luminosity,
Saturation, opacity (D), Red, Green or Blue of each
pixel using a curve.

Luma Range
The Luma Range filter applies a color in a defined
color range to each pixel in the image. When Source
is set to Luma, the luminosity alone determines the
color applied. Darker pixels are assigned the colors on
the left side of the color range, and lighter pixels are
assigned the colors on the right side of the range. You
also can limit the selection to the luminosity of just one
of the three color channels: Red, Green or Blue.

Standard LUT panel

Luma Range panel
Setting Source to Alpha uses the opacity of the
pixels in the image as a basis for assigning colors. As
a result, images like scanned images will be a solid
color because there is no variation in opacity.
Normally, the filter respects transparent areas in
the image. Activating Replace overides this behavior,
and replaces all colors regardless of opacity.
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The curves map the conversion of one set of values to another. Any point along the curve can be
defined by an x and y coordinate. A point’s coordinate along the horizontal (x) axis indicates the original
value. Its coordinate along the vertical (y) axis indicates the converted value. A straight diagonal line
from the bottom-left corner to the top-right would
indicate no change.
Using the LMB, you can literally draw the curve by
clicking on the graph and then dragging the pointer.
The RMB is used to modify the curve in a smoother
fashion. As you drag the pointer, the curve becomes a
bendable spline curve that follows the pointer location.

When applied to luminosity, the curve below maximizes image contrasts: everything to the left of the
vertical line becomes black and everything else
becomes white. This curve is an extreme case of the
more-contrast curve. The image is composed of pure
colors only, namely white, black, red, green, blue,
cyan, magenta, yellow. All grays and oranges have
disappeared. You can vary the effects by moving the
vertical line towards the right or left.
Left: Editing curve using LMB
Right: Editing curve using RMB
The example curve below illustrates how a value
of 100 can be converted into 200. All other (old) values are converted similarly based on the curve and
corresponding new values.

All or Nothing curve

Here are some example curves:
When applied to luminosity, the curve below
makes the image lighter while maintaining the purity
of blacks and whites. Applied to saturation, it reinforces colors.

When applied to luminosity, the curve below
reduces image contrasts. Dark colors become lighter
and light colors become darker, while intermediate
colors remain more or less intact. This curve should
be compared with the first example, the stronger
curve, in which intermediate colors were modified a
great deal, whereas dark and light colors were not
changed very much. It is also symmetrical about the
diagonal axis with the more-contrast curve.

Less contrast curve
Stronger curve
When applied to luminosity, the curve below reinforces image contrasts. Very dark colors become
black (step at bottom left) and very light colors
become white (step at top right). Other colors are distributed between these two extremes.

When applied to luminosity, the curve below produces a negative of the image.

Inversion curve

More Contrast curve

When applied to luminosity, the curve below transforms the image into false colors. Some of the colors
become negative, and for other colors the contrast is
enhanced.
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MISCELLANEOUS FILTERS
Calculator

Bizarre curve
HINT You can create a grayscale-looking
image by dragging the right mouse button
past the bottom-right corner, essentially filling
the saturation curve window with black. The image
will still be an RGB image, however.

EXTERNAL FILTER

The Aura Calculator

Aura is compatible with most Adobe®
Photoshop® 5.5 plug-in filters. (Aura is not compatible with Photoshop 6 filters.)

The Calculator plug-in displays a small calculator in
the Aura interface. You can use it by clicking on the
buttons in its menu, or by pressing the keys in the
numeric keypad.

To install Adobe® Photoshop® plug-in filters:
1. Make sure the plugin.dll file is located in your
system directory (i.e., C:\Windows, C:\Winnt, etc.). If it
isn’t, locate it (it is part of Photoshop) and copy it to
your system directory.
2. Run Aura using a configuration file other than the
default. The Photoshop plug-in filter information must
be saved to an Aura configuration file and since the
default cannot be altered, none of the Photoshop
plug-in information will be saved.
3. Choose Filters > External
4. Click Select Directory from the dialog box that
appears.
5. Use the file requester to navigate to your
Photoshop\Plugins subdirectory. There should be several files with a file extension of .8BF.
6. Select one .8BF file. (It doesn’t matter which.)
7. Click the OK button.
8. Quit Aura and make sure the Save this configuration option is active on the Quit panel.
9. Restart Aura using the same configuration file. All
of the Adobe Photoshop plug-in filters will be added
to the Aura Filters menu under External Filters.
NOTE Some filters may not operate properly
outside of the Photoshop environment.
NOTE Only Photoshop plug-in filters will be
available. You will not be able to access builtin filters.
You can apply Adobe Photoshop plug-in filters –
like any other Aura filter – to the current image or
selected frames in a layer.
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Clock

The Aura Clock
The Clock plug-in displays a small analog clock in
the Aura interface. The time shown on the clockface
is determined by your system settings.

George

The dialog box with path to a George program
The George plug-in lets you execute George programs that use the None launching mode. Specify the
George program by either typing its path and filename in
the input field or use the Select option from the dialog
box’s pop-up menu. Clicking Execute Image will run
the program on the current image. Execute sequence
will run the program on selected frames in a layer.

Wallpaper
When you apply the Wallpaper filter and toggle to
your system interface, you will see that you have
plopped the current Aura image in the middle of your
screen. This wallpaper is temporary and when you
reboot your system, your original wallpaper reappears. You also can remove the Aura wallpaper
through your system control panel without rebooting.

MOTION FILTERS
KeyFramer
Use KeyFramer to create brush motion paths that
can be repeated and edited. You accomplish this by
setting the position, rotation and other settings of a
brush at key points in time, called keyframes. (The filter automatically computes the appropriate inbetween states for the settings, as needed.) For
example, suppose you want to move a brush from
the middle of the screen to one of the corners, and
then return to the initial position. You only need to
create three keyframes: one for the initial position of
the brush, one for the brush in the corner of the
screen, and the third for the final position of the
brush.
To use a path, select your drawing tool and related
settings, and just apply the path. It will be as if you
drew that exact path with your mouse or drawing
tablet. Use it on a custom brush to fly it around the
screen, including 3D-like rotational changes.
You also have the ability to edit the path and
tweak it as much as you want. You can even add
brush changes with your mouse, normally only possible if you are using a tablet.
There are three ways to create the motion paths.
You can manually set your motion paths, you can
track a defined area through a sequence of frames
and you can record your mouse movements. Lesson
Five in the Tutorials in the Aura content directory covers motion paths.
NOTE KeyFramer uses the same animated filter techniques discussed at the beginning of
this chapter.

The New button and current path popup menu on the KeyFramer panel
positioned in the top-left corner. As soon as you enter
a new name, KeyFramer automatically shows a preview of your brush in the Aura work area.
If you want to copy the current path, so you can
make changes to it without changing the original, you
must choose Motion > Path Manager and click the
Copy button. Then you enter a name for the clone.
In the Path Manager, you can change the name of
the current path by clicking the Rename button. Give
the path a new name in the dialog that appears and
hit OK.
If you need to reset your path, simply choose File >
Reset from the top of the panel. To delete the current
path, click the Delete button. The other options available on the Path Manager dialog are discussed later.
Manually Creating Keys
You can create keys manually or you can use the
other motion filters to create your keys. When you
create keys manually you can position, rotate, stretch
and apply special effects. We discuss how to create
keys with the other motion filters later in this chapter.
To manually create keys using the Auto Key and
Brush source:
For this procedure, we’ll use a custom brush. You
should load or create a custom brush to follow along.
However, you can create keys with Auto Key and
Layer source as well.
1. Drag an empty layer to about 10 frames duration. Right-click the layer and choose Make Anim. On
the Layer panel, verify that the Auto Key button is
active so that Aura will automatically create your keys.

NOTE You can use KeyFramer curves for
some filters. See the discussion of the Path
menu earlier in the chapter.
Motion Path Data
Before you manually create a path, you need to
give it a name so you can refer to it later. Click the
New button to do this. The name you enter is added
to the current path pop-up menu at the top of the
panel. Aura creates default keys at frame 0 that are

Drag an empty Layer
2. Verify that your source is Brush. Select the
New button on the KeyFramer panel and name the
path. Aura shows a preview of your brush.
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3. Select the first frame in your layer and drag your
mouse to move your key to the bottom right of your
work area.

6 Select the Apply Filter button and Aura
applies the keys to your layer.
You can use Auto Key to create keys anywhere in
a layer – you do not need to start at the first frame.
However, notice that you must use the Create key to
define the initial key if you do not start at the first
frame.
1. Verify that AutoKey is active then choose your
initial frame on the global timeline.
2. Make your adjustments, such as position and
rotation, on the KeyFramer panel, or visually in the
work area and click the Create key. This defines the
initial frame for your new keys.
3. Select the target frame and then adjust your key
parameters again.
4. Select the entire layer and click Apply Filter.
Aura applies your changes only between your initial
and target frames.

First frame, drag key to bottom-right
NOTE When you grab a brush in KeyFramer,
always grab it by the corner, not the center.
Grabbing the center will select the keyframe,
which can cause the frame to jump on the
timeline after you adjust it.
4. Select the last frame in your layer and move
your key to the upper left corner. You should see an
elastic vector line stretch from the bottom right key to
your new position.

To manually create keys without Auto Key:
1. Select the target frame on the global timeline
and make sure Auto Key is inactive.
2. Edit the desired parameters on the KeyFramer
panel, or visually adjust the key.
3. Click the Create button. Keys will be created for
all parameters.
NOTE Make sure you don’t start dragging
while right on top of an existing key because
you will select it instead of creating a new key.
Manually Editing Keys
To manually edit existing keys:
1. Choose the path on the KeyFramer panel.
2. Place your mouse pointer directly over an existing key and click to select it. (An unselected key
looks like a plus sign and a selected key looks like a
square.) The frame that corresponds to that key is
automatically selected. You can select multiple keys
by holding the Shift key as you click.
3. Numerically edit settings or use your mouse in
the work area to change the image visually.

Last frame, move key to upper-left
5. Select all frames in the global timeline.

Select all frames
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Numeric settings for X, Y, Z
coordinates

If you deactivate any of the buttons to the left of
the fields, you are precluded from interactively changing the related value with your mouse. Also, using
your mouse, you can alter only parameters that
already have keys.
NOTE If you have multiple keys selected, they
will all independently reflect changes you
make to each field. Thus, if you change only
the X field, only the X data of the selected
keys will change.

Moving Keys
Dragging your LMB left or right changes the
selected key’s horizontal (X) position. Dragging your
LMB up or down changes the vertical (Y) position.
Dragging your RMB up or down changes the depth
(Z) position, which affects only brushes. Remember,
when dragging a key, grab the brush by a corner;
grabbing a brush in the middle may select a current
key and snap the timeline to that keyframe.

Linear and Spline Keys
Every key can follow a linear or spline path. You
can change the path type by selecting the key(s) and
toggling the Spline button on or off.
At first, the change will seem to make no difference. However, if you then drag your mouse over the
key, a tangent line will appear. Dragging the tangent
handle at either end will change the length and angle
of the tangent line, which in turn affects the shape of
the curve at that point.

Changing the shape of the curve
NOTE If the curve appears to do a loop-deloop, drag either tangent handle to the other
side of the key.
You can break the tangent line, which allows you
to control either side independently, by holding the
Ctrl key as you drag one handle.

Independent control over one side of tangent line
You can reunite a broken tangent by holding the
Shift key and clicking on either handle.

Moving a key visually in the work area
You can numerically set the position using the X, Y
and Z fields on the KeyFramer panel. The C, or center, button will compute and enter the position of the
center of your project window. Note that the C button
works only for the axis buttons that are active, that is
if you activate only the X button, when you choose C,
only the X axis will be centered.

Numeric settings for X, Y, Z fields
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Rotating Keys
You can rotate keys by adjusting the H, P or B
fields, which represent Heading, Pitch and Bank,
respectively. To adjust rotation visually, you must have
the Preview option selected. Hold Ctrl while dragging
your LMB left or right to change the key’s heading (left
to right rotation). Hold Ctrl and drag your LMB up or
down to change pitch (up and down rotation). Hold
Ctrl and drag your RMB around the key to change
bank (clockwise and counterclockwise rotation).

The A buttons activate the align-to-path mode
independently for heading, pitch and bank. This is a
non-keyable parameter. The KeyFramer will attempt
to align the brush to the path for the selected rotation(s).
Scaling Keys
You can scale your brush or layer image with
keyframes. Use the Width and Height fields to numerically adjust the dimensions for both brushes and layers. Clicking the R button resets fields to 100%. If
you have Lock Aspect active, Aura scales the image
so that the aspect ratio of your settings remains constant.

Visually rotating a key in the work area
You can numerically set the rotation using their
adjacent fields. Clicking the R button resets fields to 0.

Visually scaling a key in the work area

Scaling a key with numeric
settings
Above left: Heading rotation
Middle right: Pitch rotation
Below right: Bank rotation
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Special Effects
Aura offers several options for applying special
effects to your keys.

Special effects on the KeyFramer panel

Up and Down options refer to whether your drawing button (mouse or tablet) is up or down. This
allows you to stop drawing while the direction or
other parameters continue on. Note that this is a toggle setting. Once an Up or Down key is hit, that state
continues until the next Up or Down.
Applying KeyFramer
Use the Source pop-up menu to select the image
you want to keyframe. If you select the Brush apply
mode, you stamp a brush down once in each frame
using the current path. Using Brush will use the current custom brush. Using Layer, Aura acts as if you
cut out the selected frames as an animbrush and
applied the path with that animbrush.

N, for noise, will add some randomness to the
brush position.
MB, for motion blur (Brush mode only), sets the
amount of motion blur, which can make moving
objects appear to move more smoothly when played
back in an animation. Essentially, this mimics the blurring that occurs in the real world when something
moves faster than a camera’s lens (or our eyes) can
freeze, like a speeding racecar. The default setting of
50% should work in most cases.
Pop-up menus on the KeyFramer panel
Using the Once setting for the Apply pop-up
menu, the brush is applied only once, as you would
normally expect.

Before Motion Blur

After Motion Blur

Motion blur is accomplished by adding several
semi-transparent images to each brush position. It
places these additional images between the current
brush position and its previous position, slightly shifting each relative to the others. The distance between
each additional image depends on the distance
between two successive positions of the brush. The
number of additional images depends on the MS setting, below.
HINT To get a lot of blur, try using a very high
value, like 300%, on the first key for the MB
and set MS to 42.
MS, for motion step (Brush mode only), is a nonkeyable parameter that works in conjunction with
motion blur. It sets the number of complied blurred
images when there is some level of motion blur.
Values of 3 to 5 should work in most cases. With the
default value (0), no additional images are created.
O, for opacity (Brush mode only), can vary the
opacity of the brush over time.

Once mode with a rotated brush
Setting the Apply pop-up menu to Fill will tile the
brush to fill each frame – this includes respect for
perspective and size, if the brush is rotated or
stretched.

Fill mode used on rotated brush
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The Mode pop-up allows you to apply various
Drawing modes to your keyframe options. You can
learn about the different drawing modes in Chapter 6:
Drawing Modes and Paper.
The Preview button shows a preview in the work
area of the motion path you create. To adjust your
frames visually rather than numerically, you select the
Preview option. When you select a motion path that
you previously created, you must activate Preview to
see the path in your work area.
The AAliasing option on the KeyFramer panel lets
you choose whether or not Aura applies anti-aliasing
to your motion path. Anti-aliasing smoothes pixels so
that edges do not appear jagged. With motion,
AAliasing will smooth the in-between frames you create in KeyFramer.
Exporting a Motion Path to LightWave
The File menu has a special option that allows you
to save KeyFramer data to a LightWave 3D motion
file. When you choose File > Export to LW Motion,
the standard Aura Export panel appears. You must
enter a name for your motion file, choose OK, and
then the Export to LightWave Motion panel appears.
From this panel, you can adjust the origin, scale and
channel options for a motion path. Note that when
you export a motion path, it maintains the frame
duration of the project you export from. Thus if you
export from a project with a duration of 30 frames,
the motion path will cover 30 frames.

ReverseX and/or ReverseY, you can reverse the origin
coordinates, which gives them a negative value. The
Set Origin pop-up lets you choose standard coordinates for your origin, based on the project dimensions.
The Scale tab allows you to widen and/or heighten your motion path. You choose options from the
Units pop-up to specify the unit of measure that
defines the size of the motion path. When you activate the Image ratio option, you force the motion
path to maintain the aspect ratio of the project
dimensions.
The Channels tab lets you choose which channels
to use to export motion paths. Aura exports a separate motion file for each of these channels with the
channel name appended to the root motion filename.
All options except the speed option apply only to
paths created with a Wacom-compatible tablet and
stylus.
The Up/Down channel refers to the Up or Down
option for your drawing button, (see this option in the
section on the Stroke Recorder). You can create keys
for a motion path based on this setting.
The Pressure, Altitude, Azimuth and Fingerwheel
options work with the Stroke Recorder. You create
keys for these paths only if you record your motion
path with a tablet or if you edit these fields in the
stroke recorder panel.
Speed information occurs with either a mouse or a
stylus; the options vary between 0 and 1.

Path Manager
The Path Manager filter lets you manage multiple
motion paths.
From the Manage tab, you can access buttons to
rename, invert, copy and delete paths. Simply select
the path and choose the appropriate button.
Remember that once you delete a path that you cannot retrieve it again.

The Manage tab on Path Manager

On the Origin tab, you specify the position for
the origin of the motion path. The OriginX and OriginY
fields let you numerically set the position. The initial
values in these fields are based on the dimensions of
your current Aura project; the coordinates at the center of your project set the default origin. If you select
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On the Average tab, you can choose from different paths that you’ve made and Aura will average
together the motion. When you average paths
together, Aura prompts you for a new name. To see
the new path, you must apply it to a layer from one of
the motion filters.

The Average tab on Path
Manager
The Smooth function takes all keys in a motion
path and smoothes the motion. Pixel tracking often
creates a jerky motion path; Smooth improves the
motion path. Choose a path for smoothing from the
pop-up menu and then enter a value in the Smooth
field. The value you enter determines the radius of the
smoothing effect in pixels. Larger values will produce
a smoother motion path.

Pixel Tracker panel
The Smooth tab
You can access the other motion filters by selecting the Motion menu near the top of the panel.
Alternatively, you always can access the Path
Manager from the motion filters via the same route.

Pixel Tracker
As mentioned before, you can create a path by
tracking an area through an animation. You start this
process by selecting Motion > Pixel Tracker, which
displays the Pixel Tracker panel. (See Lessons Nine
and Ten in the Aura Tutorial directory to learn techniques for using the Pixel Tracker.)

ect display. A red layer is a video layer. When you set
a layer in the menu, it automatically updates the M In
and M Out point.
The M In and M Out buttons give you control over
where tracking begins in the timecode of the animation. So, you can offset pixel tracking from the actual
beginning or end of the animation. You drag the
arrows beside the field to change the timecode and
then click the M In button to set the start (or “in”)
frame for tracking. Follow the same procedure and
click the M Out button to set the end or out frame.

NOTE You can access all of the motion filters
from any motion filter panel by selecting the
Motion menu at the top of the panel.
NOTE It is not necessary to click the New
button first. The tracked path will be added
automatically as Track #.
You can choose a specific layer that contains the
pixels that you want to track. Available layers appear
in the Layer menu, and when you choose the layer
you want to track, it appears in the preview area.
When you select Current, Pixel Tracker tracks the
selected layer. If you select Display, it tracks the proj-

Visually setting the pixel to track
RefX and RefY define the center position of the
pixels you want to track. RefW and RefH define the
width and height of the tracked pixels. TrackW and
TrackH define the tracking area; i.e, the area in which
tracked pixels can be found. Note that this is a moving area so the pixels need only appear within this
area from one frame to the next. You’ll want to keep
this area as small as possible for accuracy and speed.
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Fortunately, you can graphically set these parameters by clicking the Set Tracker button.
The plus sign defines the center position, which
you can move by dragging your mouse. The inner rectangle is the tracked pixel area. You can adjust this
interactively by holding your Ctrl key and dragging
your mouse. (Adjust the tracking area by changing the
TrackW and TrackH parameter values.)
When Reference is set to Static, the first frame is
used as a tracking reference during the whole tracking operation. If the Dynamic setting is used, the reference is updated at every frame.
The Channel pop-up menu sets the channel that
Aura looks for when tracking. Depending on the
image, you may get better results if you narrow the
tracked pixels to a single channel. You can choose
from the standard RGBA, Red, Green, Blue or Alpha
channels. Aura also lets you specify a Luma channel
and a Saturation channel so that you can track based
on the brightness of saturation of an image area.
Use the Accuracy pop-up menu to set how accurate you want the tracking to be.
The Rev Track button lets you reverse the direction of the motion path as you track your image area.

Stroke Recorder

You click the Record button to begin recording your
brush strokes. Now, in the project window, draw out
the stroke you want to record. When you are done,
click the OK button. To cancel the recording operation
and return to the KeyFramer panel, click Cancel. If you
select frames before you click Record, Aura will
stretch the recorder path to the selected length.
To apply the stroke, select the Custom Brush button
from the main panel, then drag out an empty layer the
desired number of frames. Right-click the layer icon
and select Make Anim. Then select all of your frames
and click on Apply Filter in the Stroke Recorder panel.
Aura draws your stroke across the frames.
Stroke Recorder Parameters
The X and Y fields allow you to enable or disable
the X or Y axis.
The P, or pressure, field offers you a value that
responds to the pressure of your stroke if you are
using a Wacom tablet and pen. The value that you
define indicates the minimum pressure required for a
stroke to be recorded.
The T field represents a value for Azimuth that
ranges between 0 and 100.
The A, or altitude, field represents a value for the
angle of your pen if you use a Wacom tablet to draw
your stroke. You can specify an altitude between 0
and 100 that tells Aura the minimum required for a
stroke to be recorded.
The F1 field lets you enter a value between 0.00
and 100 that adjusts your fingerwheel.
The N field allows you to add noise to your stroke
recording, which gives the stroke a jittering effect. A
value of 0.00 adds no noise.
The Up and Down buttons specify whether your
drawing button (mouse or tablet) is up or down. This
allows you to stop drawing while the direction or
other parameters continue on. Note that this is a toggle setting. Once an Up or Down key is hit, that state
continues until the next Up or Down.
Applying Stroke Recorder
The next group of options affects how Aura applies
the filter. With the Normal option selected, Aura
applies the path over the selected frames just as if
they were made using your mouse or drawing tablet.

Stroke Recorder panel
The Stroke Recorder records the movement of
your brush across the screen. This is useful when you
want to animate something like a handwritten signature. (See Lesson Seven in the Aura Tutorial directory
to learn techniques for using the Stroke Recorder.)
NOTE It is not necessary to click the New
button first. The recorded stroke will be added
automatically as Stroke #.
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Using the Normal option to apply a recorded stroke
Using the Size option, Aura erases the beginning
of your brush stroke as the animation progresses.
The adjacent input field sets the number of frames to
hold before erasing.

Using the Size option to apply a recorded stroke
If you use the Stroke Recorder with the Text tool
and Size, Aura treats each text letter as an independent element. Therefore these elements may get closer
to each other, or move away from each other,
depending on the movement speed. To prevent this
from happening, create the brush and then select the
Custom Brush tool.
With the Full option, Aura draws the entire path on
each frame.

Using the Full option to apply a recorded stroke
With the Last option, Aura draws a single dot at the
end of the last brush stroke on each frame drawn.

Using the Last option to apply a recorded stroke
NOTE To define the duration of the stroke,
select frames in a layer before recording.

Interactively setting points for Stabilization 1 Point

Stabilization 2 Points
This filter allows more elaborate means to remove
the motion from a hand-held sequence. Two source
pixels from the original image are used to provide the
necessary information, rather than merely one. The filter can infer an angle of deviation from the baseline
between them for each frame of the clip. The angle
derived can then be used to correct for rotational
instability. Likewise, any variance of the distance
between the two source pixels can be taken to indicate zoom, or movement on the Z-axis. This can be
corrected by scaling.
As with Stabilization 1 Point, there are two modes:
Panning and Shift. Panning tiles the image to fill the
screen. Shift doesn’t tile, meaning you may see whatever is underneath the layer. The two additional
options, Scale and Rotate, permit the corrections
mentioned above to be performed selectively. You can
choose to correct for Rotation only, Scale only, or both.
You can interactively set the two Origin points and
their Destinations by dragging points on the project
window. To do so, click the Set button. The Origin
and Dest fields update as you move the boxes.

Stabilization 1 Point
Use this filter when you want to remove the motion
from a hand-held sequence that has been filmed to
stabilize the images.
There are two modes: Panning and Shift.
Panning tiles the image to fill the screen. While Shift
does not tile, you may see underneath the layer.
The OriginX and OriginY define a starting point on
the frame. The DestX and DestY define a target
point on the frame. The filter basically moves the
image so that the points line up.
To interactively set these two points, click the Set
button. You will see a small box in the upper-left corner.
Drag it to your starting point location. You will see the
OriginX and OriginY fields update. That point will be
connected to another point still in the upper-left corner.
Drag the second point to define the target point.

Interactively setting points for Stabilization 2 Points
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However it will often be more practical to use this
filter in conjunction with motion paths derived using
the Pixel Tracker filter. Use the latter to track two
prominent pixels, and save their motion paths separately. Also, take careful note of the starting X and Y
co-ordinates for each.
Then, in the Stabilization 2 Points filter, set the
Dest1 X and Y and the Dest2 X and Y values to those
starting co-ordinates. Next, use the filter’s Path menu
to set Origin1 to the path you saved for the first
source pixel, and Origin2 to the second path. Click
Apply to render the selected frames. Afterward,
depending on your purpose, you may find it necessary to crop out unwanted margins and scale the
entire layer to fill the frame.

4C creates a four-corner gradient. You choose colors for the Top Left, Top Right, Bottom Left, and
Bottom Right. Set an alpha value in the field beside
the color tiles for each corner.

Perlin Noise
This tool applies a procedural pattern to the current image. Perlin noise was developed to enhance
the realism of computer generated graphics by “dirtying” them up using pseudo-random textures. Additionally, it can be used to simulate clouds, smoke, or
a wide variety of natural textures such as marble,
wood, or flames.

HINT The Pixel Tracker can produce motion
paths which are themselves a bit “jumpy.” You
may find it practical to apply a little smoothing
using the Path Manager, before re-saving the
two paths and using them in the Stabilization 2
Points operation described above.

RENDER
Background Generator

Perlin Noise example
The controls in the upper part of the settings panel
define the texture to be generated. The SizeX and
SizeY fields adjust the scale of the pattern along the
X and Y axes, while the PosX, PosY and PosZ settings vary its location.

Background generator panel from left to right:
Horizontal gradient, Vertical gradient, and 4Corner
With the Background Generator, you can apply a
color gradient to the current layer. The Background
Generator accepts alpha values, so your gradient can
be semi-transparent.
Choose from three modes when you work with the
Background Generator:
H creates a horizontal gradient. Choose the Top
color and a Bottom color, and specify an alpha value
in the field beside the color tile. 0 will be completely
transparent and 255 will be completely opaque.
V creates a Vertical gradient. You choose the Left
and Right colors and define an alpha value in the
field beside the color tile.
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HINT Animating the Pos parameters can create the impression of flying past or even
through clouds.
Raising the Octave setting increases the level of
detail in the texture. The filter uses the Seed setting
to provide a pseudo-random result. For all practical
purposes, the number you choose does not really
matter.
The settings in the lower section of the panel
determine how the texture will be painted into the
current image. The Source pop-up menu presents
Color, Gradient, and Layer options.
Selecting Color tells the filter to use the single
color you set in the Color swatch below to paint the
pattern. The pattern will be created using this source
color, falling off either to black or to transparency
depending on the state of the Opacity switch.

Consider an example: with Source set to Color,
Color set to blue and Opacity off, the Perlin pattern
will appear as blue over black, ignoring any previous
content in the frame. With Opacity on, the blue pattern is still painted into the frame, but any existing
imagery is preserved where black appeared in the
previous example.
The Source Gradient option initially uses your current A and B colors to generate the pattern.
Activating Aura’s Gradient function permits more
elaborate gradients to be used. Click on the gradient
bar in the filter panel to activate the new gradient.
Finally, choosing Source Layer will create the pattern using the color values of corresponding pixels
from the current layer.
NOTE When Layer is selected as the active
Source, the Opacity and Mode selections are
not available.
The Mode setting designates the mode Aura uses
to paint the Perlin pattern. Blend mode paints the
pattern down over any existing imagery, while most
other modes correspond to standard Aura paint and
merge options by the same name. The exception is
Preserve mode. Preserve is the equivalent of painting
in Behind mode, and prevents the new pattern from
affecting existing pixels based on their opacity. Invert
reverses the pattern created.
HINT By using the Invert button with appropriate values in the Perlin noise filter, you can
easily create realistic caustic patterns like
those caused by sunlight beneath the surface
of a swimming pool, or wispy tendrils of “smoke.”
Click Preview to see the effect of your current settings, and Apply to render the effect.
NOTE Most settings for Perlin noise can be
keyframed, allowing you to animate the appearance or positioning of the texture over time.

Plasma
This tool also creates a procedural pattern in the
current image. The effect can be quite complex.
Basically, it is comprised of one or more sets of concentric rings and their interference patterns. It may
help to think of these as “ripples”, each emanating
from a Generator.
The uppermost section of the control panel offers
the Circles pop-up menu, which permits you to designate how many Generators are used. You can choose
from one to four Circles. Choosing 1 Circle, the pattern formed will be a single set of concentric rings. The
ripples from two or more generators will interfere with
one another creating more diverse effects.

Plasma Example
Unlike the similarly named control elsewhere in
Aura, the Mode pop-up does not designate how the
pattern will be painted into the current image. If
Plasma is applied to existing imagery, that imagery will
always be completely overwritten by the filter’s output.
Rather, the Mode options (Add, Average, and so
on) control how values from different generators are
combined mathematically where they interfere with
one another. Hence this setting has no effect on the
pattern created by a single generator, but can have a
dramatic impact when there are several.
In the next part of the menu there are settings for
each Generator. The pop-up menu named for each
Generator permits you to select Smooth, Linear1 or
Linear2. The settings modify the way the waveform is
calculated. The X and Y settings designate the center
point for each generator. Changing the location of the
generators impacts the interference patterns created.
HINT Since the Generator positions can be
keyframed using the X and Y values, dramatically shifting plasma patterns can be created.
The individual Scale settings control the density or
wavelength of the ripple(s). Scale values also can be
keyframed along the Aura timeline, enabling you to
create constantly changing patterns.
HINT Animating the Scale value is one way to
create the appearance that the ripples are
spreading outward from the Generator location. Increasing this setting effectively lengthens the wavelength of the ripple, causing the size of
the ripples generated to appear to grow and spread,
with less rings being created.
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The lower section of the setting panel contains
various controls with mini-sliders. Direct numeric entry
of values also is possible. The uppermost setting is
the global Phase control. This effectively alters the
pitch of the spreading waveform. Increasing it may be
thought of as equivalent to causing the ripples to roll
outward. Unlike the effect of increasing Scale, the
apparent wavelength and frequency of the pattern are
not altered. The ripples merely seem to continue to
propagate outward, without change in proportion.
Next in order are Red Phase, Green Phase, Blue
Phase, and Alpha Phase settings. These control the
colors and opacity used to paint the pattern. Each
color phase control cycles through values of its corresponding channel, affecting both the primary color
and its complement. So, for example, Blue Phase
adjusts both the blue and yellow hues used in the
pattern. Modifying the phase alters the contribution of
these two hues to the pattern, controlling both their
values and locations on the ripple pattern.
Likewise, Alpha Phase controls the level,
breadth, and placement of transparency in concentric
bands along the waveform ripples.
NOTE Phase settings cycle at integer values.
Hence, all else being equal, a global Phase
setting of 1.00 will produce the exact same
pattern as 0.00. Likewise, a setting of .351 will
be identical in appearance to the result of a phase
setting of 2.351, and so on. This enables you to easily
create looping patterns – such as spreading ripples –
by keyframing starting and ending values which,
though incremented, correspond to one another.

SPARE RELATED FILTERS
These filters generally require that an image be
copied to the spare image buffer. This is discussed in
Chapter 2.

The Bump filter with preview
Depth determines the depth, or power, of the filter.
The relief created in the image intensifies at higher
depth values. The Smooth setting smoothes the
edges of areas in relief. The amount of smoothing
increases for higher values of this setting.
If you set the Apply With option to Direction, you
can choose the angle that the light is coming from.

Bump
The Bump filter uses the brightness values of the
spare image to emboss areas of the current image.
Light areas appear raised and dark areas appear
lower. Embossing will also be less pronounced where
the opacity is less in the spare image. This filter can
produce stamped metal effects or simulate the grain
of paper and fabric.
As an alternative to using the spare image for the
bump, you also can use the current paper as the
Source, if that option is active.
If you set the Apply With option to Center, the
CenterX and CenterY values indicate the position of
the light source that highlights the relief. You can
enter these values manually or you can click the
Center Set button and then click on a position.
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Pop-up menu for Apply With option

Extrude
The Extrude filter uses the same parameters as the
Bump filter; however, it uses the brightness values of
the spare image to displace areas of the current

Left: Original. Middle: Spare image. Right: After Extrude
image. Light areas have more displacement power
than dark areas.

Lumix
Lumix uses the spare image to modify the luminosity of pixels in the current image. If the brightness
of a pixel in the spare image is greater than 128 (the
median luminosity value), the corresponding pixel in
the current image is made lighter. If less than this
value, the corresponding pixel in the current image is
made darker. There are no settings for this filter. You
can intensify the effect with multiple apply operations.

Spare Mixer
The Spare mixer filter uses the spare image to perform a number of different options on the current
image.
Add Front pastes the contents of the spare image
on top of the current image. The spare image must
have some level of transparency or you will no longer
be able to see any of the existing current image.
Add Behind pastes the contents of the spare
image behind the current image. The existing current
image must have some level of transparency or you
will not see any part of the pasted spare image.
Add Alpha adds the opacity of the spare image to
the opacity of the current image. Subtract Alpha
does the opposite by subtracting the opacity of the
spare image from the current image. You can use the
spare image like a mask with this option.

SPECIAL FX FILTERS
Bevel
The Bevel filter creates an image that appears to
be stamped, raised or embossed on the background.
The Mode menu lets you choose the type of bevel
that you want to apply. The Inner bevel makes the
image look stamped into the background. The Outer
bevel raises the image over the background; it works
only with an alpha channel. Both applies Inner and
Outer, which looks like a pillow emboss.
On the Channel menu you choose which channel
you use to apply the mask for your bevel: Red,

The Bevel filter with preview
Green, Blue, Alpha or Luma. Red, Green, and Blue
are the color channels of the image, Alpha refers to
the density of those color channels and Luma refers
to the black and white portions of the image.
The Bevel Width and Bevel Height fields let you
set the size of the bevel in pixels. Essentially, you use
these settings to adjust the depth of the bevel.
The Direction field sets the angle of light. Softness
determines the percentage of blur to apply to the edge
of the bevel; with a value of 0 you get a hard edge and
with a value of 100 you get a very soft edge. The
Power field lets you set the intensity of the bevel in
percentage. Power and Softness can work together
to make a more concentrated or diffuse bevel.

Blend
The Blend filter mixes colors in the current image;
however, all edges of the resulting image are continuous. This means that you can use the Panning tool
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(Main panel) to shift the image in any direction, and
you will never see a join line. Therefore you can use
these images to create bump maps for 3D programs.

The fields for Glow X and Glow Y let you set the
bloom size on each axis. The size is measured in pixels. The Blur Tune field lets you fine tune the bloom:
0.5 is a fine blur and 20 is a rough blur.
Finally, you can alter the actual color of the bloom
by entering different values in the Red, Green, and
Blue channels.

Convolutions

Blend filter with preview
NOTE Application of this filter involves an amount of randomness, so you will never obtain
the same result with two identical images.

Bloom

Convolutions filter using 3x3
matrix

Bloom filter with preview
Bloom applies a blooming effect to the pixels in
the selected image. You can vary the brightness of
the bloom, the saturation of color, and the bloom
color, and the bloom size.
Use Brightness to adjust the lightness or darkness of the bloom. Use Saturation to adjust the
intensity of the bloom’s color.
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A convolution is a mathematical formula that can
make an image sharper, more blurred, embossed,
outlined, and more. This filter allows you to set up
either a 3x3 or 5x5 convolution matrix. (The time
taken to apply the filter increases as the number of
convolution coefficients increases.) Each value in the
matrix is called a coefficient.
The convolution calculates a new value for each
pixel in an image by taking the average of the values
of the pixel and the pixels surrounding it. Each coefficient is independent and can have a unique value.
The coefficients and the way in which they are distributed around the central pixel can give a wide variety
of effects. As such, a 3x3 matrix takes into account
only directly adjacent pixels. A 5x5 matrix, on the
other hand, considers more remote pixels.
With a 3x3 matrix, the new central pixel value is
obtained using a weighted average. In other words,
the sum of the product of each coefficient and its
corresponding value, divided by the sum of the coefficients.
So much for the principle of the operation. What

really matters is the result. The following examples will
give you an idea of what can be done.
With the Blur convolution matrix, each pixel is simply calculated as being the average of its neighboring
pixels. (Note that the Smooth filter and Blur drawing
mode are more efficient; however, this example is useful to help you understand how convolutions work.)

Unaltered image
The More Blur convolution matrix gives more
weight to neighboring pixels than the central pixel,
which results in a more intense blur.

The Outline convolution matrix can extract the outlines of the image. Plain colors become black. The
limits between different colors become light. The limit
tends more towards white as the difference between
the colors becomes more marked.
If you transform the image to its negative, the
effect obtained will be different. To draw outlines, the
central coefficient must be the opposite of the sum of
the adjacent coefficients. In the example, the sum of
the adjacent coefficients is 4 (0+1+0+1+1+0+1+0).
Therefore the central coefficient is -4. Outline 2 shows
a variant of this matrix.

its “pivot-value” (the opposite of the sum of all adjacent values). The sharpness becomes less apparent
as the central coefficient moves away from this pivotvalue. The Sharpness 2 matrix is a more powerful
variant and Sharpness 3 less powerful.

The Relief convolution produces an effect similar to
illuminating a textured image with a ray of light almost
parallel to its surface. Plain colors remain unchanged.
The limits between different colors become lighter or
darker depending on their position relative to the light.
The highlighting effect (light or dark) becomes stronger
as the difference between the colors becomes more
marked. The orientation of the light is defined by the
distribution of the positive and negative coefficients
around the central coefficient. In the example, the light
is coming from the top left. Relief 2 is a more powerful
variant with lighting from the bottom.

The few examples given above are not restrictive
nor exhaustive. You can make any variations you
wish. The Combined example will give an outline and
a relief effect at the same time.

5x5 matrices
The only difference between 3x3 convolutions and
5x5 convolutions is that the 5x5 matrix takes into
account of more pixels (25 instead of 9) and can,
therefore, produce more subtle effects.
The Sharpness convolution matrix increases the
contrast between each pixel to sharpen an image.
(Note: These are essentially modified Outline convolutions.) However, note that as the image becomes
sharper, all its imperfections (grain, noise, etc.)
become visible. The sharpness becomes more
apparent as the central coefficient becomes closer to
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Convolutions filter sets
You can load or save convolutions as files using Load
and Save on the File menu. Several convolution files
should already exist in your Aura Convolve directory.

Erode

and size.
You can choose the glow Color and enter an
alpha value in the adjacent text field. The alpha value
gives you transparency: 0 is completely transparent
and 255 is completely opaque.
The GlowX/GlowY fields represent the glow size
on each axis, defined in pixels.

Grain

Erode filter with low settings
The Erode filter erodes the edge or border of the
selected image. When you choose Erode, you create
an alpha channel that masks out the eroded areas.
The options for this filter let you set Erode X and
Erode Y, which represent the size of the erosion
effect in pixels. Erode X sets the horizontal size and
Erode Y sets the vertical size. If you enter a large
number in this field, you essentially erode a larger
border around the image.

Glow

Glow applies a gaussian blur around the border of
your object to create the look of a glow. The glow
surrounds the entire object, and you can set its color
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The Grain filter adds film-like grain to the selected
image. A little grain can ease the unrealistic smoothness of computer images, or you can use more grain
for an artistic effect like stippling or pointillism.
The grain Size sets the cluster of pixels for each
grain. A smaller size uses fewer pixels and gives you
a more subtle effect.
The Range option lets you enter the amount of
grain variation to apply. Smaller numbers yield less
variation between grains, so that the effect is more
uniform across the image. Larger numbers give a
more random appearance to the grain.
The Red, Green and Blue fields let you control
red, green, and blue grain noise. That is, you can add
noise to the image that uses a particular RGB color.
For example, if you wanted to add white noise, you
would set the fields to 255, 255, 255.
The Monochrome button lets you choose monochrome coloring for the noise. When you use the
Red, Green and Blue fields with Monochrome, you
create a random offset for later in the grain process.

Halftone
The Halftone filter emulates the screened appearance common to printed artwork. Unlike the less

elaborate Print filter, Halftone varies the size of the
mesh according to the source value of the pixels
being processed. The Horiz. Cells and Vert. Cells
values set the global resolution of the mesh pattern,
while Angle rotates it.

Print filter panel with preview

Shadow
This filter creates a shadow for your image. You
choose the color, the intensity and position of the
shadow, and its distance from the image. This shadow may be applied under the current contents of the
image, or in another layer placed under the image. As
such, the shadow is only visible in transparent parts
of the image. If you create a shadow in a completely
opaque image, you will not be able to see it.

Halftone filter panel with preview
Horiz. Jitter and Vert. Jitter introduce some randomness in the resulting pattern, and the Cell Type
pop-up menu allows you to choose from several different styles, including Dot, CrossHatch, Line, and
the like.
The Opacity setting provides control over the
intensity of the effect, with higher percentages being
more pronounced. Finally, Color Mode offers 5 different ways to apply the halftone mesh with different
painting methods.

Print
The Print filter applies a print half tone to an image.
The Apply in pop-up menu determines how the filter is
applied. Color applies the effect using colored dots.
Black&White applies the effect using black-and-white
dots. Opacity applies the effect by changing the opacity in the dot pattern.
Size sets the dot size in the half tone. Image details
are increasingly altered as dot size increases; therefore,
it is usually preferable to keep dot size fairly small.

Shadow panel with preview
NOTE For an animation layer, applying this filter to a new layer creates a new anim layer
(instead of an image layer) if at least two
images are selected.
Set the Apply on pop-up menu to Current to
apply this filter to the current image or current layer
selection. Choose New to create the shadow in its
own underlying layer.
Click on the color button to change the color of
the shadow. The field just to the right of the button
sets the angle of the light source. When you adjust
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the angle with the minislider, a directional compass
appears. As you change the value, Aura updates the
compass for easy interactive selection. The shadow
in the preview window also updates in real-time.
Distance sets the distance, in pixels, between the
shadow and the image. When this value is zero, you
can use the Smooth setting to create glow effects
around objects. (See Hint below.)
Opacity determines the intensity of the shadow. A
value of 50% means that the shadow is half transparent. That is, half of what you see will be the shadow
and half will be the underlying imagery.
Smooth blurs the outlines of the shadow. The
shadow becomes smoother as its value increases.
Use this to avoid a hard-edged shadow. This may
tend to weaken the intensity of the shadow, so you
may want to adjust the shadow Opacity. You also
can reinforce the shadow intensity by applying this
filter several times consecutively.
HINT You also can use this filter to create
glow effects (phosphorescence, neon lights,
etc.). Choose white as the shadow color, set
Opacity to 100%, Distance to 0 and Smooth
to 4 or 5. The shadow will then be generated just
under the contents of the image but the smoothing
will spread it slightly. This creates a white glow
around objects. You can apply the same filter again
to intensify the glow (reducing Smooth if you wish).

Speed

StarField
Create a starfield with any brush, such as the airbrush, in the current layer.

Starfield filter
Set the Number of stars in your starfield and the
Angle of star rotation in degrees. You set the speed
that the stars fly by on each axis in the SpeedX,
SpeedY, SpeedZ fields. The CenterX and CenterY
fields define the vanishing point for the starfield,
which is the center from which the stars emerge.

Tornado

Speed panel with preview
The Speed filter applies a sliding blur effect to an
image. This effect gives the impression that the image
is moving in a given direction, at a speed that varies
depending on the power of the applied effect.
Use the Direction pop-up menu to change the
direction of the effect.
The Power setting adjusts the intensity of the
effect.
The distance of the blur is controlled by the Begin
setting. Lower values result in less blurring and higher
values result in more.
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Tornado panel with preview
The Tornado filter rotates parts of an image located within a circular area of influence, creating a spiral
or tornado effect. Image areas at the edges of the
effect are rotated less than areas near its center.

The Center X and Center Y values represent the
coordinates for the center of the area of influence.
Radius represents the radius, in pixels, of the area of
influence. Angle determines the amount of rotation
applied. Positive values rotate the image in the counter-clockwise direction, and negative values rotate it
clockwise.
To choose the area of influence graphically, click
the Set area button. Move your pointer over the project window. A crosshair appears. Click on the
desired center point and drag the mouse to set the
radius.
With this filter you can give the image a bizarre
twist with a fairly small angle (less than or equal to
45°), or you can roll it around itself in a wild tornado
(angle exceeding 360°). Try it out on a pretty face.

ripples move out/in from the center. Wave #, which
must be between 0 and 100, defines the number of
waves created.
To choose the area of influence graphically, click
the Set area button. Move your pointer over the project window. A crosshair will appear. Click on the
desired center point and drag the mouse to set the
radius.

Wrapping Grid

Waves

Wrapping panel

Waves panel with preview
The Waves filter generates concentric waves inside
the area of influence. These waves look something like
the circular ripples formed when a pebble hits water.
You can enter the number of waves and their maximum amplitude. The amplitude of the waves is maximum at the center of the area of influence. Amplitude
reduces as distance from the center increases, and
becomes zero at the boundary of the area.
The Center X and Center Y values represent the
position of the center of the area of influence. Radius
represents the radius, in pixels, of the area of influence. Amplitude defines the maximum amplitude
(height) of waves. Position sets the position of the
ripples from the center – animating this makes the

The Wrapping Grid filter warps imagery on the X &
Y axes in the fashion of the proverbial “funhouse mirror.” It may be thought of as a simple morphing application, as well. Pixels are translated spatially and
stretched as necessary to provide the desired effect.
Control for the effect is provided by the use of
control points at the intersections of vectors subdividing the project window. Where the vectors intersect,
control nodes are found. Each of these nodes can be
dragged from its Origin to a new Destination point,
warping the imagery in its area of influence as
required.
The density of the mesh is set using the Num Grid
X and Num Grid Y fields. Changing the values does
not automatically update the mesh, however. To
effect the change after modifying the settings, click
Resize.
To see the mesh and corresponding nodes, click
Edit. Clicking on Origin permits you to move or
group nodes closer to important details in the source
image by dragging with the LMB. Then, clicking on
Destination allows you to drag nodes to desired end
positions. Try it on a buff body.
HINT If Preview is checkmarked, you can
view the results of your Destination node editing as you drag.
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The Current X and Current Y fields display the
exact position of the currently selected control node.
If you wish to restore currently selected nodes to their
original position, click Default.
HINT You can edit the position of several
nodes simultaneously by first multi-selecting
them. To do so, drag out a box surrounding
them with the LMB.
The options available using the Interpolation popup menu include Spline, Linear, and Smooth. These
choices control the type of interpolation applied
between adjacent nodes. If you drag a single node to
a new Destination point, Linear mode warps pixels
between the altered node and it’s immediate neighbors in straight-line fashion. Smooth mode provides a
more rounded warp. Spline mode provides the greatest control over the interpolation, using adjustable
Bezier curves between nodes. When Spline is selected, clicking on a node reveals spline control handles
extending out from it, along the mesh vectors.
Dragging these handles with the LMB gives you the
ability to create very smooth warp effects.
It is important to note that the position of nodes
can be keyframed during an animation. With just a
few seconds work adjusting the keyframes of two
nodes, you could animate the Leaning tower of Pisa
hula dancing!

TRANSITION

options that you set by selecting one of the icons at
the top of the panel.
Using the Transition Filters
You can set up all of the transitions in basically the
same manner.
To set up a transition:
1. Go to the frame where you want the transition
to start.
2. Set the Position field to the amount of transition
you want to start with. Most of the time this will be
0%. A setting of 0% means no change and 100%
means total change.
3. Go to the frame where you want the transition
to end.
4. Set the Position field to the amount of transition
you want to end with. Most of the time this will be
100%.
There may be other keyable parameters, but the
above sets the basic operation of the transition.
5. Select all of the frames over which the transition
occurs and click Apply Filter.
NOTE All of the transition modes on the
Transition filter share the same parameter
keys. So if you set it for one and switch to a
different transition, the keys will still be there.
Also, not all parameters are keyable.

Transition: Wipe Fade

Transition Filter

Example of direction icons for
Transition Filters
The Transition filter features several wipes and
fades, perfect for transitioning from one layer to
another. Essentially, the contents of the current layer
are removed in a definable way to reveal whatever is
underneath. Most of the transitions have directional
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Transition on Fade tab with preview
The Transition Fade filter will dissolve the layer in or
out.

Transition: Wipe1

Transition: Wipe2

Transition on Wipe 2 tab with preview
Transition on Wipe 1 tab with preview

The Transition Wipe I filter simply wipes the layer
on or off using a rectangular shape. You can set a
Border color and its width in pixels. The Soft setting
will soften the edge, including the border, when set
above 0.

The Transition Wipe 2 filter simply wipes the layer
on or off from multiple sides. You can set a Border
color and its width in pixels. The Soft setting will soften the edge, including the border, when set above 0.
The PositionX and PositionY fields define the center
of the effect. You can define the center with your
mouse by clicking Set or you can instantly center by
clicking Center.
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Transition: Turn

Transition: Blind

Crop type

Transition on Turn tab with preview

Blind transitions using a window blind effect. Set
the number of slats using the 3 available Blind fields:
Crop wipes the image on/off without moving the visible pixels; Slide moves the entire image on/off; and
Stretch squeezes/expands the image during the
transition.

Turn transitions using the classic page turn effect.
Activating Gradient uses a gradient of the A and B
colors to fill the underside of the page. If Gradient is
not active, the pixels of the turning page will show
through.

Stretch type
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Slide type

Transition: Block

Transition: Slide

Transition on Slide tab with preview

Transition on Block tab with preview

Slide simply wipes the layer on or off using a rectangular shape. This is similar to the Wipe1 transition,
but differs in the fact that it moves the image on/off.

Block transitions using a building block-like effect.
Block X and Block Y define the number of horizontal
and vertical blocks used. The center direction icon
adds the blocks in random order.
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Transition: Rotary

parency and the position of the incoming video
source. In addition, you can overlay an uncompressed video source as a mask. ( For detailed
instructions, see the tutorial, WipeBuilder.pdf on the
Content CD.

VI FILTERS
The VI filters are third-party plug-in filters for
George Scripts. Each filter has its own documentation that is supplied in its folder with Aura.

VIDEO FILTERS
Fix Motion

Transition on Rotary tab with preview
Rotary wipes the layer on or off in a rotating swipe.
Use the ClockWise option to reverse the direction of
the swipe.

VT Wipe Builder Filter
VT Wipe Builder can be used to create 2D DVEs
that can be used in VT [3]. With this transition compiler, you can construct Wipes by controlling the trans-
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The Fix Motion filter performs two functions: it
applies a vertical smoothing effect on computer
images for use in video, and smoothes images digitized from a video source. It avoids scintillation effects
that can occur when the image is displayed. In video,
an image is displayed in two steps; all even lines are
displayed first, and then all odd lines are displayed.
This is called interlacing.
Under normal circumstances, this interlacing of
even and odd lines is unnoticeable because it is compensated by image smoothing. But when there are
strong contrasts in images (with sudden changes
from black to white), interlacing can cause a scintillation effect characteristic of the video signal.
Computer images, which are usually sharper, tend to
scintillate when they are displayed on a video monitor.
Similarly, digitized video images are often chopped
horizontally when they are displayed on a computer
monitor.
This filter solves these two problems. It does this
by interpolating data for image fields, which gener-

Pattern

Pattern panel with Bars 100 option

Above: Before
Below: After Mix
ates smoothing of the image in the vertical direction
only. A computer image is then more stable when it is
displayed in video and a digitized video image
becomes coherent once again (sometimes at the
expense of more marked smoothing).
The Duplicate Even field option will interpolate the
data for even lines in a field. Duplicate Odd field is
the opposite and interpolates data between odd lines
in a field. You also can choose the Mix mode to
combine the fields.

Use the Pattern filter to generate video test patterns to the current (or selected) frames. Use the
Pattern pop-up menu to select from the available
patterns for the selected standard. Video test patterns are used to maintain video quality; the descriptions below will briefly introduce you to each test pattern and how it is used.
Bars 100 generates a test pattern of eight colors –
white, yellow, cyan, green, magenta, red, blue, and
black – at 100 percent saturation; the bars provide a
color reference.
Bars 75 generates the same test pattern as Bars
100, except at 75 percent color saturation.
Bars + Pluge generates the Bars 75 test pattern
with a pluge pattern, which is used to adjust brightness and contrast in picture monitors.
Bars + Red generates the Bars 75 pattern with a
band of 100 percent red at the bottom; the red signal
is used to test videotapes for dropout and noise.
Bars + SMPTE generates the Bars 75 pattern
with the SMPTE pattern, which is used to adjust
VCRS and picture monitors.
Gray Step 5 and Gray Step 10 generate test patterns of five or ten equal steps of grays; these patterns help test luminance.
Gray Ramp generates a ramp of gray values from
0 to 100 IRE that is used to test luminance. (IRE is a
unit of measurement used to standardize video and
broadcast signals.)
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TimeCode Writer

installed on your system. Size changes the size of
the rectangle and the font size. You enter the screen
coordinates for the TimeCode position in the X and Y
fields.
Font Color applies a color to the TimeCode numbers; you can set an alpha value in the adjacent text
field. A value of 0 is transparent and 255 is opaque.
Back Color sets the TimeCode background color,
and again you can set an alpha value as explained
above.

Video Legalizer

TimeCode Writer from left to right: Current, Free Run
and User
TimeCode writer inserts a rectangle with timecode
over a layer. The rectangle becomes a permanent
piece of the layer, so if you plan to remove it later, you
should place it on its own layer, not in a layer with
paint.
Time Code writer offers three modes: Current,
Free Run, and User. Current applies the timecode
value from the current project; this mode has no settings.
The Free Run mode lets you choose specific project settings. The Grab option grabs the timecode
settings from the project. Then you set the display
Mode, which can be Frame or TimeCode. Frame will
display a count by frame (0, 1, 2, etc.) and TimeCode
uses SMPTE display (00:00:00:24.1).
When you check the Field option, the display
adds a .0 or .1 at the end of the current TimeCode to
indicate the field number. Start Frame defines the
frame where the TimeCode starts. Frame Rate is the
speed of TimeCode measured in frames per second.
Check Reverse to view TimeCode as time remaining
in project.
The User mode lets you set the frames where you
want the TimeCode to begin and end. The display
Mode can be Frame or TimeCode. Frame will display
a count by frame (0, 1, 2, etc.) and TimeCode uses
SMPTE display (00:00:00:24.1). The remaining
options are the same as those for Free Run mode.
The options in the lower part of the panel are available in all three TimeCode modes. When you’ve
made the changes you want, click the Set button.
You can set the TimeCode Font using fonts
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Video Legalizer panel
The Video Legalizer filter scans for pixels with
unsafe values of chrominance signal or composite
signal amplitude when encoded into a color video
signal. Such illegal pixels can be corrected by reducing their Luminance or Saturation (Reduce pop-up
menu). The Composite and Chroma values set the
maximum composite signal and chroma amplitudes,
respectively. The default values, 110 IRE (Composite)
and 50 IRE (Chroma) are the RS-170A video specifications.
You can see what effect the filter will have on the
current frame by activating the Preview button. If you
also activate Mark pixels, the affected pixels will be
shown with 0 opacity and, thus, you will be able to
see the background/layers underneath. This effect is
only for preview purposes and the option has no
effect when the filter is actually applied.
Video Legalizer filters only the current (or selected)
frames in the current layer when applied, so you
should use it only as the final step after you have
merged all layers.

The Waveform filter simulates a composite or component waveform monitor or a vectorscope. The
pop-up menu in the top-left corner sets the type.
This filter interprets the combined layers for the
current frame, so it is unnecessary to merge layers.
You can choose different display options for the
Waveform monitor. For Composite WF, choose to
display the full YC signal (luminance and chrominance, respectively),or just the Y or C portion. For
Component WF, choose between RGB and YUV.
When you set the panel to VectorScope, you
must set the Scale to match the input. Usually, the
input is 75% color bars so scale should be 75% also.
The default Luminosity values for Composite WF,

Component WF and VectorScope are 50, 100 and
100, respectively. This basically allows you to adjust
the intensity of the display.
The Reticule toggle lets you choose whether or
not to render the reticule in your project if you apply
the waveform. The reticule is the graph that measures
the signal, which uses an area chart when you work
with the Waveform, and a circular chart when you
work with a Vectorscope.
The Transparent toggle lets you render the waveform over a transparent background when you select
this option. When you deactivate Transparent, you
render the waveform over a black background.
The Apply button at the bottom of the screen lets
you render the WaveForm monitor in your current
project.

Vectorscope

Component waveform

Waveform

Composite waveform
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Chapter 9:
George Macros
WHAT IS GEORGE?
George is a macro scripting language that you can
use to control Aura. It is an automatic pilot that sends
instructions such as select this function, use this
color, draw this, etc. to Aura. Each instruction corresponds to an Aura function or icon. Everything takes
place as though George was clicking the icon in the
interface for you. Rather than clicking ten or twenty
times on the same button yourself, simply ask
George to do it for you.
You can use existing George scripts or you can
create your own. With George, you can create an infinite number of custom drawing functions and automate the use of Aura. Many example scripts are
included with Aura; these are stored in the George
subdirectory. You can read descriptions for each of
the example George scripts by double-clicking the
script name. A dialog appears that asks you if you
would like to read instructions; select Yes and the
instructions appear on a panel.
The George language is documented in the
Software Developers Kit (SDK) on the Aura CD. The
SDK contains the complete list of current George
commands and examples for how to use them.
Suppose that you wanted to draw a glass ball. To
do this, you would need to cutout a custom brush
(for the reflective surface), set the parameters to apply
this brush in a circle, draw a filled circle (which will be
filled with the brush), adjust opacity mapping parameters to obtain a reflection, select white and redraw the
circle.

The George panel with scripts and associated launching modes
If you had to create only one of these balls, you
could execute the operations manually. However,
what if you needed 10 or 20 glass balls. It would likely get pretty tedious – this is where George comes in.
With the proper program, all you have to do is to
draw a circle to define the contours of the ball and
George will do the rest for you. (What a guy.)
NOTE George programs are basically plain
ASCII text files. You can use any text editing
program (e.g., Microsoft Notepad) to create
and edit them.
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LAUNCHING MODES
Each George program uses a launching mode
indicated by a small icon adjacent to the corresponding line on the George panel. Essentially, the icon
indicates the drawing actions from which the script
derives information.
None mode: You do not need to draw anything
before using this type of George program. The program does not receive any parameters.
Single mode: You draw a dot in the image to
run the program, which receives a character string
containing the word Single, a pair of coordinates (x, y)
and a code identifying which mouse button you
pressed (0 for left and 1 for right). Each parameter in
this string is separated from the previous parameter
by a space.
Continue mode: You draw a freehand line in the
image to run the program. Each time you move the
mouse, the program receives a character string containing the word Continue, a pair of coordinates (x, y)
and the code identifying which button you pressed.
Each parameter in this string is separated from the
previous parameter by a space. The program can
store the coordinates as it receives them, and for
example, may execute them when it detects that you
released the button.
Line mode: You draw a straight line in the image
to run the program. The program receives a character string containing the word Line, two pairs of x and
y coordinates (the start and end of the straight line)
and the code for the button that you pressed. Each
parameter in this string is separated from the previous parameter by a space.
Rectangle mode: You draw a rectangle in the
image to run the program. The program receives a
character string containing the word Rectangle, two
pairs of x and y coordinates (the opposite corners of
the rectangle) and the code for the button that you
pressed. Each parameter in this string is separated
from the previous parameter by a space.
Circle mode: You draw a circle in the image to
run the program. The program receives a character
string containing the word Circle, a pair of x and y
coordinates (the center of the circle), the radius and
the code for the button that you pressed. Each
parameter in this string is separated from the previous parameter by a space.

USING A GEORGE SCRIPT
Choose Windows > George panel from the main
menu to bring up the George panel. On the All tab, a
scrollable list appears of all of the provided George
scripts in your George subdirectory.
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Selecting a George script on the George
panel
NOTE This list is updated each time you start
Aura.
To use a script, simply select it in the window with
your mouse and it is highlighted. The launching mode
icon appears on the right side; the icon indicates
what you must draw to execute the script. For example, if you select a script that shows the Line icon,
just draw a line on your project window. The script
continues executing once you release the mouse button.
Press the Esc key to pause or terminate an executing script.

George Bin
The Bin tab of the George window contains a customizable list of George scripts. You can add and
delete scripts from the list as well as load and save
user-defined groups of scripts.
Click your RMB on the blank area at the bottom of
the list to display a special pop-up menu.
Choose Add to add a script using its filename.
Choose Script to add a script from the list on the All
tab. Choose File > Save to save the group of scripts
on the Bin tab. Choose File > Load to load a previously saved script group. Use this feature to group
programs by function or according to your preferences. (The Default option will load the default group
of scripts called command.agc stored in the Aura
directory, if it exists.)
If you click your RMB directly on an item in the list,
a different menu appears.
Selecting Edit displays the Edit George Script

panel, discussed below. Remove will remove the
item from the list. The File options operate as above.

Panel to edit George script

THE STARTUP SCRIPT
Every time you run Aura, it attempts to execute the
startup.grg program in the George directory, if one
exists. This allows you to customize all working
parameters using a George program (e.g., load a
background image or your personal color palette,
adjust color cycles, the envelope and the power of
the airbrush, or the opacity curve, etc.).

THE GEORGE LANGUAGE
RMB Pop-up on the George panel
The Edit George script panel contains the path
and filename of the file currently associated with the
script line. To change the file, simply edit the input
field. You also can click the Select button and
choose another program using a file requester. By
default, only files with the .grg extension are shown.

If you want, you can write your own scripts or
modify the provided scripts to suit specific needs.
George is a very rich programming language and
even borrows many features from higher level programming languages like C, including loops, conditional tests, and calculations.

Language Conventions
Variables
George manages numeric and character string
variables transparently. You do not need to declare
variable types before using them. Thus you can write:
a=3
MyVariable = “Monday”
Additionally, variable names are not case sensitive.
Thus, George interprets PRINT, Print, PRint and PriNt
as all the same.

RMB Pop-up from the George item list
If the file you chose is a George program, the icon
corresponding to its launching mode is automatically
selected. If it is a system program, you can choose
the appropriate launching mode or you can deselect
all icons to start without a parameter.
Close the panel to return to the George panel. The
selected program name and start mode appear on
the script line.

Reserved Variables
Some variable names are reserved for George.
These variable names may be modified at any time
without warning. You can read these variables to see
what they contain, but it is strongly recommended
that you do not write into them. An example is the
George Result variable that is used in particular to
store the results of Aura commands.
Program Line
You can include only one instruction on any one
line. For example, the following is an example of what
you cannot write:
PRINT “Hello” PRINT “see you tomorrow ..”
Like variable names, instruction and command
names are not case sensitive. Thus, George interprets Tv_AliasOn, tv_aliason and TV_aliasON as all
the same.
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George Instructions
For better readability, George instruction lines can
start with the “#” character. Thus you can write:
#PRINT “hello”
instead of
PRINT “hello”
NOTE Do not confuse lines to be used by
George (which can start with the # character)
and Aura command lines (which all start with
tv_). Lines to be used by George form the
program structure (loops, tests, calculations, etc.),
whereas lines that contain Aura commands affect
Aura panels and screens.
Remarks
Two slashes will remark out whatever follows. This
allows you to add comments to your code.
//PRINT “hello” will not write anything
PRINT “hello” // actually writes “hello”
Arithmetic operators
**
*
/
+
-

negative
exponent
multiplication
division
addition
subtraction

Relational operators
==
!=
>
>=
<
<=

equal to
not equal to
greater than
greater than or equal to
less than
less than or equal to

NOTE Do not confuse the assignment operator = and the comparison operator ==. The
former is used to assign a new value to a variable (like a=a+1) whereas the second is used
to compare two expressions (like a==b) during tests.
NOTE You must use the CMP instruction to
find out if two character strings are identical.
Do not use the equality operator (==).
Logical operators
&&
and
||
or

Character Strings and Tables of
Variable
Character strings
All character (text) strings must be written between
double quotation marks (“) or between single quotation marks (‘). When you want to use either of these
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two quotation characters in a string, you must use
the other quotation character to surround it (for
example, “It’s finished !” or ‘The program name is
“Aura” ‘).
You can process numeric values like string values
in operations such as concatenation (joining several
strings together). For example:
PRINT “The result is “value
Use the CONCAT instruction or the empty character string (“”) if you want to concatenate two strings,
in other words join them together one behind the
other. The following two lines:
CONCAT(string1,string2)
and
string1””string2
produce the same result.
If you want to concatenate these two strings and
separate them by a space, you can write:
string1” “string2
If you want to increment the numeric part of a
character string (for example a file name) you can
write:
FOR i = 1 TO 10
name = base””i// base is the base name
PRINT name // base1, base2, etc.
END
Arrays
You can create variable arrays in George in the
form var[i] or var(i), where i is a numeric value indicating the position of the required element in the table,
and “var” is the generic name of the variables in the
array. There is no need to make a prior declaration for
the dimension (the number of elements) in these
tables because they are created dynamically. These
arrays may contain several dimensions (for example
var[i,j] or var(i,j) for a table with two dimensions).
Example:
day[1] = “Monday”
day[2] = “Tuesday”
day[3] = “Wednesday”
FOR i = 1 TO 3
PRINT day[i] //displays “Monday”,
“Tuesday”, “Wednesday”
END

PROCEDURES
A procedure is an independent part of a program
that is called from the main program and that carries
out some processing on the data in the program. A
procedure can repeat a set of operations without the
need for you to duplicate the corresponding lines in
the program. Simply create a procedure, and then
call it from the main program. Procedures are recursive, so a procedure can call itself.
There is no need to know exactly how a procedure

works. All you need to know is the type of data that it
needs and the type of data that it will return to the
main program.
All procedures must be placed after the end of the
main program, although, their order is not particularly
important. You can use any George instructions and
any Aura commands in a procedure.
Procedure Declaration and Call
Use the FUNCTION instruction to declare a procedure. You must state the name of the procedure and
the names of the variables transferred to the procedure, after the FUNCTION instruction. The procedure
must end with an END instruction. Therefore the general form of a procedure is:
FUNCTION name(var1,var2,…,varN)
(instructions in the procedure)
END
The procedure can access any of the variables
declared in the main program at the time that the
procedure is called. The main program will recognize
any new variable declared in the procedure, after
returning from the procedure. You can also create
variables that will be recognized only in the procedure, by using the LOCAL instruction. Use the
RETURN instruction to return a value to the main program.
Procedure “name” is called from the main program
as follows :
name(var1,var2,…,varN)
The number of variables transferred must be
exactly the same as the number of variables expected by the procedure. If the procedure returns a result,
you can store it in a variable, or test it, and so on.

Procedure Instructions
FUNCTION
Syntax:
FUNCTION Dothis(var1,var2,…,varN)
(instructions)
END
Declare a procedure named Dothis, which expects
variables var1,var2,…,varN. Note that
var1,var2,…,varN are the names by which the
received variables are known in the procedure.
Examples:
FUNCTION Counter(number)
LOCAL I
IF (i > 0)
FOR i = number TO 0 STEP –1
END
RETURN “Countdown finished”
ELSE
RETURN “Countdown impossible”
END
END
Example calls to this procedure from the main program:

PRINT Counter(100)
or
var = 100
a = Counter(var)
PRINT a
RETURN
Syntax: RETURN expression
Returns the value expression to the main program.
This instruction is not compulsory in a procedure.
Examples:
RETURN 0
RETURN “End of procedure”
RETURN var
LOCAL
Syntax: LOCAL var1 var2 … varN
Declares one or several local variables in the procedure. These variables are available (in other words
recognized) only within the procedure. Example:
LOCAL day1 day2
INCLUDE
Syntax: #INCLUDE “file”
Declares a file to be inserted in the current George
program. Example:
#INCLUDE “include\basic.grg”
When the George command interpreter meets a
line containing this command, it replaces it by the
contents of the specified file. This allows you to create function libraries and include them in your George
programs.
To access the specified file, George gives priority
to two search directories: the Aura home directory
(mentioned in the “HomeDir” line in the “Aura2.ini” file)
and the directory containing the George program in
which the INCLUDE instruction was given.
From these base directories you can specify an
access path for the file to be included (for example,
#INCLUDE “library\strfunct\strlib.grg”). If the file to be
included contains procedures (see the FUNCTION
instruction above), you must place the INCLUDE line
after the end of the main program. You will find two
examples of function libraries for the processing of
character strings (“Basic.grg” and “Advanced.grg”) in
the “George\Include” directory of Aura.

GEORGE INSTRUCTIONS AND
AURA COMMANDS
George Instructions are special functions, like
Rnd() and Tan(). Aura commands are the command
lines you use to execute Aura operations. These are
listed and explained in HTML format on the Aura CDROM.
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Appendix
FILE FORMATS
Select a save format for your files using the Mode
pop-up list in the Aura File menu. You can read a
description of how to use this menu in Chapter 2.
This appendix describes the different file formats and
the options available for each of these formats.

Indexed Color Palettes and
Dithering
Some file formats use indexed color palettes
exclusively or offer this option. This means that every
pixel in the image points to a color in a defined set of
colors. The total number of colors can be 256 (8-bit)
or less. (If you could change a color on the palette, all
of the pixels that pointed to it would change.) This
differs from a true color format, where the color for
each pixel is determined independently, usually using
24-bits of information, allowing over 16 million different possible colors. There can be up to four indexed
color options available on the Palette pop-up menu
that appears on many file format mode panels.
Preset uses a pre-defined palette containing different
shades of red, green and blue. User-defined uses
the 256-color palette that is currently on the Bin tab
of the Color Picker panel. Global quantized computes an optimum palette that it uses for all images in
a sequence. (When you save using this option, it may
take a little longer, since the program has to examine

Dithering option on the GIF panel
all the images in the sequence to determine this
palette.) With the Local quantized option (animation
file formats only), Aura uses one palette for each
frame, which can be different.
The Dithering pop-up menu gives you the option of
using the Floyd-Steinberg (error diffusion) or Standard
(available only with Preset Palette) dithering techniques
to give the illusion that there are more than 256 colors
in the image. Choose None to deactivate dithering.
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NOTE As you change the Palette or
Dithering settings, the preview window will
adjust accordingly.
Set Colors to the number of colors you want to
use out of the 256 color palette. It can vary between
16 and 256.

Aura format (.aur)
The Aura format is specific to Aura and there are
no settings for it. It is used only by the project, palette
and mixer files.

AVI format (.avi) (Video for
Windows)

does not affect the animation playback rate). This is
available for codecs that support delta compression.
If you set the value to 10, every tenth frame is stored
in its entirety. Only the changes (i.e., delta) between
frames are stored for other frames. If you do not activate this option, every frame is a key frame.
Data rate sets the maximum allowed data transfer
rate. The quality of the video is automatically adjusted
to achieve the specified data rate.
Configure accesses another dialog box, if any, containing settings specific to the chosen compressor.
Make the desired settings and then click on OK to
save the AVI file.

Cineon (.cin)
The Cineon file format is a 10-bit per channel
logorithmic image format originally designed by the
Eastman Kodak Company for use with its line of film
scanners and recorders.

DEEP format (.dip)
The DEEP format saves an animation or a single
image in 32 bits (16 million colors with 8-bit alphachannel). This is a fast and compact proprietary format specific to Aura. There is no settings panel for
this format.

FLC format (.flc)
System dialog box for Video Compression
The AVI format saves an animation as a single file
or a single image that you can then display afterwards, for example, using the Windows®
Multimedia® player. The number of colors saved
depends on which compression method you use. A
system dialog box appears after you have entered
the file name to be saved.
The Compressor pop-up menu contains the
names of the compression/decompression algorithms
(codecs) currently installed on your system. This will
vary from system to system. Compression is essentially the process of reorganizing and eliminating data
to reduce the required data transfer rate (and file size)
necessary to playback and store video (animations).
NOTE The available options vary depending
on the Compressor selected. As such, some
options on the panel may be ghosted.
Compression Quality determines the final image
quality. A high value provides a better quality image
with less compression, but increases the resulting file
size.
The Key Frame Every option sets the number of
full images that will actually be saved in the file (this

Aura VT Appendix.2

This format is used to save an animation as a single file or a single image in 8 bits (256 colors). See
the previous discussion on Indexed Color Palettes
and Dithering for information on the Palette and
Dithering pop-up menu options.

FLYER CLIP format (.fly)
The Flyer Clip format is used to save an animation
as a single file for use with NewTek’s VideoToaster
Flyer. Generally, your project size should be 752 x
480.

GIF format (.gif)
The GIF format is used to save an animation as a
single file or a single image in up to eight bits (256
colors). See the previous discussion on Indexed Color
Palettes and Dithering for information on the Palette
and Dithering pop-up menu options.
NOTE With this format, Aura defines all transparent areas of the image as using the GIF
transparent color. This is not a variable transparency, but rather a transparency mask (an
area is either completely opaque or completely transparent). When you load a GIF file, Aura will take into
account the transparency color areas, if they exist.

D1 RTV

quality of saved images. As this value increases, file
size increases and image quality improves. This can
be set between 1 and 100.

Options on the RTV panel

Options on the RTV panel.
The DI RTV format is used to save an animation as
a single file for use with NewTek’s VT[3]. Generally,
your project size should be 720 x 486 for NTSC and
720 x 576 for PAL.
If you save RTV files with Save Alpha Channel,
you maintain masking or transparency. Or you can
save without the alpha channel using Normal.
If you save the file with Super Black, it is similar to
saving with an alpha channel. Super Black provides
good hard edges on video elements.

PCX format (.pcx)
The ever-popular PCX format can save a single
image or a sequence of numbered images in 8 bits
(256 colors). See the previous discussion on Indexed
Color Palettes and Dithering for information on the
Palette and Dithering pop-up menu options.

Portable Network Graphics format (.png)

BMP format (.bmp)
The BMP format can save a single image or a
sequence of numbered images in 24 bits (16 million
colors) or 8 bits (256 colors). See the previous discussion on Indexed Color Palettes and Dithering for
information on the Palette and Dithering pop-up
menu options. You will have the additional choice of
using the 24 bits option, which saves images using
over 16 million colors. No dithering options are available with this mode and the number color is fixed at
16M(illion).

ILBM format (.iff)
The ILBM format, standard for the Amiga computer, can save a single image or a sequence of numbered images in 24 bits (16 million colors) or 8 bits
(256 colors). See the previous discussion on Indexed
Color Palettes and Dithering for information on the
Palette and Dithering pop-up menu options. You will
have the additional choice of using the 24 bits
option, which saves images using over 16 million colors. No dithering options are available with this mode
and the number color is fixed at 16M(illion).

JPEG format (.jpg)
The JPEG format saves a single image or a
sequence of numbered images in 24 bits (16 million
colors). Its settings panel contains a single setting,
the JPEG Ratio Quality. This setting affects the

Panel for compression settings for QuickTime
The PNG format saves a single image or a sequence
of numbered images in 8-, 24-, or 32 bits (16 million
colors with 8-bit alpha channel). This format can give
very attractive compression ratios and it is particularly
suitable for images that will be transmitted by network
or modem (Internet, remote update system, etc.). See
the previous discussion on Indexed Color Palettes and
Dithering for information on the Palette and Dithering
pop-up menu options. No dithering options are available for the 24- or 32-bit modes.
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Photoshop format (.psd)
The Photoshop format saves a single image or a
sequence of numbered images in 32 bits (16 million
colors with 8-bit alpha channel). This is the file format
native to Adobe® Photoshop. Layers are preserved
as are their individual opacity settings, if the file is
loaded as a project; otherwise, the layers are
merged. There is no settings panel for this format.
Note that Aura’s PSD format is compatible only with
Photoshop 5.0 and 5.5.

Data rate sets the maximum allowed data transfer
rate. The quality of the video is automatically adjusted
to achieve the specified data rate.
Choose your settings and then click on OK to
save the QuickTime file.

SGI Image format (.rgb)

Quantel® format (.vpb)
The VPB format can save a single image or a
sequence of numbered images in 24 bits (16 million
colors). This file format is native to Quantel® Video
Paintbox®. Aura merges layers when you export as
VPB, however Aura supports VPB with a Stencil
layer. There is no settings panel for this format.

QuickTime format (.mov)
The QuickTime format saves an animation as a
single file or a single image that you can then display
afterwards, using the QuickTime Player. The number
of colors saved depends on which compression
method you use. A system dialog box appears after
you have entered the file name to be saved.
The Compressor drop menu contains the names
of the compression/decompression algorithms
(codecs) currently installed on your system. This will
vary from system to system. Compression is essentially the process of reorganizing and eliminating data
to reduce the required data transfer rate (and file size)
necessary to playback and store video (animations).

Panel for SGI options
The SGI Image format can save a single image or
a sequence of numbered images in 32 bits, RGBA
mode, (16 million colors with alpha-channel) or 24
bits, RGB mode, (16 million colors without alphachannel). Set the Compression pop-up menu to
RLE to use compression when saving the file. Use
None for no compression. You can enter optional
text in the Comment input field, like the author’s
name. SoftImage format (.pic)
The SoftImage format saves a single image or a
sequence of numbered images in 32 bits (16 million
colors with alpha-channel). There is no settings panel
for this format.

Sun Raster format (.ras)

NOTE The available options vary depending
on the Compressor selected. As such, some
options on the panel may be ghosted.
Best Depth specifies the number of colors to use
in the final image. Your options range between Black
and White up to Millions of Colors+.
Quality determines the final image quality. Best
provides a high quality image with less compression,
but increases the resulting file size. While Least gives
a low quality image with high compression, and
therefore a smaller file size.
Under the Motion options, you can set the number
of Frames Per Second, which determines the speed
at which your final animation plays.
The Key Frame Every option sets the number of
full images that will actually be saved in the file (this
does not affect the animation playback rate). This is
available for codecs that support delta compression.
If you set the value to 10, every tenth frame is stored
in its entirety. Only the changes (i.e., delta) between
frames are stored for other frames. If you do not activate this option, every frame is a key frame.
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Panel for Sun Raster options
The Sun Raster format saves a single image or a
sequence of images numbered in 32 bits (16 million
colors with alpha-channel) or 24 bits (16 million colors without alpha-channel).

Targa format (.tga)

Panel for TGA options

The Targa format saves a single image or a
sequence of digitized images in 32 bits (16 million
colors with alpha-channel). Images may or may not
be compressed.

TIFF format (.tif)

NOTE To enable tablet subpixel input, add
this line: Nosubtablet=0. This option does not
work on all computers, it will depend of your
system.
DDrawEmulationOnly=1
This line disables the DirectDraw hardware acceleration. You must use this setting if your graphic card
doesn’t support all DirectDraw acceleration options.
DDrawRgbaOnly=1
This line sets DirectDraw to RGBA mode instead
of YUVA mode. You must use this setting if your
graphic card doesn’t support YUV DirectDraw acceleration. This setting is equal to DirectDraw Use RGB
on the Settings panel.

Panel for TIFF options
The TIFF format saves a single image or a
sequence of images digitized in 32 bits (16 million
colors with alpha channel) or 24 bits (16 million colors
without alpha channel). From the Format pop-up
menu, choose RGB to save in 24 bits or RGBA or
RGB+A to save in 32 bits. With the RGBA option,
the alpha channel data are interlaced with RGB data
in the file. With the RGB+A option, alpha channel
data is stored separately.
From the Compression pop-up menu, choose
LZW or PackBits to compress the file. Select None
for no compression. You can enter optional text in the
Artist input field.

THE AURA VT INITIALIZATION
FILE
A number of default parameters are defined in the
Aura VT configuration file. This file is called AuraVT.ini
and it is located in your main system directory (e.g.,
Windows, Winnt, etc.). It is a plain ASCII text file that
can be edited with any word processor or text editor,
such as the WindowsTM Notepad.
NOTE When you save the configuration file,
make sure that it is an ASCII text file.
Otherwise, Aura will not be able to read it.
All values that you can modify in this file are located in the [STARTUP] section. In the following description, terms between square brackets indicate the
type of values expected for each parameter (the
brackets do not appear in the file). If one of these
lines is missing in the .ini file, Aura will use the default
value for the corresponding parameter.
You may comment out lines by placing a semicolon (;) at the beginning of the line, allowing you to
leave settings for future use.

HomeDir=[directory]
This line indicates the location of the Aura home
directory, in other words, the access path to the
directory containing the executable program. This line
is automatically updated when Aura is installed on
your system. If you move the Aura directory after it is
installed, you will need to modify this line accordingly.
GeorgeDir=[directory]
This line indicates the default directory used to
store George programs. Aura displays the contents of
this directory when you want to select a George program. The default directory is the George subdirectory in the Aura home directory.
Gauge=[0 | 1] Setting this to 0 will suppress the
display of progress gauges.
Last_Config=[configuration file]
This indicates the last configuration file used when
Aura was last run. This entry is updated each time
you run Aura.
PopX=[value] PopY=[value]
These two values define the position of the center
of the menus and windows displayed by Aura. By
default, these windows are centered in the center of
the screen. Use this for dual monitor systems.
HINT For dual monitor setup you can adjust
where the popup menus appear so they are
not sliced in half between the two monitors.
Try adding these lines to the Aura2.ini or
AuraVT.ini file to adjust the position of the pop-ups.
PopX=300 PopY=300 Changing the number,
changes the position of the pop-ups.
ReqFileName=No
By default, the name of the last loaded or saved
file appears in the file selector when you save or load
a file. Add this line into the Aura2.ini file if you want
the Name field in the selector to remain empty.
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INTERNET RESOURCES
In addition to information about NewTek products,
upgrades, and the latest releases of Aura software,
our World Wide Web and FTP sites have various support files and information you may find helpful.
Our web address is http://www.newtek.com and
our FTP address is ftp.newtek.com.
You can also find and exchange information with
the Aura discussion group:
http://vbulletin.newtek.com

TECHNICAL SUPPORT
The best source for help with installing or configuring software or hardware is the retailer from whom
you purchased your NewTek product. While we have
made every effort to keep your software and hardware trouble-free and easy to use, you may occasionally need help right from the source. If you have
problems with NewTek supplied hardware or Aura
doesn’t seem to be functioning as it should, please
contact technical support in one of the following
ways:
• By email: atech@newtek.com
• By fax: (210) 370-8030
• By telephone: (210) 341-8444. Technicians are
available to answer questions from 10:00 AM
to 5:00 PM Central Time, Monday through
Friday
Please supply in your communication or have the
following information handy when calling:
• Your computer’s operating system and version
(e.g., Windows 2000, XP Pro, etc.)
• The version of AuraVT you are using
• The amount of RAM in your computer
• Any relevant specifics about your system (dis
play card type, memory managers, accelerator
type, etc.)
• Your product serial number
NOTE Your product must be registered
before you can receive support.
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